Upstream information

CVE-2015-8027 at MITRE

Description

Node.js 0.12.x before 0.12.9, 4.x before 4.2.3, and 5.x before 5.1.1 does not ensure the availability of a parser for each HTTP socket, which allows remote attackers to cause a denial of service (uncaughtException and service outage) via a pipelined HTTP request.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 956901 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • nodejs >= 4.2.4-9.1
  • nodejs-debuginfo >= 4.2.4-9.1
  • nodejs-debugsource >= 4.2.4-9.1
  • nodejs-devel >= 4.2.4-9.1
  • nodejs-doc >= 4.2.4-9.1
Patchnames:
openSUSE-2016-46
openSUSE Leap 42.1
  • nodejs >= 4.2.4-15.1
  • nodejs-debuginfo >= 4.2.4-15.1
  • nodejs-debugsource >= 4.2.4-15.1
  • nodejs-devel >= 4.2.4-15.1
  • nodejs-doc >= 4.2.4-9.1
  • nodejs-docs >= 4.2.4-15.1
  • npm >= 4.2.4-15.1
Patchnames:
openSUSE-2016-46