Upstream information

CVE-2015-8023 at MITRE

Description

The server implementation of the EAP-MSCHAPv2 protocol in the eap-mschapv2 plugin in strongSwan 4.2.12 through 5.x before 5.3.4 does not properly validate local state, which allows remote attackers to bypass authentication via an empty Success message in response to an initial Challenge message.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 7.5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact None Partial
Integrity Impact Partial Partial
Availability Impact None Partial
SUSE Bugzilla entry: 953817 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • strongswan >= 4.4.0-6.32.1
  • strongswan-doc >= 4.4.0-6.32.1
Patchnames:
sledsp3-strongswan-12246
SUSE Linux Enterprise Desktop 11 SP4
  • strongswan >= 4.4.0-6.32.1
  • strongswan-doc >= 4.4.0-6.32.1
Patchnames:
sledsp4-strongswan-12246
SUSE Linux Enterprise Desktop 12
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-934
SUSE Linux Enterprise Desktop 12 SP1
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2015-934
SUSE Linux Enterprise Desktop 12 SP2
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA strongswan
SUSE Linux Enterprise Desktop 12 SP3
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA strongswan
SUSE Linux Enterprise Module for Basesystem 15
  • strongswan >= 5.6.0-2.43
  • strongswan-doc >= 5.6.0-2.43
  • strongswan-hmac >= 5.6.0-2.43
  • strongswan-ipsec >= 5.6.0-2.43
  • strongswan-libs0 >= 5.6.0-2.43
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA strongswan
SUSE Linux Enterprise Server 11 SP3
  • strongswan >= 4.4.0-6.32.1
  • strongswan-doc >= 4.4.0-6.32.1
Patchnames:
slessp3-strongswan-12246
SUSE Linux Enterprise Server 11 SP4
  • strongswan >= 4.4.0-6.32.1
  • strongswan-doc >= 4.4.0-6.32.1
Patchnames:
slessp4-strongswan-12246
SUSE Linux Enterprise Server 12
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-hmac >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE-SLE-SERVER-12-2015-934
SUSE Linux Enterprise Server 12 SP1
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-hmac >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2015-934
SUSE Linux Enterprise Server 12 SP2
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-hmac >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA strongswan
SUSE Linux Enterprise Server 12 SP3
  • strongswan >= 5.1.3-25.1
  • strongswan-doc >= 5.1.3-25.1
  • strongswan-hmac >= 5.1.3-25.1
  • strongswan-ipsec >= 5.1.3-25.1
  • strongswan-libs0 >= 5.1.3-25.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA strongswan
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-hmac >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA strongswan
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • strongswan >= 4.4.0-6.32.1
  • strongswan-doc >= 4.4.0-6.32.1
Patchnames:
slessp3-strongswan-12246
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • strongswan >= 4.4.0-6.32.1
  • strongswan-doc >= 4.4.0-6.32.1
Patchnames:
slessp4-strongswan-12246
SUSE Linux Enterprise Server for SAP Applications 12
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-hmac >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE-SLE-SERVER-12-2015-934
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • strongswan >= 5.1.3-22.1
  • strongswan-doc >= 5.1.3-22.1
  • strongswan-hmac >= 5.1.3-22.1
  • strongswan-ipsec >= 5.1.3-22.1
  • strongswan-libs0 >= 5.1.3-22.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2015-934
SUSE Linux Enterprise Server for VMWare 11 SP3
  • strongswan >= 4.4.0-6.32.1
  • strongswan-doc >= 4.4.0-6.32.1
Patchnames:
slessp3-strongswan-12246
openSUSE 13.1
  • strongswan >= 5.1.1-14.1
  • strongswan-debugsource >= 5.1.1-14.1
  • strongswan-doc >= 5.1.1-14.1
  • strongswan-ipsec >= 5.1.1-14.1
  • strongswan-ipsec-debuginfo >= 5.1.1-14.1
  • strongswan-libs0 >= 5.1.1-14.1
  • strongswan-libs0-debuginfo >= 5.1.1-14.1
  • strongswan-mysql >= 5.1.1-14.1
  • strongswan-mysql-debuginfo >= 5.1.1-14.1
  • strongswan-nm >= 5.1.1-14.1
  • strongswan-nm-debuginfo >= 5.1.1-14.1
  • strongswan-sqlite >= 5.1.1-14.1
  • strongswan-sqlite-debuginfo >= 5.1.1-14.1
Patchnames:
openSUSE-2015-810
openSUSE Leap 42.1
  • strongswan >= 5.2.2-7.1
  • strongswan-debugsource >= 5.2.2-7.1
  • strongswan-doc >= 5.2.2-7.1
  • strongswan-hmac >= 5.2.2-7.1
  • strongswan-ipsec >= 5.2.2-7.1
  • strongswan-ipsec-debuginfo >= 5.2.2-7.1
  • strongswan-libs0 >= 5.2.2-7.1
  • strongswan-libs0-debuginfo >= 5.2.2-7.1
  • strongswan-mysql >= 5.2.2-7.1
  • strongswan-mysql-debuginfo >= 5.2.2-7.1
  • strongswan-nm >= 5.2.2-7.1
  • strongswan-nm-debuginfo >= 5.2.2-7.1
  • strongswan-sqlite >= 5.2.2-7.1
  • strongswan-sqlite-debuginfo >= 5.2.2-7.1
Patchnames:
openSUSE-2015-810
openSUSE Tumbleweed
  • strongswan >= 5.3.5-1.1
  • strongswan-doc >= 5.3.5-1.1
  • strongswan-hmac >= 5.3.5-1.1
  • strongswan-ipsec >= 5.3.5-1.1
  • strongswan-libs0 >= 5.3.5-1.1
  • strongswan-mysql >= 5.3.5-1.1
  • strongswan-nm >= 5.3.5-1.1
  • strongswan-sqlite >= 5.3.5-1.1
Patchnames:
openSUSE Tumbleweed GA strongswan


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 strongswan Released
SUSE Linux Enterprise Desktop 11 SP3 strongswan Released
SUSE Linux Enterprise Desktop 11 SP4 strongswan Released
SUSE Linux Enterprise Desktop 12 GA strongswan Released
SUSE Linux Enterprise Desktop 12 SP1 strongswan Released
SUSE Linux Enterprise Server 11 SP1 LTSS strongswan Released
SUSE Linux Enterprise Server 11 SP2 strongswan Released
SUSE Linux Enterprise Server 11 SP2 LTSS strongswan Released
SUSE Linux Enterprise Server 11 SP3 strongswan Released
SUSE Linux Enterprise Server 11 SP4 strongswan Released
SUSE Linux Enterprise Server 12 GA strongswan Released
SUSE Linux Enterprise Server 12 SP1 strongswan Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 strongswan Released
SUSE Linux Enterprise Server for VMWare 11 SP2 strongswan Released
SUSE Linux Enterprise Server for VMWare 11 SP3 strongswan Released