Upstream information

CVE-2015-7700 at MITRE

Description

Double-free vulnerability in the sPLT chunk structure and png.c in pngcrush before 1.7.87 allows attackers to have unspecified impact via unknown vectors.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 1056770 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • pngcrush >= 1.7.85-5.3.1
  • pngcrush-debuginfo >= 1.7.85-5.3.1
  • pngcrush-debugsource >= 1.7.85-5.3.1
Patchnames:
openSUSE-2018-43
openSUSE Leap 42.3
  • pngcrush >= 1.7.85-8.1
  • pngcrush-debuginfo >= 1.7.85-8.1
  • pngcrush-debugsource >= 1.7.85-8.1
Patchnames:
openSUSE-2018-43
openSUSE Tumbleweed
  • pngcrush >= 1.7.92-1.5
Patchnames:
openSUSE Tumbleweed GA pngcrush