Upstream information

CVE-2015-7555 at MITRE

Description

Heap-based buffer overflow in giffix.c in giffix in giflib 5.1.1 allows attackers to cause a denial of service (program crash) via crafted image and logical screen width fields in a GIF file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 5.1
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium High
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Partial
SUSE Bugzilla entry: 960319 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • giflib >= 4.1.6-13.1
  • giflib-32bit >= 4.1.6-13.1
Patchnames:
sledsp3-giflib-12353
SUSE Linux Enterprise Desktop 11 SP4
  • giflib >= 4.1.6-13.1
  • giflib-32bit >= 4.1.6-13.1
Patchnames:
sledsp4-giflib-12353
SUSE Linux Enterprise Desktop 12
  • giflib >= 5.0.5-7.1
  • libgif6 >= 5.0.5-7.1
  • libgif6-32bit >= 5.0.5-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-136
SUSE Linux Enterprise Desktop 12 SP1
  • giflib >= 5.0.5-7.1
  • libgif6 >= 5.0.5-7.1
  • libgif6-32bit >= 5.0.5-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-136
SUSE Linux Enterprise Desktop 12 SP2
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libgif6-32bit
SUSE Linux Enterprise Desktop 12 SP3
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libgif6-32bit
SUSE Linux Enterprise Module for Basesystem 15
  • giflib-devel >= 5.1.4-2.19
  • libgif7 >= 5.1.4-2.19
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA giflib-devel
SUSE Linux Enterprise Server 11 SP3
  • giflib >= 4.1.6-13.1
  • giflib-32bit >= 4.1.6-13.1
  • giflib-progs >= 4.1.6-13.1
  • giflib-x86 >= 4.1.6-13.1
Patchnames:
slessp3-giflib-12353
SUSE Linux Enterprise Server 11 SP4
  • giflib >= 4.1.6-13.1
  • giflib-32bit >= 4.1.6-13.1
  • giflib-progs >= 4.1.6-13.1
  • giflib-x86 >= 4.1.6-13.1
Patchnames:
slessp4-giflib-12353
SUSE Linux Enterprise Server 12
  • giflib >= 5.0.5-7.1
  • giflib-progs >= 5.0.5-7.1
  • libgif6 >= 5.0.5-7.1
  • libgif6-32bit >= 5.0.5-7.1
Patchnames:
SUSE-SLE-SERVER-12-2016-136
SUSE Linux Enterprise Server 12 SP1
  • giflib >= 5.0.5-7.1
  • giflib-progs >= 5.0.5-7.1
  • libgif6 >= 5.0.5-7.1
  • libgif6-32bit >= 5.0.5-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-136
SUSE Linux Enterprise Server 12 SP2
  • giflib-progs >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA giflib-progs
SUSE Linux Enterprise Server 12 SP3
  • giflib-progs >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
  • libgif6-32bit >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA giflib-progs
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • giflib-progs >= 5.0.5-12.1
  • libgif6 >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA giflib-progs
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • giflib >= 4.1.6-13.1
  • giflib-32bit >= 4.1.6-13.1
  • giflib-progs >= 4.1.6-13.1
  • giflib-x86 >= 4.1.6-13.1
Patchnames:
slessp3-giflib-12353
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • giflib >= 4.1.6-13.1
  • giflib-32bit >= 4.1.6-13.1
  • giflib-progs >= 4.1.6-13.1
  • giflib-x86 >= 4.1.6-13.1
Patchnames:
slessp4-giflib-12353
SUSE Linux Enterprise Server for SAP Applications 12
  • giflib >= 5.0.5-7.1
  • giflib-progs >= 5.0.5-7.1
  • libgif6 >= 5.0.5-7.1
  • libgif6-32bit >= 5.0.5-7.1
Patchnames:
SUSE-SLE-SERVER-12-2016-136
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • giflib >= 5.0.5-7.1
  • giflib-progs >= 5.0.5-7.1
  • libgif6 >= 5.0.5-7.1
  • libgif6-32bit >= 5.0.5-7.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-136
SUSE Linux Enterprise Server for VMWare 11 SP3
  • giflib >= 4.1.6-13.1
  • giflib-32bit >= 4.1.6-13.1
  • giflib-progs >= 4.1.6-13.1
  • giflib-x86 >= 4.1.6-13.1
Patchnames:
slessp3-giflib-12353
SUSE Linux Enterprise Software Development Kit 11 SP3
  • giflib >= 4.1.6-13.1
  • giflib-devel >= 4.1.6-13.1
  • giflib-devel-32bit >= 4.1.6-13.1
Patchnames:
sdksp3-giflib-12353
SUSE Linux Enterprise Software Development Kit 11 SP4
  • giflib >= 4.1.6-13.1
  • giflib-devel >= 4.1.6-13.1
  • giflib-devel-32bit >= 4.1.6-13.1
Patchnames:
sdksp4-giflib-12353
SUSE Linux Enterprise Software Development Kit 12
  • giflib >= 5.0.5-7.1
  • giflib-devel >= 5.0.5-7.1
Patchnames:
SUSE-SLE-SDK-12-2016-136
SUSE Linux Enterprise Software Development Kit 12 SP1
  • giflib >= 5.0.5-7.1
  • giflib-devel >= 5.0.5-7.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-136
SUSE Linux Enterprise Software Development Kit 12 SP2
  • giflib-devel >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA giflib-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • giflib-devel >= 5.0.5-12.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA giflib-devel
openSUSE 13.1
  • giflib >= 5.0.5-2.3.1
  • giflib-debugsource >= 5.0.5-2.3.1
  • giflib-devel >= 5.0.5-2.3.1
  • giflib-devel-32bit >= 5.0.5-2.3.1
  • giflib-progs >= 5.0.5-2.3.1
  • giflib-progs-debuginfo >= 5.0.5-2.3.1
  • libgif6 >= 5.0.5-2.3.1
  • libgif6-32bit >= 5.0.5-2.3.1
  • libgif6-debuginfo >= 5.0.5-2.3.1
  • libgif6-debuginfo-32bit >= 5.0.5-2.3.1
Patchnames:
2016-76
openSUSE Leap 15.0
  • libgif7 >= 5.1.4-lp150.2.5
Patchnames:
openSUSE Leap 15.0 GA libgif7
openSUSE Leap 42.1
  • giflib >= 5.0.5-7.1
  • giflib-debugsource >= 5.0.5-7.1
  • giflib-devel >= 5.0.5-7.1
  • giflib-devel-32bit >= 5.0.5-7.1
  • giflib-progs >= 5.0.5-7.1
  • giflib-progs-debuginfo >= 5.0.5-7.1
  • libgif6 >= 5.0.5-7.1
  • libgif6-32bit >= 5.0.5-7.1
  • libgif6-debuginfo >= 5.0.5-7.1
  • libgif6-debuginfo-32bit >= 5.0.5-7.1
Patchnames:
openSUSE-2016-118
openSUSE Leap 42.2
  • giflib-devel >= 5.0.5-11.1
  • libgif6 >= 5.0.5-11.1
Patchnames:
openSUSE Leap 42.2 GA giflib-devel
openSUSE Leap 42.3
  • giflib-devel >= 5.0.5-13.13
  • libgif6 >= 5.0.5-13.13
Patchnames:
openSUSE Leap 42.3 GA giflib-devel
openSUSE Tumbleweed
  • giflib-devel >= 5.1.4-1.12
  • giflib-devel-32bit >= 5.1.4-1.12
  • giflib-progs >= 5.1.4-1.12
  • libgif7 >= 5.1.4-1.12
  • libgif7-32bit >= 5.1.4-1.12
Patchnames:
openSUSE Tumbleweed GA giflib-devel-32bit


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 giflib Released
SUSE Linux Enterprise Desktop 11 SP2 giflib Released
SUSE Linux Enterprise Desktop 11 SP3 giflib Released
SUSE Linux Enterprise Desktop 11 SP4 giflib Released
SUSE Linux Enterprise Desktop 12 GA giflib Released
SUSE Linux Enterprise Desktop 12 SP1 giflib Released
SUSE Linux Enterprise SDK 11 SP2 giflib Released
SUSE Linux Enterprise SDK 11 SP3 giflib Released
SUSE Linux Enterprise SDK 11 SP4 giflib Released
SUSE Linux Enterprise SDK 12 GA giflib Released
SUSE Linux Enterprise SDK 12 SP1 giflib Released
SUSE Linux Enterprise Server 10 SP4 LTSS giflib Released
SUSE Linux Enterprise Server 11 SP1 LTSS giflib Released
SUSE Linux Enterprise Server 11 SP2 giflib Released
SUSE Linux Enterprise Server 11 SP2 LTSS giflib Released
SUSE Linux Enterprise Server 11 SP3 giflib Released
SUSE Linux Enterprise Server 11 SP4 giflib Released
SUSE Linux Enterprise Server 12 GA giflib Released
SUSE Linux Enterprise Server 12 SP1 giflib Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 giflib Released
SUSE Linux Enterprise Server for VMWare 11 SP2 giflib Released
SUSE Linux Enterprise Server for VMWare 11 SP3 giflib Released