Upstream information

CVE-2015-7547 at MITRE

Description

Multiple stack-based buffer overflows in the (1) send_dg and (2) send_vc functions in the libresolv library in the GNU C Library (aka glibc or libc6) before 2.23 allow remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted DNS response that triggers a call to the getaddrinfo function with the AF_UNSPEC or AF_INET6 address family, related to performing "dual A/AAAA DNS queries" and the libnss_dns.so.2 NSS module.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.82 5.76
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial None

Note from the SUSE Security Team

This vulnerability was introduced in glibc 2.9. SUSE Linux Enterprise 10 and older products are not affected.

SUSE Bugzilla entries: 847227 [RESOLVED / FIXED], 961721 [RESOLVED / FIXED], 967023 [RESOLVED / FIXED], 967061 [RESOLVED / FIXED], 967072 [RESOLVED / FIXED], 967496 [CONFIRMED], 969216 [RESOLVED / DUPLICATE], 969241 [RESOLVED / WONTFIX], 986086 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • glibc >= 2.11.3-17.95.2
  • glibc-32bit >= 2.11.3-17.95.2
  • glibc-devel >= 2.11.3-17.95.2
  • glibc-devel-32bit >= 2.11.3-17.95.2
  • glibc-i18ndata >= 2.11.3-17.95.2
  • glibc-locale >= 2.11.3-17.95.2
  • glibc-locale-32bit >= 2.11.3-17.95.2
  • nscd >= 2.11.3-17.95.2
Patchnames:
sledsp3-glibc-12406
SUSE Linux Enterprise Desktop 11 SP4
  • glibc >= 2.11.3-17.95.2
  • glibc-32bit >= 2.11.3-17.95.2
  • glibc-devel >= 2.11.3-17.95.2
  • glibc-devel-32bit >= 2.11.3-17.95.2
  • glibc-i18ndata >= 2.11.3-17.95.2
  • glibc-locale >= 2.11.3-17.95.2
  • glibc-locale-32bit >= 2.11.3-17.95.2
  • nscd >= 2.11.3-17.95.2
Patchnames:
sledsp4-glibc-12406
SUSE Linux Enterprise Desktop 12
  • glibc >= 2.19-22.13.1
  • glibc-32bit >= 2.19-22.13.1
  • glibc-devel >= 2.19-22.13.1
  • glibc-devel-32bit >= 2.19-22.13.1
  • glibc-i18ndata >= 2.19-22.13.1
  • glibc-locale >= 2.19-22.13.1
  • glibc-locale-32bit >= 2.19-22.13.1
  • nscd >= 2.19-22.13.1
Patchnames:
SUSE-SLE-DESKTOP-12-2016-272
SUSE Linux Enterprise Desktop 12 SP1
  • glibc >= 2.19-35.1
  • glibc-32bit >= 2.19-35.1
  • glibc-devel >= 2.19-35.1
  • glibc-devel-32bit >= 2.19-35.1
  • glibc-i18ndata >= 2.19-35.1
  • glibc-locale >= 2.19-35.1
  • glibc-locale-32bit >= 2.19-35.1
  • nscd >= 2.19-35.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2016-271
SUSE Linux Enterprise Desktop 12 SP2
  • glibc >= 2.22-49.16
  • glibc-32bit >= 2.22-49.16
  • glibc-devel >= 2.22-49.16
  • glibc-devel-32bit >= 2.22-49.16
  • glibc-i18ndata >= 2.22-49.16
  • glibc-locale >= 2.22-49.16
  • glibc-locale-32bit >= 2.22-49.16
  • nscd >= 2.22-49.16
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA glibc
SUSE Linux Enterprise Module for Containers 12
  • sles11sp4-docker-image >= 1.1.1-20160304104123
  • sles12-docker-image >= 1.1.1-20160307082632
  • sles12sp1-docker-image >= 1.0.4-20160308170633
Patchnames:
SUSE-SLE-Module-Containers-12-2016-440
SUSE-SLE-Module-Containers-12-2016-457
SUSE-SLE-Module-Containers-12-2016-459
SUSE Linux Enterprise Server 11 SP2-LTSS
  • glibc >= 2.11.3-17.45.66.1
  • glibc-32bit >= 2.11.3-17.45.66.1
  • glibc-devel >= 2.11.3-17.45.66.1
  • glibc-devel-32bit >= 2.11.3-17.45.66.1
  • glibc-html >= 2.11.3-17.45.66.1
  • glibc-i18ndata >= 2.11.3-17.45.66.1
  • glibc-info >= 2.11.3-17.45.66.1
  • glibc-locale >= 2.11.3-17.45.66.1
  • glibc-locale-32bit >= 2.11.3-17.45.66.1
  • glibc-profile >= 2.11.3-17.45.66.1
  • glibc-profile-32bit >= 2.11.3-17.45.66.1
  • nscd >= 2.11.3-17.45.66.1
Patchnames:
slessp2-glibc-12405
SUSE Linux Enterprise Server 11 SP3
  • glibc >= 2.11.3-17.95.2
  • glibc-32bit >= 2.11.3-17.95.2
  • glibc-devel >= 2.11.3-17.95.2
  • glibc-devel-32bit >= 2.11.3-17.95.2
  • glibc-html >= 2.11.3-17.95.2
  • glibc-i18ndata >= 2.11.3-17.95.2
  • glibc-info >= 2.11.3-17.95.2
  • glibc-locale >= 2.11.3-17.95.2
  • glibc-locale-32bit >= 2.11.3-17.95.2
  • glibc-locale-x86 >= 2.11.3-17.95.2
  • glibc-profile >= 2.11.3-17.95.2
  • glibc-profile-32bit >= 2.11.3-17.95.2
  • glibc-profile-x86 >= 2.11.3-17.95.2
  • glibc-x86 >= 2.11.3-17.95.2
  • nscd >= 2.11.3-17.95.2
Patchnames:
slessp3-glibc-12406
SUSE Linux Enterprise Server 11 SP4
  • glibc >= 2.11.3-17.95.2
  • glibc-32bit >= 2.11.3-17.95.2
  • glibc-devel >= 2.11.3-17.95.2
  • glibc-devel-32bit >= 2.11.3-17.95.2
  • glibc-html >= 2.11.3-17.95.2
  • glibc-i18ndata >= 2.11.3-17.95.2
  • glibc-info >= 2.11.3-17.95.2
  • glibc-locale >= 2.11.3-17.95.2
  • glibc-locale-32bit >= 2.11.3-17.95.2
  • glibc-locale-x86 >= 2.11.3-17.95.2
  • glibc-profile >= 2.11.3-17.95.2
  • glibc-profile-32bit >= 2.11.3-17.95.2
  • glibc-profile-x86 >= 2.11.3-17.95.2
  • glibc-x86 >= 2.11.3-17.95.2
  • nscd >= 2.11.3-17.95.2
Patchnames:
slessp4-glibc-12406
SUSE Linux Enterprise Server 12
  • glibc >= 2.19-22.13.1
  • glibc-32bit >= 2.19-22.13.1
  • glibc-devel >= 2.19-22.13.1
  • glibc-devel-32bit >= 2.19-22.13.1
  • glibc-html >= 2.19-22.13.1
  • glibc-i18ndata >= 2.19-22.13.1
  • glibc-info >= 2.19-22.13.1
  • glibc-locale >= 2.19-22.13.1
  • glibc-locale-32bit >= 2.19-22.13.1
  • glibc-profile >= 2.19-22.13.1
  • glibc-profile-32bit >= 2.19-22.13.1
  • nscd >= 2.19-22.13.1
Patchnames:
SUSE-SLE-SERVER-12-2016-272
SUSE Linux Enterprise Server 12 SP1
  • glibc >= 2.19-35.1
  • glibc-32bit >= 2.19-35.1
  • glibc-devel >= 2.19-35.1
  • glibc-devel-32bit >= 2.19-35.1
  • glibc-html >= 2.19-35.1
  • glibc-i18ndata >= 2.19-35.1
  • glibc-info >= 2.19-35.1
  • glibc-locale >= 2.19-35.1
  • glibc-locale-32bit >= 2.19-35.1
  • glibc-profile >= 2.19-35.1
  • glibc-profile-32bit >= 2.19-35.1
  • nscd >= 2.19-35.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2016-271
SUSE Linux Enterprise Server 12 SP2
  • glibc >= 2.22-49.16
  • glibc-32bit >= 2.22-49.16
  • glibc-devel >= 2.22-49.16
  • glibc-devel-32bit >= 2.22-49.16
  • glibc-html >= 2.22-49.16
  • glibc-i18ndata >= 2.22-49.16
  • glibc-info >= 2.22-49.16
  • glibc-locale >= 2.22-49.16
  • glibc-locale-32bit >= 2.22-49.16
  • glibc-profile >= 2.22-49.16
  • glibc-profile-32bit >= 2.22-49.16
  • nscd >= 2.22-49.16
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA glibc
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • glibc >= 2.22-49.16
  • glibc-devel >= 2.22-49.16
  • glibc-html >= 2.22-49.16
  • glibc-i18ndata >= 2.22-49.16
  • glibc-info >= 2.22-49.16
  • glibc-locale >= 2.22-49.16
  • glibc-profile >= 2.22-49.16
  • nscd >= 2.22-49.16
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA glibc
SUSE Linux Enterprise Server for VMWare 11 SP3
  • glibc >= 2.11.3-17.95.2
  • glibc-32bit >= 2.11.3-17.95.2
  • glibc-devel >= 2.11.3-17.95.2
  • glibc-devel-32bit >= 2.11.3-17.95.2
  • glibc-html >= 2.11.3-17.95.2
  • glibc-i18ndata >= 2.11.3-17.95.2
  • glibc-info >= 2.11.3-17.95.2
  • glibc-locale >= 2.11.3-17.95.2
  • glibc-locale-32bit >= 2.11.3-17.95.2
  • glibc-locale-x86 >= 2.11.3-17.95.2
  • glibc-profile >= 2.11.3-17.95.2
  • glibc-profile-32bit >= 2.11.3-17.95.2
  • glibc-profile-x86 >= 2.11.3-17.95.2
  • glibc-x86 >= 2.11.3-17.95.2
  • nscd >= 2.11.3-17.95.2
Patchnames:
slessp3-glibc-12406
SUSE Linux Enterprise Software Development Kit 11 SP3
  • glibc >= 2.11.3-17.95.2
  • glibc-html >= 2.11.3-17.95.2
  • glibc-info >= 2.11.3-17.95.2
Patchnames:
sdksp3-glibc-12406
SUSE Linux Enterprise Software Development Kit 11 SP4
  • glibc >= 2.11.3-17.95.2
  • glibc-html >= 2.11.3-17.95.2
  • glibc-info >= 2.11.3-17.95.2
Patchnames:
sdksp4-glibc-12406
SUSE Linux Enterprise Software Development Kit 12
  • glibc >= 2.19-22.13.1
  • glibc-devel-static >= 2.19-22.13.1
Patchnames:
SUSE-SLE-SDK-12-2016-272
SUSE Linux Enterprise Software Development Kit 12 SP1
  • glibc >= 2.19-35.1
  • glibc-devel-static >= 2.19-35.1
  • glibc-info >= 2.19-35.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2016-271
SUSE Linux Enterprise Software Development Kit 12 SP2
  • glibc-devel-static >= 2.22-49.16
  • glibc-info >= 2.22-49.16
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA glibc-devel-static
openSUSE 13.2
  • glibc >= 2.19-16.22.2
  • glibc-32bit >= 2.19-16.22.2
  • glibc-debuginfo >= 2.19-16.22.2
  • glibc-debuginfo-32bit >= 2.19-16.22.2
  • glibc-debugsource >= 2.19-16.22.2
  • glibc-devel >= 2.19-16.22.2
  • glibc-devel-32bit >= 2.19-16.22.2
  • glibc-devel-debuginfo >= 2.19-16.22.2
  • glibc-devel-debuginfo-32bit >= 2.19-16.22.2
  • glibc-devel-static >= 2.19-16.22.2
  • glibc-devel-static-32bit >= 2.19-16.22.2
  • glibc-extra >= 2.19-16.22.2
  • glibc-extra-debuginfo >= 2.19-16.22.2
  • glibc-html >= 2.19-16.22.2
  • glibc-i18ndata >= 2.19-16.22.2
  • glibc-info >= 2.19-16.22.2
  • glibc-locale >= 2.19-16.22.2
  • glibc-locale-32bit >= 2.19-16.22.2
  • glibc-locale-debuginfo >= 2.19-16.22.2
  • glibc-locale-debuginfo-32bit >= 2.19-16.22.2
  • glibc-obsolete >= 2.19-16.22.2
  • glibc-obsolete-debuginfo >= 2.19-16.22.2
  • glibc-profile >= 2.19-16.22.2
  • glibc-profile-32bit >= 2.19-16.22.2
  • glibc-testsuite >= 2.19-16.22.4
  • glibc-utils >= 2.19-16.22.2
  • glibc-utils-32bit >= 2.19-16.22.2
  • glibc-utils-debuginfo >= 2.19-16.22.2
  • glibc-utils-debuginfo-32bit >= 2.19-16.22.2
  • glibc-utils-debugsource >= 2.19-16.22.2
  • nscd >= 2.19-16.22.2
  • nscd-debuginfo >= 2.19-16.22.2
Patchnames:
openSUSE-2016-233
openSUSE Evergreen 11.4
  • glibc >= 2.11.3-69.2
  • glibc-32bit >= 2.11.3-69.1
  • glibc-debuginfo >= 2.11.3-69.2
  • glibc-debuginfo-32bit >= 2.11.3-69.1
  • glibc-debuginfo-x86 >= 2.11.3-69.1
  • glibc-debugsource >= 2.11.3-69.2
  • glibc-devel >= 2.11.3-69.2
  • glibc-devel-32bit >= 2.11.3-69.1
  • glibc-devel-debuginfo >= 2.11.3-69.2
  • glibc-devel-debuginfo-32bit >= 2.11.3-69.1
  • glibc-devel-debuginfo-x86 >= 2.11.3-69.1
  • glibc-html >= 2.11.3-69.2
  • glibc-i18ndata >= 2.11.3-69.2
  • glibc-info >= 2.11.3-69.2
  • glibc-locale >= 2.11.3-69.2
  • glibc-locale-32bit >= 2.11.3-69.1
  • glibc-locale-debuginfo >= 2.11.3-69.2
  • glibc-locale-debuginfo-32bit >= 2.11.3-69.1
  • glibc-locale-debuginfo-x86 >= 2.11.3-69.1
  • glibc-locale-x86 >= 2.11.3-69.1
  • glibc-obsolete >= 2.11.3-69.2
  • glibc-obsolete-debuginfo >= 2.11.3-69.2
  • glibc-profile >= 2.11.3-69.2
  • glibc-profile-32bit >= 2.11.3-69.1
  • glibc-profile-x86 >= 2.11.3-69.1
  • glibc-x86 >= 2.11.3-69.1
  • nscd >= 2.11.3-69.2
  • nscd-debuginfo >= 2.11.3-69.2
Patchnames:
2016-234
openSUSE Leap 42.1
  • glibc >= 2.19-19.1
  • glibc-32bit >= 2.19-19.1
  • glibc-debuginfo >= 2.19-19.1
  • glibc-debuginfo-32bit >= 2.19-19.1
  • glibc-debugsource >= 2.19-19.1
  • glibc-devel >= 2.19-19.1
  • glibc-devel-32bit >= 2.19-19.1
  • glibc-devel-debuginfo >= 2.19-19.1
  • glibc-devel-debuginfo-32bit >= 2.19-19.1
  • glibc-devel-static >= 2.19-19.1
  • glibc-devel-static-32bit >= 2.19-19.1
  • glibc-extra >= 2.19-19.1
  • glibc-extra-debuginfo >= 2.19-19.1
  • glibc-html >= 2.19-19.1
  • glibc-i18ndata >= 2.19-19.1
  • glibc-info >= 2.19-19.1
  • glibc-locale >= 2.19-19.1
  • glibc-locale-32bit >= 2.19-19.1
  • glibc-locale-debuginfo >= 2.19-19.1
  • glibc-locale-debuginfo-32bit >= 2.19-19.1
  • glibc-obsolete >= 2.19-19.1
  • glibc-obsolete-debuginfo >= 2.19-19.1
  • glibc-profile >= 2.19-19.1
  • glibc-profile-32bit >= 2.19-19.1
  • glibc-testsuite >= 2.19-19.2
  • glibc-utils >= 2.19-19.1
  • glibc-utils-32bit >= 2.19-19.1
  • glibc-utils-debuginfo >= 2.19-19.1
  • glibc-utils-debuginfo-32bit >= 2.19-19.1
  • glibc-utils-debugsource >= 2.19-19.1
  • nscd >= 2.19-19.1
  • nscd-debuginfo >= 2.19-19.1
Patchnames:
openSUSE-2016-224
openSUSE Leap 42.2
  • glibc >= 2.22-3.7
  • glibc-32bit >= 2.22-3.7
  • glibc-devel >= 2.22-3.7
  • glibc-extra >= 2.22-3.7
  • glibc-info >= 2.22-3.7
  • glibc-locale >= 2.22-3.7
  • glibc-locale-32bit >= 2.22-3.7
  • nscd >= 2.22-3.7
Patchnames:
openSUSE Leap 42.2 GA glibc
openSUSE Tumbleweed
  • glibc >= 2.24-2.3
  • glibc-32bit >= 2.24-2.3
  • glibc-devel >= 2.24-2.3
  • glibc-devel-32bit >= 2.24-2.3
  • glibc-devel-static >= 2.24-2.3
  • glibc-devel-static-32bit >= 2.24-2.3
  • glibc-extra >= 2.24-2.3
  • glibc-html >= 2.24-2.3
  • glibc-i18ndata >= 2.24-2.3
  • glibc-info >= 2.24-2.3
  • glibc-locale >= 2.24-2.3
  • glibc-locale-32bit >= 2.24-2.3
  • glibc-obsolete >= 2.24-2.3
  • glibc-profile >= 2.24-2.3
  • glibc-profile-32bit >= 2.24-2.3
  • glibc-utils >= 2.24-2.3
  • glibc-utils-32bit >= 2.24-2.3
  • nscd >= 2.24-2.3
Patchnames:
openSUSE Tumbleweed GA glibc