Upstream information

CVE-2015-7545 at MITRE

Description

The (1) git-remote-ext and (2) unspecified other remote helper programs in Git before 2.3.10, 2.4.x before 2.4.10, 2.5.x before 2.5.4, and 2.6.x before 2.6.1 do not properly restrict the allowed protocols, which might allow remote attackers to execute arbitrary code via a URL in a (a) .gitmodules file or (b) unknown other sources in a submodule.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial

Note from the SUSE Security Team

Updates for this git issue have been released already, without CVE number, but with bug number 948969 referenced.

SUSE Bugzilla entries: 948969 [RESOLVED / FIXED], 973177 [RESOLVED / FIXED], 978391 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Development Tools 15
  • mercurial >= 4.5.2-1.19
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA mercurial
SUSE Linux Enterprise Server 12
  • git >= 1.8.5.6-15.1
  • git-core >= 1.8.5.6-15.1
Patchnames:
SUSE-SLE-SERVER-12-2015-857
SUSE Linux Enterprise Server 12 SP1
  • git >= 1.8.5.6-15.1
  • git-core >= 1.8.5.6-15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2015-857
SUSE Linux Enterprise Server for SAP Applications 12
  • git >= 1.8.5.6-15.1
  • git-core >= 1.8.5.6-15.1
Patchnames:
SUSE-SLE-SERVER-12-2015-857
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • git >= 1.8.5.6-15.1
  • git-core >= 1.8.5.6-15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2015-857
SUSE Linux Enterprise Software Development Kit 12
  • git >= 1.8.5.6-15.1
  • git-arch >= 1.8.5.6-15.1
  • git-core >= 1.8.5.6-15.1
  • git-cvs >= 1.8.5.6-15.1
  • git-daemon >= 1.8.5.6-15.1
  • git-email >= 1.8.5.6-15.1
  • git-gui >= 1.8.5.6-15.1
  • git-svn >= 1.8.5.6-15.1
  • git-web >= 1.8.5.6-15.1
  • gitk >= 1.8.5.6-15.1
Patchnames:
SUSE-SLE-SDK-12-2015-857
SUSE Linux Enterprise Software Development Kit 12 SP1
  • git >= 1.8.5.6-15.1
  • git-arch >= 1.8.5.6-15.1
  • git-core >= 1.8.5.6-15.1
  • git-cvs >= 1.8.5.6-15.1
  • git-daemon >= 1.8.5.6-15.1
  • git-email >= 1.8.5.6-15.1
  • git-gui >= 1.8.5.6-15.1
  • git-svn >= 1.8.5.6-15.1
  • git-web >= 1.8.5.6-15.1
  • gitk >= 1.8.5.6-15.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2015-857
openSUSE Leap 42.2
  • mercurial >= 3.8.3-1.15
  • mercurial-lang >= 3.8.3-1.15
Patchnames:
openSUSE Leap 42.2 GA mercurial
openSUSE Leap 42.3
  • mercurial >= 4.2-1.2
  • mercurial-lang >= 4.2-1.2
Patchnames:
openSUSE Leap 42.3 GA mercurial
openSUSE Tumbleweed
  • mercurial >= 4.0-1.1
  • mercurial-lang >= 4.0-1.1
Patchnames:
openSUSE Tumbleweed GA mercurial


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 11.3 git Released
SUSE Cloud 4 git Released
SUSE Cloud 5 git Released
SUSE Linux Enterprise SDK 11 SP1 git Released
SUSE Linux Enterprise SDK 11 SP2 git Released
SUSE Linux Enterprise SDK 11 SP3 git Released
SUSE Linux Enterprise SDK 11 SP4 git Released
SUSE Linux Enterprise SDK 12 GA git Released
SUSE Linux Enterprise SDK 12 SP1 git Released
SUSE Linux Enterprise Server 12 GA git Released
SUSE Linux Enterprise Server 12 SP1 git Released
SUSE Studio Onsite 1.3 git Released