Upstream information

CVE-2015-7543 at MITRE

Description

aRts 1.5.10 and kdelibs3 3.5.10 and earlier do not properly create temporary directories, which allows local users to hijack the IPC by pre-creating the temporary directory.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.4
Vector AV:L/AC:M/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 958347 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP4
  • kdelibs3 >= 3.5.10-23.30.5.1
  • kdelibs3-32bit >= 3.5.10-23.30.5.1
  • kdelibs3-default-style >= 3.5.10-23.30.5.1
  • kdelibs3-default-style-32bit >= 3.5.10-23.30.5.1
  • kdelibs3-default-style-x86 >= 3.5.10-23.30.5.1
  • kdelibs3-x86 >= 3.5.10-23.30.5.1
Patchnames:
slessp4-kdelibs3-13846
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • kdelibs3 >= 3.5.10-23.30.5.1
  • kdelibs3-32bit >= 3.5.10-23.30.5.1
  • kdelibs3-default-style >= 3.5.10-23.30.5.1
  • kdelibs3-default-style-32bit >= 3.5.10-23.30.5.1
  • kdelibs3-default-style-x86 >= 3.5.10-23.30.5.1
  • kdelibs3-x86 >= 3.5.10-23.30.5.1
Patchnames:
slessp4-kdelibs3-13846
SUSE Linux Enterprise Software Development Kit 11 SP4
  • kdelibs3 >= 3.5.10-23.30.5.1
  • kdelibs3-32bit >= 3.5.10-23.30.5.1
  • kdelibs3-arts >= 3.5.10-23.30.5.1
  • kdelibs3-arts-32bit >= 3.5.10-23.30.5.1
  • kdelibs3-arts-x86 >= 3.5.10-23.30.5.1
  • kdelibs3-default-style-32bit >= 3.5.10-23.30.5.1
  • kdelibs3-devel >= 3.5.10-23.30.5.1
  • kdelibs3-doc >= 3.5.10-23.30.5.1
Patchnames:
sdksp4-kdelibs3-13846


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP3 arts Affected
SUSE Linux Enterprise Desktop 11 SP3 kdelibs3 Affected
SUSE Linux Enterprise Desktop 11 SP4 arts Affected
SUSE Linux Enterprise Desktop 11 SP4 kdelibs3 Affected
SUSE Linux Enterprise SDK 11 SP3 arts Affected
SUSE Linux Enterprise SDK 11 SP3 kdelibs3 Affected
SUSE Linux Enterprise SDK 11 SP4 arts Affected
SUSE Linux Enterprise SDK 11 SP4 kdelibs3 Released
SUSE Linux Enterprise Server 11 SP3 kdelibs3 Affected
SUSE Linux Enterprise Server 11 SP4 kdelibs3 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 kdelibs3 Affected