Upstream information

CVE-2015-6525 at MITRE

Description

Multiple integer overflows in the evbuffer API in Libevent 2.0.x before 2.0.22 and 2.1.x before 2.1.5-beta allow context-dependent attackers to cause a denial of service or possibly have other unspecified impact via "insanely large inputs" to the (1) evbuffer_add, (2) evbuffer_prepend, (3) evbuffer_expand, (4) exbuffer_reserve_space, or (5) evbuffer_read function, which triggers a heap-based buffer overflow or an infinite loop. NOTE: this identifier was SPLIT from CVE-2014-6272 per ADT3 due to different affected versions.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 897243 [RESOLVED], 943011 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 libevent Not affected
SUSE Linux Enterprise Desktop 12 GA libevent Affected
SUSE Linux Enterprise Desktop 12 SP2 libevent Not affected
SUSE Linux Enterprise Desktop 12 SP3 libevent Not affected
SUSE Linux Enterprise SDK 11 SP4 libevent Not affected
SUSE Linux Enterprise SDK 12 GA libevent Affected
SUSE Linux Enterprise SDK 12 SP2 libevent Not affected
SUSE Linux Enterprise SDK 12 SP3 libevent Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS libevent Not affected
SUSE Linux Enterprise Server 11 SP4 libevent Not affected
SUSE Linux Enterprise Server 12 GA libevent Affected
SUSE Linux Enterprise Server 12 GA LTSS libevent Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS libevent Not affected
SUSE Linux Enterprise Server 12 SP2 libevent Not affected
SUSE Linux Enterprise Server 12 SP3 libevent Not affected