Upstream information

CVE-2015-5828 at MITRE

Description

The API in the WebKit Plug-ins component in Apple Safari before 9 does not provide notification of an HTTP Redirection (aka 3xx) status code to a plugin, which allows remote attackers to bypass intended request restrictions via a crafted web site.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 1082221 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • libjavascriptcoregtk-4_0-18 >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.10.7-7.1
  • libjavascriptcoregtk-4_0-18-debuginfo-32bit >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37 >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-32bit >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.10.7-7.1
  • libwebkit2gtk-4_0-37-debuginfo-32bit >= 2.10.7-7.1
  • libwebkit2gtk3-lang >= 2.10.7-7.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.10.7-7.1
  • typelib-1_0-WebKit2-4_0 >= 2.10.7-7.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.10.7-7.1
  • webkit-jsc-4 >= 2.10.7-7.1
  • webkit-jsc-4-debuginfo >= 2.10.7-7.1
  • webkit2gtk-4_0-injected-bundles >= 2.10.7-7.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.10.7-7.1
  • webkit2gtk3 >= 2.10.7-7.1
  • webkit2gtk3-debugsource >= 2.10.7-7.1
  • webkit2gtk3-devel >= 2.10.7-7.1
Patchnames:
openSUSE-2016-340