Upstream information

CVE-2015-5621 at MITRE

Description

The snmp_pdu_parse function in snmp_api.c in net-snmp 5.7.2 and earlier does not remove the varBind variable in a netsnmp_variable_list item when parsing of the SNMP PDU fails, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted packet.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 1111123 [RESOLVED / INVALID], 940188 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libsnmp15 >= 5.4.2.1-8.12.24.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • perl-SNMP >= 5.4.2.1-8.12.24.1
  • snmp-mibs >= 5.4.2.1-8.12.24.1
Patchnames:
sledsp3-net-snmp-12079
SUSE Linux Enterprise Desktop 11 SP4
  • libsnmp15 >= 5.4.2.1-8.12.24.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • perl-SNMP >= 5.4.2.1-8.12.24.1
  • snmp-mibs >= 5.4.2.1-8.12.24.1
Patchnames:
sledsp4-net-snmp-12079
SUSE Linux Enterprise Desktop 12
  • libsnmp30 >= 5.7.2.1-4.3.2
  • libsnmp30-32bit >= 5.7.2.1-4.3.2
  • net-snmp >= 5.7.2.1-4.3.2
  • perl-SNMP >= 5.7.2.1-4.3.2
  • snmp-mibs >= 5.7.2.1-4.3.2
Patchnames:
SUSE-SLE-DESKTOP-12-2015-537
SUSE Linux Enterprise Desktop 12 SP1
  • libsnmp30 >= 5.7.3-4.2
  • libsnmp30-32bit >= 5.7.3-4.2
  • net-snmp >= 5.7.3-4.2
  • perl-SNMP >= 5.7.3-4.2
  • snmp-mibs >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libsnmp30-32bit
SUSE Linux Enterprise Desktop 12 SP2
  • libsnmp30 >= 5.7.3-4.2
  • libsnmp30-32bit >= 5.7.3-4.2
  • net-snmp >= 5.7.3-4.2
  • perl-SNMP >= 5.7.3-4.2
  • snmp-mibs >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libsnmp30-32bit
SUSE Linux Enterprise Desktop 12 SP3
  • libsnmp30 >= 5.7.3-4.2
  • libsnmp30-32bit >= 5.7.3-4.2
  • net-snmp >= 5.7.3-4.2
  • perl-SNMP >= 5.7.3-4.2
  • snmp-mibs >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libsnmp30-32bit
SUSE Linux Enterprise Module for Basesystem 15
  • libsnmp30 >= 5.7.3-5.21
  • net-snmp >= 5.7.3-5.21
  • net-snmp-devel >= 5.7.3-5.21
  • perl-SNMP >= 5.7.3-5.21
  • snmp-mibs >= 5.7.3-5.21
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libsnmp30
SUSE Linux Enterprise Server 11 SP3
  • libsnmp15 >= 5.4.2.1-8.12.24.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • libsnmp15-x86 >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • perl-SNMP >= 5.4.2.1-8.12.24.1
  • snmp-mibs >= 5.4.2.1-8.12.24.1
Patchnames:
slessp3-net-snmp-12079
SUSE Linux Enterprise Server 11 SP4
  • libsnmp15 >= 5.4.2.1-8.12.24.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • libsnmp15-x86 >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • perl-SNMP >= 5.4.2.1-8.12.24.1
  • snmp-mibs >= 5.4.2.1-8.12.24.1
Patchnames:
slessp4-net-snmp-12079
SUSE Linux Enterprise Server 11-SECURITY
  • libsnmp15-openssl1 >= 5.4.2.1-8.12.31.1
  • libsnmp15-openssl1-32bit >= 5.4.2.1-8.12.31.1
Patchnames:
SUSE Linux Enterprise Server 11-SECURITY GA libsnmp15-openssl1-32bit
SUSE Linux Enterprise Server 12
  • libsnmp30 >= 5.7.2.1-4.3.2
  • libsnmp30-32bit >= 5.7.2.1-4.3.2
  • net-snmp >= 5.7.2.1-4.3.2
  • perl-SNMP >= 5.7.2.1-4.3.2
  • snmp-mibs >= 5.7.2.1-4.3.2
Patchnames:
SUSE-SLE-SERVER-12-2015-537
SUSE Linux Enterprise Server 12 SP1
  • libsnmp30 >= 5.7.3-4.2
  • libsnmp30-32bit >= 5.7.3-4.2
  • net-snmp >= 5.7.3-4.2
  • perl-SNMP >= 5.7.3-4.2
  • snmp-mibs >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libsnmp30-32bit
SUSE Linux Enterprise Server 12 SP2
  • libsnmp30 >= 5.7.3-4.2
  • libsnmp30-32bit >= 5.7.3-4.2
  • net-snmp >= 5.7.3-4.2
  • perl-SNMP >= 5.7.3-4.2
  • snmp-mibs >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libsnmp30-32bit
SUSE Linux Enterprise Server 12 SP3
  • libsnmp30 >= 5.7.3-4.2
  • libsnmp30-32bit >= 5.7.3-4.2
  • net-snmp >= 5.7.3-4.2
  • perl-SNMP >= 5.7.3-4.2
  • snmp-mibs >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libsnmp30-32bit
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libsnmp30 >= 5.7.3-4.2
  • net-snmp >= 5.7.3-4.2
  • perl-SNMP >= 5.7.3-4.2
  • snmp-mibs >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libsnmp30
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • libsnmp15 >= 5.4.2.1-8.12.24.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • libsnmp15-x86 >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • perl-SNMP >= 5.4.2.1-8.12.24.1
  • snmp-mibs >= 5.4.2.1-8.12.24.1
Patchnames:
slessp3-net-snmp-12079
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libsnmp15 >= 5.4.2.1-8.12.24.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • libsnmp15-x86 >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • perl-SNMP >= 5.4.2.1-8.12.24.1
  • snmp-mibs >= 5.4.2.1-8.12.24.1
Patchnames:
slessp4-net-snmp-12079
SUSE Linux Enterprise Server for SAP Applications 12
  • libsnmp30 >= 5.7.2.1-4.3.2
  • libsnmp30-32bit >= 5.7.2.1-4.3.2
  • net-snmp >= 5.7.2.1-4.3.2
  • perl-SNMP >= 5.7.2.1-4.3.2
  • snmp-mibs >= 5.7.2.1-4.3.2
Patchnames:
SUSE-SLE-SERVER-12-2015-537
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libsnmp15 >= 5.4.2.1-8.12.24.1
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • libsnmp15-x86 >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • perl-SNMP >= 5.4.2.1-8.12.24.1
  • snmp-mibs >= 5.4.2.1-8.12.24.1
Patchnames:
slessp3-net-snmp-12079
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • net-snmp-devel >= 5.4.2.1-8.12.24.1
  • net-snmp-devel-32bit >= 5.4.2.1-8.12.24.1
Patchnames:
sdksp3-net-snmp-12079
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libsnmp15-32bit >= 5.4.2.1-8.12.24.1
  • net-snmp >= 5.4.2.1-8.12.24.1
  • net-snmp-devel >= 5.4.2.1-8.12.24.1
  • net-snmp-devel-32bit >= 5.4.2.1-8.12.24.1
Patchnames:
sdksp4-net-snmp-12079
SUSE Linux Enterprise Software Development Kit 12
  • net-snmp >= 5.7.2.1-4.3.2
  • net-snmp-devel >= 5.7.2.1-4.3.2
Patchnames:
SUSE-SLE-SDK-12-2015-537
SUSE Linux Enterprise Software Development Kit 12 SP1
  • net-snmp-devel >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA net-snmp-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • net-snmp-devel >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA net-snmp-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • net-snmp-devel >= 5.7.3-4.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA net-snmp-devel
openSUSE 13.1
  • libsnmp30 >= 5.7.2-9.11.1
  • libsnmp30-32bit >= 5.7.2-9.11.1
  • libsnmp30-debuginfo >= 5.7.2-9.11.1
  • libsnmp30-debuginfo-32bit >= 5.7.2-9.11.1
  • net-snmp >= 5.7.2-9.11.1
  • net-snmp-debuginfo >= 5.7.2-9.11.1
  • net-snmp-debugsource >= 5.7.2-9.11.1
  • net-snmp-devel >= 5.7.2-9.11.1
  • net-snmp-devel-32bit >= 5.7.2-9.11.1
  • net-snmp-python >= 5.7.2-9.11.1
  • net-snmp-python-debuginfo >= 5.7.2-9.11.1
  • perl-SNMP >= 5.7.2-9.11.1
  • perl-SNMP-debuginfo >= 5.7.2-9.11.1
  • snmp-mibs >= 5.7.2-9.11.1
Patchnames:
openSUSE-2015-568
openSUSE Leap 15.0
  • libsnmp30 >= 5.7.3-lp150.5.1
  • net-snmp >= 5.7.3-lp150.5.1
  • perl-SNMP >= 5.7.3-lp150.5.1
  • snmp-mibs >= 5.7.3-lp150.5.1
Patchnames:
openSUSE Leap 15.0 GA libsnmp30
openSUSE Leap 42.1
  • libsnmp30 >= 5.7.3-2.5
  • libsnmp30-32bit >= 5.7.3-2.5
  • net-snmp >= 5.7.3-2.5
  • net-snmp-devel >= 5.7.3-2.5
  • perl-SNMP >= 5.7.3-2.5
  • snmp-mibs >= 5.7.3-2.5
Patchnames:
openSUSE Leap 42.1 GA libsnmp30-32bit
openSUSE Leap 42.2
  • libsnmp30 >= 5.7.3-4.5
  • libsnmp30-32bit >= 5.7.3-4.5
  • net-snmp >= 5.7.3-4.5
  • net-snmp-devel >= 5.7.3-4.5
  • perl-SNMP >= 5.7.3-4.5
  • snmp-mibs >= 5.7.3-4.5
Patchnames:
openSUSE Leap 42.2 GA libsnmp30-32bit
openSUSE Leap 42.3
  • libsnmp30 >= 5.7.3-6.6
  • libsnmp30-32bit >= 5.7.3-6.6
  • net-snmp >= 5.7.3-6.6
  • net-snmp-devel >= 5.7.3-6.6
  • perl-SNMP >= 5.7.3-6.6
  • snmp-mibs >= 5.7.3-6.6
Patchnames:
openSUSE Leap 42.3 GA libsnmp30-32bit
openSUSE Tumbleweed
  • libsnmp30 >= 5.7.3-8.4
  • libsnmp30-32bit >= 5.7.3-8.4
  • net-snmp >= 5.7.3-8.4
  • net-snmp-devel >= 5.7.3-8.4
  • net-snmp-devel-32bit >= 5.7.3-8.4
  • net-snmp-python >= 5.7.3-8.4
  • perl-SNMP >= 5.7.3-8.4
  • snmp-mibs >= 5.7.3-8.4
Patchnames:
openSUSE Tumbleweed GA libsnmp30-32bit


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 net-snmp Released
SUSE Linux Enterprise Desktop 11 SP3 net-snmp Released
SUSE Linux Enterprise Desktop 11 SP4 net-snmp Released
SUSE Linux Enterprise Desktop 12 GA net-snmp Released
SUSE Linux Enterprise SDK 11 SP2 net-snmp Released
SUSE Linux Enterprise SDK 11 SP3 net-snmp Released
SUSE Linux Enterprise SDK 11 SP4 net-snmp Released
SUSE Linux Enterprise SDK 12 GA net-snmp Released
SUSE Linux Enterprise Server 11 SP1 LTSS net-snmp Released
SUSE Linux Enterprise Server 11 SP2 net-snmp Released
SUSE Linux Enterprise Server 11 SP2 LTSS net-snmp Released
SUSE Linux Enterprise Server 11 SP3 net-snmp Released
SUSE Linux Enterprise Server 11 SP3 LTSS net-snmp Affected
SUSE Linux Enterprise Server 11 SP4 net-snmp Released
SUSE Linux Enterprise Server 12 GA net-snmp Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 net-snmp Released
SUSE Linux Enterprise Server for VMWare 11 SP2 net-snmp Released
SUSE Linux Enterprise Server for VMWare 11 SP3 net-snmp Released