Upstream information

CVE-2015-5316 at MITRE


The eap_pwd_perform_confirm_exchange function in eap_peer/eap_pwd.c in wpa_supplicant 2.x before 2.6, when EAP-pwd is enabled in a network configuration profile, allows remote attackers to cause a denial of service (NULL pointer dereference and daemon crash) via an EAP-pwd Confirm message followed by the Identity exchange.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 953115 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • wpa_supplicant >= 2.6-2.50
SUSE Linux Enterprise Module for Basesystem 15 GA wpa_supplicant
openSUSE Leap 15.0
  • wpa_supplicant >= 2.6-lp150.2.13
openSUSE Leap 15.0 GA wpa_supplicant
openSUSE Tumbleweed
  • wpa_supplicant >= 2.6-1.1
  • wpa_supplicant-gui >= 2.6-1.1
openSUSE Tumbleweed GA wpa_supplicant