Upstream information

CVE-2015-5309 at MITRE

Description

Integer overflow in the terminal emulator in PuTTY before 0.66 allows remote attackers to cause a denial of service (memory corruption) or possibly execute arbitrary code via an ECH (erase characters) escape sequence with a large parameter value, which triggers a buffer underflow.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 954191 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • putty >= 0.66-2.7.1
  • putty-debuginfo >= 0.66-2.7.1
  • putty-debugsource >= 0.66-2.7.1
Patchnames:
openSUSE-2015-766
openSUSE Leap 42.1
  • putty >= 0.66-6.1
  • putty-debuginfo >= 0.66-6.1
  • putty-debugsource >= 0.66-6.1
Patchnames:
openSUSE-2015-766
openSUSE Tumbleweed
  • putty >= 0.67-1.5
Patchnames:
openSUSE Tumbleweed GA putty