Upstream information

CVE-2015-5259 at MITRE

Description

Integer overflow in the read_string function in libsvn_ra_svn/marshal.c in Apache Subversion 1.9.x before 1.9.3 allows remote attackers to execute arbitrary code via an svn:// protocol string, which triggers a heap-based buffer overflow and an out-of-bounds read.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 9 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:C AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Complete Partial
SUSE Bugzilla entry: 958299 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • subversion >= 1.10.0-1.24
  • subversion-devel >= 1.10.0-1.24
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA subversion
SUSE Linux Enterprise Module for Development Tools 15
  • subversion-bash-completion >= 1.10.0-1.24
  • subversion-perl >= 1.10.0-1.24
  • subversion-python >= 1.10.0-1.24
  • subversion-tools >= 1.10.0-1.24
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA subversion-bash-completion
SUSE Linux Enterprise Module for Server Applications 15
  • subversion-server >= 1.10.0-1.24
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA subversion-server
openSUSE Leap 42.2
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.4-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.4-1.1
  • subversion >= 1.9.4-1.1
  • subversion-bash-completion >= 1.9.4-1.1
  • subversion-devel >= 1.9.4-1.1
  • subversion-perl >= 1.9.4-1.1
  • subversion-python >= 1.9.4-1.1
  • subversion-server >= 1.9.4-1.1
  • subversion-tools >= 1.9.4-1.1
Patchnames:
openSUSE Leap 42.2 GA libsvn_auth_gnome_keyring-1-0
openSUSE Leap 42.3
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.5-6.3
  • libsvn_auth_kwallet-1-0 >= 1.9.5-6.3
  • subversion >= 1.9.5-6.3
  • subversion-bash-completion >= 1.9.5-6.3
  • subversion-devel >= 1.9.5-6.3
  • subversion-perl >= 1.9.5-6.3
  • subversion-python >= 1.9.5-6.3
  • subversion-server >= 1.9.5-6.3
  • subversion-tools >= 1.9.5-6.3
Patchnames:
openSUSE Leap 42.3 GA libsvn_auth_gnome_keyring-1-0
openSUSE Tumbleweed
  • libsvn_auth_gnome_keyring-1-0 >= 1.9.5-1.1
  • libsvn_auth_kwallet-1-0 >= 1.9.5-1.1
  • subversion >= 1.9.5-1.1
  • subversion-bash-completion >= 1.9.5-1.1
  • subversion-devel >= 1.9.5-1.1
  • subversion-perl >= 1.9.5-1.1
  • subversion-python >= 1.9.5-1.1
  • subversion-python-ctypes >= 1.9.5-1.1
  • subversion-ruby >= 1.9.5-1.1
  • subversion-server >= 1.9.5-1.1
  • subversion-tools >= 1.9.5-1.1
Patchnames:
openSUSE Tumbleweed GA libsvn_auth_gnome_keyring-1-0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP2 subversion Analysis
SUSE Linux Enterprise SDK 11 SP3 subversion Analysis
SUSE Linux Enterprise SDK 11 SP4 subversion Analysis
SUSE Linux Enterprise SDK 12 GA subversion Analysis