Upstream information

CVE-2015-5161 at MITRE

Description

The Zend_Xml_Security::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when running under PHP-FPM in a threaded environment, allows remote attackers to bypass security checks and conduct XML external entity (XXE) and XML entity expansion (XEE) attacks via multibyte encoded characters.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 976996 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP2-LTSS
  • apache2-mod_php53 >= 5.3.17-47.1
  • php53 >= 5.3.17-47.1
  • php53-bcmath >= 5.3.17-47.1
  • php53-bz2 >= 5.3.17-47.1
  • php53-calendar >= 5.3.17-47.1
  • php53-ctype >= 5.3.17-47.1
  • php53-curl >= 5.3.17-47.1
  • php53-dba >= 5.3.17-47.1
  • php53-dom >= 5.3.17-47.1
  • php53-exif >= 5.3.17-47.1
  • php53-fastcgi >= 5.3.17-47.1
  • php53-fileinfo >= 5.3.17-47.1
  • php53-ftp >= 5.3.17-47.1
  • php53-gd >= 5.3.17-47.1
  • php53-gettext >= 5.3.17-47.1
  • php53-gmp >= 5.3.17-47.1
  • php53-iconv >= 5.3.17-47.1
  • php53-intl >= 5.3.17-47.1
  • php53-json >= 5.3.17-47.1
  • php53-ldap >= 5.3.17-47.1
  • php53-mbstring >= 5.3.17-47.1
  • php53-mcrypt >= 5.3.17-47.1
  • php53-mysql >= 5.3.17-47.1
  • php53-odbc >= 5.3.17-47.1
  • php53-openssl >= 5.3.17-47.1
  • php53-pcntl >= 5.3.17-47.1
  • php53-pdo >= 5.3.17-47.1
  • php53-pear >= 5.3.17-47.1
  • php53-pgsql >= 5.3.17-47.1
  • php53-pspell >= 5.3.17-47.1
  • php53-shmop >= 5.3.17-47.1
  • php53-snmp >= 5.3.17-47.1
  • php53-soap >= 5.3.17-47.1
  • php53-suhosin >= 5.3.17-47.1
  • php53-sysvmsg >= 5.3.17-47.1
  • php53-sysvsem >= 5.3.17-47.1
  • php53-sysvshm >= 5.3.17-47.1
  • php53-tokenizer >= 5.3.17-47.1
  • php53-wddx >= 5.3.17-47.1
  • php53-xmlreader >= 5.3.17-47.1
  • php53-xmlrpc >= 5.3.17-47.1
  • php53-xmlwriter >= 5.3.17-47.1
  • php53-xsl >= 5.3.17-47.1
  • php53-zip >= 5.3.17-47.1
  • php53-zlib >= 5.3.17-47.1
Patchnames:
slessp2-php53-12621
SUSE Linux Enterprise Server for SAP Applications 11 SP2-LTSS
  • apache2-mod_php53 >= 5.3.17-47.1
  • php53 >= 5.3.17-47.1
  • php53-bcmath >= 5.3.17-47.1
  • php53-bz2 >= 5.3.17-47.1
  • php53-calendar >= 5.3.17-47.1
  • php53-ctype >= 5.3.17-47.1
  • php53-curl >= 5.3.17-47.1
  • php53-dba >= 5.3.17-47.1
  • php53-dom >= 5.3.17-47.1
  • php53-exif >= 5.3.17-47.1
  • php53-fastcgi >= 5.3.17-47.1
  • php53-fileinfo >= 5.3.17-47.1
  • php53-ftp >= 5.3.17-47.1
  • php53-gd >= 5.3.17-47.1
  • php53-gettext >= 5.3.17-47.1
  • php53-gmp >= 5.3.17-47.1
  • php53-iconv >= 5.3.17-47.1
  • php53-intl >= 5.3.17-47.1
  • php53-json >= 5.3.17-47.1
  • php53-ldap >= 5.3.17-47.1
  • php53-mbstring >= 5.3.17-47.1
  • php53-mcrypt >= 5.3.17-47.1
  • php53-mysql >= 5.3.17-47.1
  • php53-odbc >= 5.3.17-47.1
  • php53-openssl >= 5.3.17-47.1
  • php53-pcntl >= 5.3.17-47.1
  • php53-pdo >= 5.3.17-47.1
  • php53-pear >= 5.3.17-47.1
  • php53-pgsql >= 5.3.17-47.1
  • php53-pspell >= 5.3.17-47.1
  • php53-shmop >= 5.3.17-47.1
  • php53-snmp >= 5.3.17-47.1
  • php53-soap >= 5.3.17-47.1
  • php53-suhosin >= 5.3.17-47.1
  • php53-sysvmsg >= 5.3.17-47.1
  • php53-sysvsem >= 5.3.17-47.1
  • php53-sysvshm >= 5.3.17-47.1
  • php53-tokenizer >= 5.3.17-47.1
  • php53-wddx >= 5.3.17-47.1
  • php53-xmlreader >= 5.3.17-47.1
  • php53-xmlrpc >= 5.3.17-47.1
  • php53-xmlwriter >= 5.3.17-47.1
  • php53-xsl >= 5.3.17-47.1
  • php53-zip >= 5.3.17-47.1
  • php53-zlib >= 5.3.17-47.1
Patchnames:
slessp2-php53-12621


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for Web and Scripting 12 php5 Released
SUSE Linux Enterprise SDK 11 SP2 php5 Released
SUSE Linux Enterprise SDK 12 GA php5 Released
SUSE Linux Enterprise SDK 12 SP1 php5 Released
SUSE Linux Enterprise Server 10 SP3 php5 Released
SUSE Linux Enterprise Server 10 SP4 php5 Released
SUSE Linux Enterprise Server 10 SP4 LTSS php5 Released
SUSE Linux Enterprise Server 11 SP1 LTSS php5 Released
SUSE Linux Enterprise Server 11 SP2 php5 Released
SUSE Linux Enterprise Server 11 SP2 LTSS php5 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 php5 Released
SUSE Linux Enterprise Server for VMWare 11 SP2 php5 Released