Upstream information

CVE-2015-4645 at MITRE

Description

Integer overflow in the read_fragment_table_4 function in unsquash-4.c in Squashfs and sasquatch allows remote attackers to cause a denial of service (application crash) via a crafted input, which triggers a stack-based buffer overflow.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 935380 [CONFIRMED]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP3 squashfs Affected
SUSE Linux Enterprise Desktop 11 SP4 squashfs Affected
SUSE Linux Enterprise Desktop 12 GA squashfs Affected
SUSE Linux Enterprise Server 11 SP3 squashfs Affected
SUSE Linux Enterprise Server 11 SP4 squashfs Affected
SUSE Linux Enterprise Server 12 GA squashfs Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 squashfs Affected