Upstream information

CVE-2015-4506 at MITRE

Description

Buffer overflow in the vp9_init_context_buffers function in libvpx, as used in Mozilla Firefox before 41.0 and Firefox ESR 38.x before 38.3, allows remote attackers to execute arbitrary code via a crafted VP9 file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 947003 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-translations >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
Patchnames:
sledsp3-firefox-20150923-12113
sledsp3-firefox-20150923-12122
SUSE Linux Enterprise Desktop 11 SP4
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-translations >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
Patchnames:
sledsp4-firefox-20150923-12113
sledsp4-firefox-20150923-12122
SUSE Linux Enterprise Desktop 12
  • MozillaFirefox >= 38.3.0esr-48.1
  • MozillaFirefox-translations >= 38.3.0esr-48.1
  • mozilla-nspr >= 4.10.9-6.1
  • mozilla-nspr-32bit >= 4.10.9-6.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-640
SUSE Linux Enterprise Desktop 12 SP1
  • MozillaFirefox >= 38.4.0esr-51.1
  • MozillaFirefox-translations >= 38.4.0esr-51.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA MozillaFirefox
SUSE Linux Enterprise Desktop 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Desktop 12 SP3
  • MozillaFirefox >= 52.2.0esr-108.3
  • MozillaFirefox-translations >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA MozillaFirefox
SUSE Linux Enterprise Module for Desktop Applications 15
  • MozillaFirefox >= 52.7.3-1.35
  • MozillaFirefox-devel >= 52.7.3-1.35
  • MozillaFirefox-translations-common >= 52.7.3-1.35
  • MozillaFirefox-translations-other >= 52.7.3-1.35
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA MozillaFirefox
SUSE Linux Enterprise Server 11 SP2-LTSS
  • MozillaFirefox >= 38.3.0esr-20.1
  • MozillaFirefox-translations >= 38.3.0esr-20.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
  • mozilla-nspr-devel >= 4.10.9-11.1
Patchnames:
slessp2-firefox-20150923-12113
SUSE Linux Enterprise Server 11 SP3
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-translations >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
  • mozilla-nspr-x86 >= 4.10.9-11.1
Patchnames:
slessp3-firefox-20150923-12113
slessp3-firefox-20150923-12122
SUSE Linux Enterprise Server 11 SP4
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-translations >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
  • mozilla-nspr-x86 >= 4.10.9-11.1
Patchnames:
slessp4-firefox-20150923-12113
slessp4-firefox-20150923-12122
SUSE Linux Enterprise Server 12
  • MozillaFirefox >= 38.3.0esr-48.1
  • MozillaFirefox-translations >= 38.3.0esr-48.1
  • mozilla-nspr >= 4.10.9-6.1
  • mozilla-nspr-32bit >= 4.10.9-6.1
Patchnames:
SUSE-SLE-SERVER-12-2015-640
SUSE Linux Enterprise Server 12 SP1
  • MozillaFirefox >= 38.4.0esr-51.1
  • MozillaFirefox-translations >= 38.4.0esr-51.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA MozillaFirefox
SUSE Linux Enterprise Server 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Server 12 SP3
  • MozillaFirefox >= 52.2.0esr-108.3
  • MozillaFirefox-translations >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA MozillaFirefox
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • MozillaFirefox >= 45.4.0esr-81.1
  • MozillaFirefox-translations >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA MozillaFirefox
SUSE Linux Enterprise Server for SAP Applications 11 SP2-LTSS
  • MozillaFirefox >= 38.3.0esr-20.1
  • MozillaFirefox-translations >= 38.3.0esr-20.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
  • mozilla-nspr-devel >= 4.10.9-11.1
Patchnames:
slessp2-firefox-20150923-12113
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-translations >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
  • mozilla-nspr-x86 >= 4.10.9-11.1
Patchnames:
slessp3-firefox-20150923-12113
slessp3-firefox-20150923-12122
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-translations >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
  • mozilla-nspr-x86 >= 4.10.9-11.1
Patchnames:
slessp4-firefox-20150923-12113
slessp4-firefox-20150923-12122
SUSE Linux Enterprise Server for SAP Applications 12
  • MozillaFirefox >= 38.3.0esr-48.1
  • MozillaFirefox-translations >= 38.3.0esr-48.1
  • mozilla-nspr >= 4.10.9-6.1
  • mozilla-nspr-32bit >= 4.10.9-6.1
Patchnames:
SUSE-SLE-SERVER-12-2015-640
SUSE Linux Enterprise Server for VMWare 11 SP3
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-translations >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-32bit >= 4.10.9-11.1
  • mozilla-nspr-x86 >= 4.10.9-11.1
Patchnames:
slessp3-firefox-20150923-12113
slessp3-firefox-20150923-12122
SUSE Linux Enterprise Software Development Kit 11 SP3
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-devel >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-devel >= 4.10.9-11.1
Patchnames:
sdksp3-firefox-20150923-12113
sdksp3-firefox-20150923-12122
SUSE Linux Enterprise Software Development Kit 11 SP4
  • MozillaFirefox >= 38.3.0esr-22.1
  • MozillaFirefox-devel >= 38.3.0esr-22.1
  • mozilla-nspr >= 4.10.9-11.1
  • mozilla-nspr-devel >= 4.10.9-11.1
Patchnames:
sdksp4-firefox-20150923-12113
sdksp4-firefox-20150923-12122
SUSE Linux Enterprise Software Development Kit 12
  • MozillaFirefox >= 38.3.0esr-48.1
  • MozillaFirefox-devel >= 38.3.0esr-48.1
  • mozilla-nspr >= 4.10.9-6.1
  • mozilla-nspr-devel >= 4.10.9-6.1
Patchnames:
SUSE-SLE-SDK-12-2015-640
SUSE Linux Enterprise Software Development Kit 12 SP1
  • MozillaFirefox-devel >= 38.4.0esr-51.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA MozillaFirefox-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • MozillaFirefox-devel >= 45.4.0esr-81.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA MozillaFirefox-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • MozillaFirefox-devel >= 52.2.0esr-108.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA MozillaFirefox-devel
SUSE Linux Enterprise Workstation Extension 15
  • MozillaThunderbird >= 52.8-1.2
  • MozillaThunderbird-devel >= 52.8-1.2
  • MozillaThunderbird-translations-common >= 52.8-1.2
  • MozillaThunderbird-translations-other >= 52.8-1.2
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA MozillaThunderbird
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • MozillaFirefox >= 38.4.0esr-0.7.1
  • MozillaFirefox-branding-SLED >= 38-0.5.3
  • MozillaFirefox-translations >= 38.4.0esr-0.7.1
  • mozilla-nspr >= 4.10.10-0.5.1
  • mozilla-nspr-devel >= 4.10.10-0.5.1
  • mozilla-nss >= 3.19.2.1-0.5.1
  • mozilla-nss-devel >= 3.19.2.1-0.5.1
  • mozilla-nss-tools >= 3.19.2.1-0.5.1
Builds
ZYPP Patch Nr: 9176
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
  • MozillaFirefox >= 38.4.0esr-0.7.1
  • MozillaFirefox-branding-SLED >= 38-0.5.3
  • MozillaFirefox-translations >= 38.4.0esr-0.7.1
  • mozilla-nspr >= 4.10.10-0.5.1
  • mozilla-nspr-32bit >= 4.10.10-0.5.1
  • mozilla-nspr-devel >= 4.10.10-0.5.1
  • mozilla-nss >= 3.19.2.1-0.5.1
  • mozilla-nss-32bit >= 3.19.2.1-0.5.1
  • mozilla-nss-devel >= 3.19.2.1-0.5.1
  • mozilla-nss-tools >= 3.19.2.1-0.5.1
Builds
ZYPP Patch Nr: 9176
openSUSE 13.1
  • MozillaFirefox >= 41.0-88.1
  • MozillaFirefox-branding-upstream >= 41.0-88.1
  • MozillaFirefox-buildsymbols >= 41.0-88.1
  • MozillaFirefox-debuginfo >= 41.0-88.1
  • MozillaFirefox-debugsource >= 41.0-88.1
  • MozillaFirefox-devel >= 41.0-88.1
  • MozillaFirefox-translations-common >= 41.0-88.1
  • MozillaFirefox-translations-other >= 41.0-88.1
  • MozillaThunderbird >= 38.3.0-70.65.1
  • MozillaThunderbird-buildsymbols >= 38.3.0-70.65.1
  • MozillaThunderbird-debuginfo >= 38.3.0-70.65.1
  • MozillaThunderbird-debugsource >= 38.3.0-70.65.1
  • MozillaThunderbird-devel >= 38.3.0-70.65.1
  • MozillaThunderbird-translations-common >= 38.3.0-70.65.1
  • MozillaThunderbird-translations-other >= 38.3.0-70.65.1
  • seamonkey >= 2.38-56.1
  • seamonkey-debuginfo >= 2.38-56.1
  • seamonkey-debugsource >= 2.38-56.1
  • seamonkey-dom-inspector >= 2.38-56.1
  • seamonkey-irc >= 2.38-56.1
  • seamonkey-translations-common >= 2.38-56.1
  • seamonkey-translations-other >= 2.38-56.1
Patchnames:
openSUSE-2015-619
openSUSE-2015-631
openSUSE-2015-632
openSUSE Leap 15.0
  • MozillaFirefox >= 60.0-lp150.2.2
  • MozillaFirefox-translations-common >= 60.0-lp150.2.2
  • MozillaFirefox-translations-other >= 60.0-lp150.2.2
  • MozillaThunderbird >= 52.7-lp150.2.16
  • MozillaThunderbird-translations-common >= 52.7-lp150.2.16
  • MozillaThunderbird-translations-other >= 52.7-lp150.2.16
Patchnames:
openSUSE Leap 15.0 GA MozillaFirefox
openSUSE Leap 15.0 GA MozillaThunderbird
openSUSE Leap 42.1
  • MozillaFirefox >= 41.0.2-1.2
  • MozillaFirefox-translations-common >= 41.0.2-1.2
  • MozillaThunderbird >= 38.3.0-2.2
  • MozillaThunderbird-translations-common >= 38.3.0-2.2
Patchnames:
openSUSE Leap 42.1 GA MozillaFirefox
openSUSE Leap 42.1 GA MozillaThunderbird
openSUSE Leap 42.2
  • MozillaFirefox >= 49.0.2-37.1
  • MozillaFirefox-translations-common >= 49.0.2-37.1
  • MozillaThunderbird >= 45.4.0-23.1
  • MozillaThunderbird-translations-common >= 45.4.0-23.1
Patchnames:
openSUSE Leap 42.2 GA MozillaFirefox
openSUSE Leap 42.2 GA MozillaThunderbird
openSUSE Leap 42.3
  • MozillaFirefox >= 52.2-58.2
  • MozillaFirefox-translations-common >= 52.2-58.2
  • MozillaThunderbird >= 52.2.1-42.1
  • MozillaThunderbird-translations-common >= 52.2.1-42.1
Patchnames:
openSUSE Leap 42.3 GA MozillaFirefox
openSUSE Leap 42.3 GA MozillaThunderbird
openSUSE Tumbleweed
  • MozillaFirefox >= 50.1.0-1.1
  • MozillaFirefox-branding-upstream >= 50.1.0-1.1
  • MozillaFirefox-buildsymbols >= 50.1.0-1.1
  • MozillaFirefox-devel >= 50.1.0-1.1
  • MozillaFirefox-translations-common >= 50.1.0-1.1
  • MozillaFirefox-translations-other >= 50.1.0-1.1
  • MozillaThunderbird >= 45.5.1-1.1
  • MozillaThunderbird-buildsymbols >= 45.5.1-1.1
  • MozillaThunderbird-devel >= 45.5.1-1.1
  • MozillaThunderbird-translations-common >= 45.5.1-1.1
  • MozillaThunderbird-translations-other >= 45.5.1-1.1
  • seamonkey >= 2.40-6.1
  • seamonkey-dom-inspector >= 2.40-6.1
  • seamonkey-irc >= 2.40-6.1
  • seamonkey-translations-common >= 2.40-6.1
  • seamonkey-translations-other >= 2.40-6.1
Patchnames:
openSUSE Tumbleweed GA MozillaFirefox
openSUSE Tumbleweed GA MozillaThunderbird
openSUSE Tumbleweed GA seamonkey


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 SP3 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise Desktop 12 GA MozillaFirefox Released
SUSE Linux Enterprise SDK 11 SP3 MozillaFirefox Released
SUSE Linux Enterprise SDK 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise SDK 12 GA MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP1 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP2 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP3 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise Server 12 GA MozillaFirefox Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server for VMWare 11 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server for VMWare 11 SP3 MozillaFirefox Released