Upstream information

CVE-2015-4047 at MITRE

Description

racoon/gssapi.c in IPsec-Tools 0.8.2 allows remote attackers to cause a denial of service (NULL pointer dereference and IKE daemon crash) via a series of crafted UDP requests.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.8 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Complete Partial
SUSE Bugzilla entry: 931989 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP3
  • ipsec-tools >= 0.7.3-1.13.1
Patchnames:
slessp3-ipsec-tools-12024
SUSE Linux Enterprise Server 11 SP4
  • ipsec-tools >= 0.7.3-1.13.1
Patchnames:
slessp4-ipsec-tools-12024
SUSE Linux Enterprise Server 12 SP1
  • ipsec-tools >= 0.8.0-11.2
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA ipsec-tools
SUSE Linux Enterprise Server 12 SP2
  • ipsec-tools >= 0.8.0-15.16
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA ipsec-tools
SUSE Linux Enterprise Server 12 SP3
  • ipsec-tools >= 0.8.0-18.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA ipsec-tools
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ipsec-tools >= 0.8.0-15.16
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA ipsec-tools
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • ipsec-tools >= 0.7.3-1.13.1
Patchnames:
slessp3-ipsec-tools-12024
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • ipsec-tools >= 0.7.3-1.13.1
Patchnames:
slessp4-ipsec-tools-12024
SUSE Linux Enterprise Server for VMWare 11 SP3
  • ipsec-tools >= 0.7.3-1.13.1
Patchnames:
slessp3-ipsec-tools-12024
openSUSE Leap 42.1
  • ipsec-tools >= 0.8.0-4.4
Patchnames:
openSUSE Leap 42.1 GA ipsec-tools
openSUSE Leap 42.2
  • ipsec-tools >= 0.8.0-11.1
Patchnames:
openSUSE Leap 42.2 GA ipsec-tools
openSUSE Leap 42.3
  • ipsec-tools >= 0.8.0-13.2
Patchnames:
openSUSE Leap 42.3 GA ipsec-tools


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Server 10 SP3 ipsec-tools Released
SUSE Linux Enterprise Server 10 SP4 ipsec-tools Released
SUSE Linux Enterprise Server 10 SP4 LTSS ipsec-tools Released
SUSE Linux Enterprise Server 11 SP1 ipsec-tools Affected
SUSE Linux Enterprise Server 11 SP1 LTSS ipsec-tools Affected
SUSE Linux Enterprise Server 11 SP2 ipsec-tools Affected
SUSE Linux Enterprise Server 11 SP2 LTSS ipsec-tools Affected
SUSE Linux Enterprise Server 11 SP3 ipsec-tools Affected
SUSE Linux Enterprise Server 11 SP3 LTSS ipsec-tools Affected
SUSE Linux Enterprise Server 11 SP4 ipsec-tools Affected
SUSE Linux Enterprise Server 12 GA ipsec-tools Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 ipsec-tools Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ipsec-tools Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ipsec-tools Affected
SUSE Linux Enterprise Server for SAP ES 11 SP1 ipsec-tools Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 ipsec-tools Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 ipsec-tools Affected