Upstream information

CVE-2015-3247 at MITRE

Description

Race condition in the worker_update_monitors_config function in SPICE 0.12.4 allows a remote authenticated guest user to cause a denial of service (heap-based memory corruption and QEMU-KVM crash) or possibly execute arbitrary code on the host via unspecified vectors.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 944460 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libspice-server1 >= 0.12.4-8.5.1
  • spice >= 0.12.4-8.5.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-674
SUSE Linux Enterprise Desktop 12 SP1
  • libspice-server1 >= 0.12.5-2.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libspice-server1
SUSE Linux Enterprise Desktop 12 SP2
  • libspice-server1 >= 0.12.7-6.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libspice-server1
SUSE Linux Enterprise Desktop 12 SP3
  • libspice-server1 >= 0.12.8-1.17
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libspice-server1
SUSE Linux Enterprise Module for Server Applications 15
  • libspice-server-devel >= 0.14.0-2.32
  • libspice-server1 >= 0.14.0-2.32
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libspice-server-devel
SUSE Linux Enterprise Server 11 SP4
  • libspice-server1 >= 0.12.4-5.1
  • spice >= 0.12.4-5.1
Patchnames:
slessp4-spice-12542
SUSE Linux Enterprise Server 12
  • libspice-server1 >= 0.12.4-8.5.1
  • spice >= 0.12.4-8.5.1
Patchnames:
SUSE-SLE-SERVER-12-2015-674
SUSE Linux Enterprise Server 12 SP1
  • libspice-server1 >= 0.12.5-2.2
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libspice-server1
SUSE Linux Enterprise Server 12 SP2
  • libspice-server1 >= 0.12.7-6.3
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libspice-server1
SUSE Linux Enterprise Server 12 SP3
  • libspice-server1 >= 0.12.8-1.17
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libspice-server1
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libspice-server1 >= 0.12.4-5.1
  • spice >= 0.12.4-5.1
Patchnames:
slessp4-spice-12542
SUSE Linux Enterprise Server for SAP Applications 12
  • libspice-server1 >= 0.12.4-8.5.1
  • spice >= 0.12.4-8.5.1
Patchnames:
SUSE-SLE-SERVER-12-2015-674
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libspice-server-devel >= 0.12.4-5.1
  • spice >= 0.12.4-5.1
Patchnames:
sdksp4-spice-12542
SUSE Linux Enterprise Software Development Kit 12
  • libspice-server-devel >= 0.12.4-8.5.1
  • spice >= 0.12.4-8.5.1
Patchnames:
SUSE-SLE-SDK-12-2015-674
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libspice-server-devel >= 0.12.5-2.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libspice-server-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libspice-server-devel >= 0.12.7-6.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libspice-server-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libspice-server-devel >= 0.12.8-1.17
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libspice-server-devel
openSUSE 13.1
  • libspice-server-devel >= 0.12.4-2.3.1
  • libspice-server1 >= 0.12.4-2.3.1
  • libspice-server1-debuginfo >= 0.12.4-2.3.1
  • spice >= 0.12.4-2.3.1
  • spice-client >= 0.12.4-2.3.1
  • spice-client-debuginfo >= 0.12.4-2.3.1
  • spice-debugsource >= 0.12.4-2.3.1
Patchnames:
openSUSE-2015-657
openSUSE Leap 15.0
  • libspice-server1 >= 0.14.0-lp150.2.4
Patchnames:
openSUSE Leap 15.0 GA libspice-server1
openSUSE Leap 42.1
  • libspice-server1 >= 0.12.5-6.1
Patchnames:
openSUSE Leap 42.1 GA libspice-server1
openSUSE Leap 42.2
  • libspice-server1 >= 0.12.7-1.4
Patchnames:
openSUSE Leap 42.2 GA libspice-server1
openSUSE Leap 42.3
  • libspice-server1 >= 0.12.8-1.4
Patchnames:
openSUSE Leap 42.3 GA libspice-server1
openSUSE Tumbleweed
  • libspice-server-devel >= 0.12.8-2.1
  • libspice-server1 >= 0.12.8-2.1
  • spice-client >= 0.12.8-2.1
Patchnames:
openSUSE Tumbleweed GA libspice-server-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA spice Released
SUSE Linux Enterprise SDK 11 SP4 spice Released
SUSE Linux Enterprise SDK 12 GA spice Released
SUSE Linux Enterprise Server 11 SP4 spice Released
SUSE Linux Enterprise Server 12 GA spice Released