Upstream information

CVE-2015-3238 at MITRE

Description

The _unix_run_helper_binary function in the pam_unix module in Linux-PAM (aka pam) before 1.2.1, when unable to directly access passwords, allows local users to enumerate usernames or cause a denial of service (hang) via a large password.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5.8 6.4
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network Network
Access Complexity Medium Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial Partial
SUSE Bugzilla entry: 934920 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • pam >= 1.1.8-23.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-865
SUSE Linux Enterprise Desktop 12 SP1
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-865
SUSE Linux Enterprise Desktop 12 SP2
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-865
SUSE Linux Enterprise Desktop 12 SP3
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA pam
SUSE Linux Enterprise Module for Basesystem 15
  • pam >= 1.3.0-4.10
  • pam-32bit >= 1.3.0-4.10
  • pam-devel >= 1.3.0-4.10
  • pam-doc >= 1.3.0-4.10
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA pam
SUSE Linux Enterprise Module for Containers 12
  • sles12-docker-image >= 1.1.4-20171002
  • sles12sp1-docker-image >= 1.0.7-20171002
  • sles12sp2-docker-image >= 1.0.2-20180821
Patchnames:
SUSE-SLE-Module-Containers-12-2017-1672
SUSE-SLE-Module-Containers-12-2017-1673
SUSE-SLE-Module-Containers-12-2018-1762
SUSE Linux Enterprise Module for Development Tools 15
  • pam-devel-32bit >= 1.3.0-4.10
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA pam-devel-32bit
SUSE Linux Enterprise Server 11 SP4
  • pam >= 1.1.5-0.17.2
  • pam-32bit >= 1.1.5-0.17.2
  • pam-doc >= 1.1.5-0.17.2
  • pam-x86 >= 1.1.5-0.17.2
Patchnames:
slessp4-pam-12624
SUSE Linux Enterprise Server 12 SP1
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-865
SUSE Linux Enterprise Server 12 SP2
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-865
SUSE Linux Enterprise Server 12 SP3
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA pam
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • pam >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-865
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • pam >= 1.1.5-0.17.2
  • pam-32bit >= 1.1.5-0.17.2
  • pam-doc >= 1.1.5-0.17.2
  • pam-x86 >= 1.1.5-0.17.2
Patchnames:
slessp4-pam-12624
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-865
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-865
SUSE Linux Enterprise Software Development Kit 11 SP4
  • pam >= 1.1.5-0.17.2
  • pam-devel >= 1.1.5-0.17.2
  • pam-devel-32bit >= 1.1.5-0.17.2
Patchnames:
sdksp4-pam-12624
SUSE Linux Enterprise Software Development Kit 12 SP1
  • pam >= 1.1.8-23.1
  • pam-devel >= 1.1.8-23.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-865
SUSE Linux Enterprise Software Development Kit 12 SP2
  • pam >= 1.1.8-23.1
  • pam-devel >= 1.1.8-23.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-865
SUSE Linux Enterprise Software Development Kit 12 SP3
  • pam-devel >= 1.1.8-23.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA pam-devel
openSUSE Leap 15.0
  • pam >= 1.3.0-lp150.4.6
  • pam-32bit >= 1.3.0-lp150.4.6
Patchnames:
openSUSE Leap 15.0 GA pam
openSUSE Leap 42.2
  • pam >= 1.3.0-1.9
  • pam-32bit >= 1.3.0-1.9
  • pam-devel >= 1.3.0-1.9
Patchnames:
openSUSE Leap 42.2 GA pam
openSUSE Leap 42.3
  • pam >= 1.3.0-3.15
  • pam-32bit >= 1.3.0-3.15
  • pam-devel >= 1.3.0-3.15
Patchnames:
openSUSE Leap 42.3 GA pam
openSUSE Tumbleweed
  • pam >= 1.3.0-3.4
  • pam-32bit >= 1.3.0-3.4
  • pam-devel >= 1.3.0-3.4
  • pam-devel-32bit >= 1.3.0-3.4
  • pam-doc >= 1.3.0-3.4
Patchnames:
openSUSE Tumbleweed GA pam


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
OpenStack Cloud Magnum Orchestration 7.0 pam Released
SUSE Linux Enterprise Desktop 11 SP3 pam Affected
SUSE Linux Enterprise Desktop 11 SP4 pam Released
SUSE Linux Enterprise Desktop 12 GA pam Released
SUSE Linux Enterprise Desktop 12 SP1 pam Released
SUSE Linux Enterprise Desktop 12 SP2 pam Released
SUSE Linux Enterprise SDK 11 SP3 pam Affected
SUSE Linux Enterprise SDK 11 SP4 pam Released
SUSE Linux Enterprise SDK 12 GA pam Released
SUSE Linux Enterprise SDK 12 SP1 pam Released
SUSE Linux Enterprise SDK 12 SP2 pam Released
SUSE Linux Enterprise Server 11 SP3 pam Affected
SUSE Linux Enterprise Server 11 SP4 pam Released
SUSE Linux Enterprise Server 12 GA pam Released
SUSE Linux Enterprise Server 12 GA LTSS pam Released
SUSE Linux Enterprise Server 12 SP1 pam Released
SUSE Linux Enterprise Server 12 SP2 pam Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI pam Released
SUSE Linux Enterprise Server for VMWare 11 SP3 pam Affected