Upstream information

CVE-2015-3185 at MITRE

Description

The ap_some_auth_required function in server/request.c in the Apache HTTP Server 2.4.x before 2.4.14 does not consider that a Require directive may be associated with an authorization setting rather than an authentication setting, which allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging the presence of a module that relies on the 2.2 API behavior.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 938723 [RESOLVED / FIXED], 939514 [RESOLVED], 939516 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 1.0
  • apache2-mod_fastcgi >= 2.4.7-3.4.1
Patchnames:
SUSE-Storage-1.0-2015-772
SUSE Linux Enterprise Server 12
  • apache2 >= 2.4.10-14.10.1
  • apache2-doc >= 2.4.10-14.10.1
  • apache2-example-pages >= 2.4.10-14.10.1
  • apache2-mod_auth_kerb >= 5.4-2.4.1
  • apache2-mod_jk >= 1.2.40-2.6.1
  • apache2-mod_security2 >= 2.8.0-3.4.1
  • apache2-prefork >= 2.4.10-14.10.1
  • apache2-utils >= 2.4.10-14.10.1
  • apache2-worker >= 2.4.10-14.10.1
Patchnames:
SUSE-SLE-SERVER-12-2015-772
SUSE Linux Enterprise Server for SAP Applications 12
  • apache2 >= 2.4.10-14.10.1
  • apache2-doc >= 2.4.10-14.10.1
  • apache2-example-pages >= 2.4.10-14.10.1
  • apache2-mod_auth_kerb >= 5.4-2.4.1
  • apache2-mod_jk >= 1.2.40-2.6.1
  • apache2-mod_security2 >= 2.8.0-3.4.1
  • apache2-prefork >= 2.4.10-14.10.1
  • apache2-utils >= 2.4.10-14.10.1
  • apache2-worker >= 2.4.10-14.10.1
Patchnames:
SUSE-SLE-SERVER-12-2015-772
SUSE Linux Enterprise Software Development Kit 12
  • apache2 >= 2.4.10-14.10.1
  • apache2-devel >= 2.4.10-14.10.1
Patchnames:
SUSE-SLE-SDK-12-2015-772
openSUSE 13.1
  • apache2 >= 2.4.6-6.50.1
  • apache2-debuginfo >= 2.4.6-6.50.1
  • apache2-debugsource >= 2.4.6-6.50.1
  • apache2-devel >= 2.4.6-6.50.1
  • apache2-doc >= 2.4.6-6.50.1
  • apache2-event >= 2.4.6-6.50.1
  • apache2-event-debuginfo >= 2.4.6-6.50.1
  • apache2-example-pages >= 2.4.6-6.50.1
  • apache2-prefork >= 2.4.6-6.50.1
  • apache2-prefork-debuginfo >= 2.4.6-6.50.1
  • apache2-utils >= 2.4.6-6.50.1
  • apache2-utils-debuginfo >= 2.4.6-6.50.1
  • apache2-worker >= 2.4.6-6.50.1
  • apache2-worker-debuginfo >= 2.4.6-6.50.1
Patchnames:
openSUSE-2015-635


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP3 apache2 In progress
SUSE Linux Enterprise SDK 11 SP4 apache2 In progress
SUSE Linux Enterprise SDK 12 GA apache2 Released
SUSE Linux Enterprise Server 11 SP3 apache2 In progress
SUSE Linux Enterprise Server 11 SP4 apache2 In progress
SUSE Linux Enterprise Server 12 GA apache2 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 apache2 In progress