Upstream information

CVE-2015-2698 at MITRE

Description

The iakerb_gss_export_sec_context function in lib/gssapi/krb5/iakerb.c in MIT Kerberos 5 (aka krb5) 1.14 pre-release 2015-09-14 improperly accesses a certain pointer, which allows remote authenticated users to cause a denial of service (memory corruption) or possibly have unspecified other impact by interacting with an application that calls the gss_export_sec_context function. NOTE: this vulnerability exists because of an incorrect fix for CVE-2015-2696.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 8.5 6.8
Vector AV:N/AC:M/Au:S/C:C/I:C/A:C AV:N/AC:H/Au:S/C:C/I:P/A:C
Access Vector Network Network
Access Complexity Medium High
Authentication Single Single
Confidentiality Impact Complete Complete
Integrity Impact Complete Partial
Availability Impact Complete Complete
SUSE Bugzilla entries: 770172 [RESOLVED / FIXED], 954204 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12
  • krb5-mini >= 1.12.1-22.2
  • krb5-mini-devel >= 1.12.1-22.2
Patchnames:
SUSE-SLE-BSK-12-2015-992
SUSE Linux Enterprise Build System Kit 12 SP1
  • krb5-mini >= 1.12.1-22.2
  • krb5-mini-devel >= 1.12.1-22.2
Patchnames:
SUSE-SLE-BSK-12-SP1-2015-992
SUSE Linux Enterprise Desktop 12
  • krb5 >= 1.12.1-22.5
  • krb5-32bit >= 1.12.1-22.5
  • krb5-client >= 1.12.1-22.5
Patchnames:
SUSE-SLE-DESKTOP-12-2015-992
SUSE Linux Enterprise Desktop 12 SP1
  • krb5 >= 1.12.1-22.5
  • krb5-32bit >= 1.12.1-22.5
  • krb5-client >= 1.12.1-22.5
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2015-992
SUSE Linux Enterprise Desktop 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA krb5
SUSE Linux Enterprise Desktop 12 SP3
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA krb5
SUSE Linux Enterprise Module for Basesystem 15
  • krb5 >= 1.15.2-4.25
  • krb5-32bit >= 1.15.2-4.25
  • krb5-client >= 1.15.2-4.25
  • krb5-devel >= 1.15.2-4.25
  • krb5-plugin-preauth-otp >= 1.15.2-4.25
  • krb5-plugin-preauth-pkinit >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA krb5
SUSE Linux Enterprise Module for Server Applications 15
  • krb5-plugin-kdb-ldap >= 1.15.2-4.25
  • krb5-server >= 1.15.2-4.25
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA krb5-plugin-kdb-ldap
SUSE Linux Enterprise Server 12
  • krb5 >= 1.12.1-22.5
  • krb5-32bit >= 1.12.1-22.5
  • krb5-client >= 1.12.1-22.5
  • krb5-doc >= 1.12.1-22.5
  • krb5-plugin-kdb-ldap >= 1.12.1-22.5
  • krb5-plugin-preauth-otp >= 1.12.1-22.5
  • krb5-plugin-preauth-pkinit >= 1.12.1-22.5
  • krb5-server >= 1.12.1-22.5
Patchnames:
SUSE-SLE-SERVER-12-2015-992
SUSE Linux Enterprise Server 12 SP1
  • krb5 >= 1.12.1-22.5
  • krb5-32bit >= 1.12.1-22.5
  • krb5-client >= 1.12.1-22.5
  • krb5-doc >= 1.12.1-22.5
  • krb5-plugin-kdb-ldap >= 1.12.1-22.5
  • krb5-plugin-preauth-otp >= 1.12.1-22.5
  • krb5-plugin-preauth-pkinit >= 1.12.1-22.5
  • krb5-server >= 1.12.1-22.5
Patchnames:
SUSE-SLE-SERVER-12-SP1-2015-992
SUSE Linux Enterprise Server 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA krb5
SUSE Linux Enterprise Server 12 SP3
  • krb5 >= 1.12.5-39.1
  • krb5-32bit >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA krb5
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • krb5 >= 1.12.5-39.1
  • krb5-client >= 1.12.5-39.1
  • krb5-doc >= 1.12.5-39.1
  • krb5-plugin-kdb-ldap >= 1.12.5-39.1
  • krb5-plugin-preauth-otp >= 1.12.5-39.1
  • krb5-plugin-preauth-pkinit >= 1.12.5-39.1
  • krb5-server >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA krb5
SUSE Linux Enterprise Server for SAP Applications 12
  • krb5 >= 1.12.1-22.5
  • krb5-32bit >= 1.12.1-22.5
  • krb5-client >= 1.12.1-22.5
  • krb5-doc >= 1.12.1-22.5
  • krb5-plugin-kdb-ldap >= 1.12.1-22.5
  • krb5-plugin-preauth-otp >= 1.12.1-22.5
  • krb5-plugin-preauth-pkinit >= 1.12.1-22.5
  • krb5-server >= 1.12.1-22.5
Patchnames:
SUSE-SLE-SERVER-12-2015-992
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • krb5 >= 1.12.1-22.5
  • krb5-32bit >= 1.12.1-22.5
  • krb5-client >= 1.12.1-22.5
  • krb5-doc >= 1.12.1-22.5
  • krb5-plugin-kdb-ldap >= 1.12.1-22.5
  • krb5-plugin-preauth-otp >= 1.12.1-22.5
  • krb5-plugin-preauth-pkinit >= 1.12.1-22.5
  • krb5-server >= 1.12.1-22.5
Patchnames:
SUSE-SLE-SERVER-12-SP1-2015-992
SUSE Linux Enterprise Software Development Kit 12
  • krb5 >= 1.12.1-22.5
  • krb5-devel >= 1.12.1-22.5
Patchnames:
SUSE-SLE-SDK-12-2015-992
SUSE Linux Enterprise Software Development Kit 12 SP1
  • krb5 >= 1.12.1-22.5
  • krb5-devel >= 1.12.1-22.5
Patchnames:
SUSE-SLE-SDK-12-SP1-2015-992
SUSE Linux Enterprise Software Development Kit 12 SP2
  • krb5-devel >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA krb5-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • krb5-devel >= 1.12.5-39.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA krb5-devel
openSUSE 13.1
  • krb5 >= 1.11.3-3.24.1
  • krb5-32bit >= 1.11.3-3.24.1
  • krb5-client >= 1.11.3-3.24.1
  • krb5-client-debuginfo >= 1.11.3-3.24.1
  • krb5-debuginfo >= 1.11.3-3.24.1
  • krb5-debuginfo-32bit >= 1.11.3-3.24.1
  • krb5-debugsource >= 1.11.3-3.24.1
  • krb5-devel >= 1.11.3-3.24.1
  • krb5-devel-32bit >= 1.11.3-3.24.1
  • krb5-doc >= 1.11.3-3.24.1
  • krb5-mini >= 1.11.3-3.24.1
  • krb5-mini-debuginfo >= 1.11.3-3.24.1
  • krb5-mini-debugsource >= 1.11.3-3.24.1
  • krb5-mini-devel >= 1.11.3-3.24.1
  • krb5-plugin-kdb-ldap >= 1.11.3-3.24.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.11.3-3.24.1
  • krb5-plugin-preauth-pkinit >= 1.11.3-3.24.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.11.3-3.24.1
  • krb5-server >= 1.11.3-3.24.1
  • krb5-server-debuginfo >= 1.11.3-3.24.1
Patchnames:
openSUSE-2015-784
openSUSE Leap 15.0
  • krb5 >= 1.15.2-lp150.4.4
  • krb5-32bit >= 1.15.2-lp150.4.4
  • krb5-server >= 1.15.2-lp150.4.4
Patchnames:
openSUSE Leap 15.0 GA krb5
openSUSE Leap 42.1
  • krb5 >= 1.12.1-24.1
  • krb5-32bit >= 1.12.1-24.1
  • krb5-client >= 1.12.1-24.1
  • krb5-client-debuginfo >= 1.12.1-24.1
  • krb5-debuginfo >= 1.12.1-24.1
  • krb5-debuginfo-32bit >= 1.12.1-24.1
  • krb5-debugsource >= 1.12.1-24.1
  • krb5-devel >= 1.12.1-24.1
  • krb5-devel-32bit >= 1.12.1-24.1
  • krb5-doc >= 1.12.1-24.1
  • krb5-mini >= 1.12.1-24.1
  • krb5-mini-debuginfo >= 1.12.1-24.1
  • krb5-mini-debugsource >= 1.12.1-24.1
  • krb5-mini-devel >= 1.12.1-24.1
  • krb5-plugin-kdb-ldap >= 1.12.1-24.1
  • krb5-plugin-kdb-ldap-debuginfo >= 1.12.1-24.1
  • krb5-plugin-preauth-otp >= 1.12.1-24.1
  • krb5-plugin-preauth-otp-debuginfo >= 1.12.1-24.1
  • krb5-plugin-preauth-pkinit >= 1.12.1-24.1
  • krb5-plugin-preauth-pkinit-debuginfo >= 1.12.1-24.1
  • krb5-server >= 1.12.1-24.1
  • krb5-server-debuginfo >= 1.12.1-24.1
Patchnames:
openSUSE-2015-961
openSUSE Leap 42.2
  • krb5 >= 1.12.5-5.13
  • krb5-32bit >= 1.12.5-5.13
  • krb5-client >= 1.12.5-5.13
  • krb5-devel >= 1.12.5-5.13
Patchnames:
openSUSE Leap 42.2 GA krb5
openSUSE Leap 42.3
  • krb5 >= 1.12.5-7.17
  • krb5-32bit >= 1.12.5-7.17
  • krb5-client >= 1.12.5-7.17
  • krb5-devel >= 1.12.5-7.17
Patchnames:
openSUSE Leap 42.3 GA krb5
openSUSE Tumbleweed
  • krb5 >= 1.15-1.1
  • krb5-32bit >= 1.15-1.1
  • krb5-client >= 1.15-1.1
  • krb5-devel >= 1.15-1.1
  • krb5-devel-32bit >= 1.15-1.1
  • krb5-doc >= 1.15-1.1
  • krb5-mini >= 1.15-1.1
  • krb5-mini-devel >= 1.15-1.1
  • krb5-plugin-kdb-ldap >= 1.15-1.1
  • krb5-plugin-preauth-otp >= 1.15-1.1
  • krb5-plugin-preauth-pkinit >= 1.15-1.1
  • krb5-server >= 1.15-1.1
Patchnames:
openSUSE Tumbleweed GA krb5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP3 krb5 Not affected
SUSE Linux Enterprise Desktop 11 SP4 krb5 Not affected
SUSE Linux Enterprise Desktop 12 GA krb5 Released
SUSE Linux Enterprise Desktop 12 SP1 krb5 Released
SUSE Linux Enterprise SDK 11 SP3 krb5 Not affected
SUSE Linux Enterprise SDK 11 SP4 krb5 Not affected
SUSE Linux Enterprise SDK 12 GA krb5 Released
SUSE Linux Enterprise SDK 12 SP1 krb5 Released
SUSE Linux Enterprise Server 11 SP3 krb5 Not affected
SUSE Linux Enterprise Server 11 SP4 krb5 Not affected
SUSE Linux Enterprise Server 12 GA krb5 Released
SUSE Linux Enterprise Server 12 SP1 krb5 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 krb5 Not affected