Upstream information

CVE-2015-1868 at MITRE

Description

The label decompression functionality in PowerDNS Recursor 3.5.x, 3.6.x before 3.6.3, and 3.7.x before 3.7.2 and Authoritative (Auth) Server 3.2.x, 3.3.x before 3.3.2, and 3.4.x before 3.4.4 allows remote attackers to cause a denial of service (CPU consumption or crash) via a request with a name that refers to itself.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entries: 927569 [RESOLVED], 943078 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • pdns-recursor >= 3.6.2-8.7.1
  • pdns-recursor-debuginfo >= 3.6.2-8.7.1
  • pdns-recursor-debugsource >= 3.6.2-8.7.1
Patchnames:
openSUSE-2015-505
openSUSE Tumbleweed
  • pdns >= 4.0.1-1.2
  • pdns-backend-geoip >= 4.0.1-1.2
  • pdns-backend-godbc >= 4.0.1-1.2
  • pdns-backend-ldap >= 4.0.1-1.2
  • pdns-backend-lua >= 4.0.1-1.2
  • pdns-backend-mydns >= 4.0.1-1.2
  • pdns-backend-mysql >= 4.0.1-1.2
  • pdns-backend-postgresql >= 4.0.1-1.2
  • pdns-backend-remote >= 4.0.1-1.2
  • pdns-backend-sqlite3 >= 4.0.1-1.2
  • pdns-recursor >= 4.0.3-1.2
Patchnames:
openSUSE Tumbleweed GA pdns
openSUSE Tumbleweed GA pdns-recursor