Upstream information

CVE-2015-1852 at MITRE

Description

The s3_token middleware in OpenStack keystonemiddleware before 1.6.0 and python-keystoneclient before 1.4.0 disables certification verification when the "insecure" option is set in a paste configuration (paste.ini) file regardless of the value, which allows remote attackers to conduct man-in-the-middle attacks via a crafted certificate, a different vulnerability than CVE-2014-7144.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 928205 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Cloud Compute Node for SUSE Linux Enterprise 12 5
  • python-glanceclient >= 0.15.0-3.1
  • python-keystoneclient >= 1.0.0-19.1
  • python-keystoneclient-doc >= 1.0.0-19.1
  • python-keystonemiddleware >= 1.2.0-4.1
  • python-novaclient >= 2.20.0-6.1
  • python-novaclient-doc >= 2.20.0-6.1
  • python-swiftclient >= 2.3.1-3.1
  • python-swiftclient-doc >= 2.3.1-3.1
Patchnames:
SUSE-SLE12-CLOUD-5-2015-303
SUSE-SLE12-CLOUD-5-2015-570
SUSE Linux Enterprise Module for Public Cloud 15
  • python3-keystoneclient >= 3.15.0-2.33
Patchnames:
SUSE Linux Enterprise Module for Public Cloud 15 GA python3-keystoneclient
SUSE OpenStack Cloud 4
  • python-keystoneclient >= 0.9.0-0.13.1
  • python-keystoneclient-doc >= 0.9.0-0.13.1
Patchnames:
sleclo40sp3-python-keystoneclient
SUSE OpenStack Cloud 5
  • python-glanceclient >= 0.15.0-9.2
  • python-keystoneclient >= 1.0.0-11.1
  • python-keystoneclient-doc >= 1.0.0-11.1
  • python-keystonemiddleware >= 1.2.0-11.2
  • python-novaclient >= 2.20.0-9.2
  • python-novaclient-doc >= 2.20.0-9.2
  • python-openstackclient >= 0.4.1-9.2
Patchnames:
sleclo50sp3-python-modules-201507-12046
SUSE OpenStack Cloud 6
  • python-keystoneclient >= 1.7.2-3.1
  • python-keystoneclient-doc >= 1.7.2-3.1
  • python-keystonemiddleware >= 2.3.1-1.1
Patchnames:
SUSE OpenStack Cloud 6 GA python-keystoneclient
SUSE OpenStack Cloud 6 GA python-keystonemiddleware
SUSE Cloud 4
  • python-keystoneclient >= 0.9.0-0.13.1
  • python-keystoneclient-doc >= 0.9.0-0.13.1
Builds
SAT Patch Nr: 10667
openSUSE Tumbleweed
  • python-keystoneclient >= 3.5.0-1.1
  • python-keystoneclient-doc >= 3.5.0-1.1
  • python-keystonemiddleware >= 4.9.0-1.3
  • python-keystonemiddleware-doc >= 4.9.0-1.3
Patchnames:
openSUSE Tumbleweed GA python-keystoneclient
openSUSE Tumbleweed GA python-keystonemiddleware


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 11.3 python-keystoneclient Released
SUSE Cloud 2.0 python-keystoneclient Already fixed
SUSE Cloud 4 python-keystoneclient Released
SUSE Cloud 5 python-keystoneclient Released
SUSE Cloud 5 python-keystonemiddleware Released
SUSE Linux Enterprise 12 Compute Node for Cloud 5 python-keystoneclient Released
SUSE Linux Enterprise 12 Compute Node for Cloud 5 python-keystonemiddleware Released
SUSE Linux Enterprise Module for Public Cloud 12 python-keystoneclient Released