Upstream information

CVE-2015-1798 at MITRE

Description

The symmetric-key feature in the receive function in ntp_proto.c in ntpd in NTP 4.x before 4.2.8p2 requires a correct MAC only if the MAC field has a nonzero length, which makes it easier for man-in-the-middle attackers to spoof packets by omitting the MAC.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 1.8
Vector AV:A/AC:H/Au:N/C:N/I:P/A:N
Access Vector Adjacent Network
Access Complexity High
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None

Note from the SUSE Security Team

This issue affects ntp-4.2.5p99 up to ntp-4.2.8p1. SUSE Linux Enterprise Server 11 SP3 and older have ntp 4.2.4 and older versions, so are not affected by this problem.

SUSE Bugzilla entries: 924202 [RESOLVED / FIXED], 927497 [RESOLVED / FIXED], 928321 [RESOLVED / FIXED], 957163 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • ntp >= 4.2.6p5-44.1
  • ntp-doc >= 4.2.6p5-44.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-193
SUSE Linux Enterprise Desktop 12 SP1
  • ntp >= 4.2.8p4-1.3
  • ntp-doc >= 4.2.8p4-1.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA ntp
SUSE Linux Enterprise Desktop 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA ntp
SUSE Linux Enterprise Desktop 12 SP3
  • ntp >= 4.2.8p10-63.3
  • ntp-doc >= 4.2.8p10-63.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA ntp
SUSE Linux Enterprise Module for Legacy Software 15
  • ntp >= 4.2.8p11-2.12
Patchnames:
SUSE Linux Enterprise Module for Legacy Software 15 GA ntp
SUSE Linux Enterprise Server 11 SP4
  • ntp >= 4.2.8p2-2.18
  • ntp-doc >= 4.2.8p2-2.18
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ntp
SUSE Linux Enterprise Server 12
  • ntp >= 4.2.6p5-44.1
  • ntp-doc >= 4.2.6p5-44.1
Patchnames:
SUSE-SLE-SERVER-12-2015-193
SUSE Linux Enterprise Server 12 SP1
  • ntp >= 4.2.8p4-1.3
  • ntp-doc >= 4.2.8p4-1.3
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA ntp
SUSE Linux Enterprise Server 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA ntp
SUSE Linux Enterprise Server 12 SP3
  • ntp >= 4.2.8p10-63.3
  • ntp-doc >= 4.2.8p10-63.3
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA ntp
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ntp >= 4.2.8p8-14.1
  • ntp-doc >= 4.2.8p8-14.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA ntp
SUSE Linux Enterprise Server for SAP Applications 12
  • ntp >= 4.2.6p5-44.1
  • ntp-doc >= 4.2.6p5-44.1
Patchnames:
SUSE-SLE-SERVER-12-2015-193
SUSE OpenStack Cloud 6
  • ntp >= 4.2.8p4-1.3
Patchnames:
SUSE OpenStack Cloud 6 GA ntp
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • yast2-ntp-client >= 2.13.18-0.20.1
Builds
ZYPP Patch Nr: 9295
SUSE Linux Enterprise Server 10 SP4 LTSS for AMD64 and Intel EM64T
SUSE Linux Enterprise Server 10 SP4 LTSS for IBM zSeries 64bit
SUSE Linux Enterprise Server 10 SP4 LTSS for x86
  • ntp >= 4.2.8p8-0.7.1
  • ntp-doc >= 4.2.8p8-0.7.1
Builds
ZYPP Patch Nr: 9293
openSUSE 13.1
  • ntp >= 4.2.6p5-15.16.1
  • ntp-debuginfo >= 4.2.6p5-15.16.1
  • ntp-debugsource >= 4.2.6p5-15.16.1
  • ntp-doc >= 4.2.6p5-15.16.1
Patchnames:
openSUSE-2015-330
openSUSE Leap 42.1
  • ntp >= 4.2.8p3-7.5
  • ntp-doc >= 4.2.8p3-7.5
Patchnames:
openSUSE Leap 42.1 GA ntp
openSUSE Leap 42.2
  • ntp >= 4.2.8p8-25.1
  • ntp-doc >= 4.2.8p8-25.1
Patchnames:
openSUSE Leap 42.2 GA ntp
openSUSE Leap 42.3
  • ntp >= 4.2.8p10-30.1
  • ntp-doc >= 4.2.8p10-30.1
Patchnames:
openSUSE Leap 42.3 GA ntp
openSUSE Tumbleweed
  • ntp >= 4.2.8p9-1.1
  • ntp-doc >= 4.2.8p9-1.1
Patchnames:
openSUSE Tumbleweed GA ntp


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP4 xntp Affected
SUSE Linux Enterprise Desktop 11 SP1 ntp Released
SUSE Linux Enterprise Desktop 11 SP2 ntp Released
SUSE Linux Enterprise Desktop 11 SP3 ntp Released
SUSE Linux Enterprise Desktop 11 SP4 ntp Released
SUSE Linux Enterprise Desktop 12 GA ntp Released
SUSE Linux Enterprise Server 10 SP4 xntp Affected
SUSE Linux Enterprise Server 10 SP4 LTSS xntp Affected
SUSE Linux Enterprise Server 11 SP1 ntp Released
SUSE Linux Enterprise Server 11 SP1 LTSS ntp Released
SUSE Linux Enterprise Server 11 SP2 ntp Released
SUSE Linux Enterprise Server 11 SP2 LTSS ntp Released
SUSE Linux Enterprise Server 11 SP3 ntp Released
SUSE Linux Enterprise Server 11 SP3 LTSS ntp Released
SUSE Linux Enterprise Server 11 SP4 ntp Released
SUSE Linux Enterprise Server 12 GA ntp Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 ntp Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ntp Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ntp Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 ntp Released
SUSE Linux Enterprise Server for VMWare 11 SP2 ntp Released
SUSE Linux Enterprise Server for VMWare 11 SP3 ntp Released