Upstream information

CVE-2015-1774 at MITRE

Description

The HWP filter in LibreOffice before 4.3.7 and 4.4.x before 4.4.2 and Apache OpenOffice before 4.1.2 allows remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via a crafted HWP document, which triggers an out-of-bounds write.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 919409 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12
  • flute >= 1.3.0-4.2
  • libbase >= 1.1.3-4.3
  • libfonts >= 1.1.3-4.9
  • libformula >= 1.1.3-4.3
  • liblayout >= 0.2.10-4.8
  • libloader >= 1.1.3-3.2
  • libreoffice >= 5.0.2.2-13.14
  • libreoffice-sdk >= 5.0.2.2-13.14
  • librepository >= 1.1.3-4.3
  • librevenge >= 0.0.2-4.1
  • librevenge-devel >= 0.0.2-4.1
  • librevenge-generators-0_0-0 >= 0.0.2-4.1
  • libserializer >= 1.1.2-4.3
  • mdds >= 0.12.1-3.1
  • mdds-devel >= 0.12.1-3.1
  • pentaho-libxml >= 1.1.3-4.3
  • pentaho-reporting-flow-engine >= 0.9.4-4.5
  • sac >= 1.3-4.1
Patchnames:
SUSE-SLE-BSK-12-2015-797
SUSE Linux Enterprise Desktop 12
  • apache-commons-logging >= 1.1.3-7.1
  • cmis-client >= 0.5.0-5.1
  • flute >= 1.3.0-4.2
  • graphite2 >= 1.3.1-3.1
  • hyphen >= 2.8.8-9.1
  • libabw >= 0.1.1-5.3
  • libabw-0_1-1 >= 0.1.1-5.3
  • libbase >= 1.1.3-4.3
  • libcdr >= 0.1.1-5.3
  • libcdr-0_1-1 >= 0.1.1-5.3
  • libcmis-0_5-5 >= 0.5.0-5.1
  • libe-book >= 0.1.2-4.2
  • libe-book-0_1-1 >= 0.1.2-4.2
  • libetonyek >= 0.1.3-3.5
  • libetonyek-0_1-1 >= 0.1.3-3.5
  • libfonts >= 1.1.3-4.9
  • libformula >= 1.1.3-4.3
  • libfreehand >= 0.1.1-4.9
  • libfreehand-0_1-1 >= 0.1.1-4.9
  • libgltf >= 0.0.1-2.1
  • libgltf-0_0-0 >= 0.0.1-2.1
  • libgraphite2-3 >= 1.3.1-3.1
  • libgraphite2-3-32bit >= 1.3.1-3.1
  • libhyphen0 >= 2.8.8-9.1
  • libixion >= 0.9.1-3.1
  • libixion-0_10-0 >= 0.9.1-3.1
  • liblangtag >= 0.5.7-3.1
  • liblangtag1 >= 0.5.7-3.1
  • liblayout >= 0.2.10-4.8
  • libloader >= 1.1.3-3.2
  • libmspub >= 0.1.2-5.1
  • libmspub-0_1-1 >= 0.1.2-5.1
  • libmwaw >= 0.3.6-3.3
  • libmwaw-0_3-3 >= 0.3.6-3.3
  • libodfgen >= 0.1.4-3.9
  • libodfgen-0_1-1 >= 0.1.4-3.9
  • liborcus >= 0.7.1-3.1
  • liborcus-0_8-0 >= 0.7.1-3.1
  • libpagemaker >= 0.0.2-2.3
  • libpagemaker-0_0-0 >= 0.0.2-2.3
  • libreoffice >= 5.0.2.2-13.14
  • libreoffice-base >= 5.0.2.2-13.14
  • libreoffice-base-drivers-mysql >= 5.0.2.2-13.14
  • libreoffice-base-drivers-postgresql >= 5.0.2.2-13.14
  • libreoffice-calc >= 5.0.2.2-13.14
  • libreoffice-calc-extensions >= 5.0.2.2-13.14
  • libreoffice-draw >= 5.0.2.2-13.14
  • libreoffice-filters-optional >= 5.0.2.2-13.14
  • libreoffice-gnome >= 5.0.2.2-13.14
  • libreoffice-icon-theme-tango >= 5.0.2.2-13.14
  • libreoffice-impress >= 5.0.2.2-13.14
  • libreoffice-l10n-af >= 5.0.2.2-13.14
  • libreoffice-l10n-ar >= 5.0.2.2-13.14
  • libreoffice-l10n-ca >= 5.0.2.2-13.14
  • libreoffice-l10n-cs >= 5.0.2.2-13.14
  • libreoffice-l10n-da >= 5.0.2.2-13.14
  • libreoffice-l10n-de >= 5.0.2.2-13.14
  • libreoffice-l10n-en >= 5.0.2.2-13.14
  • libreoffice-l10n-es >= 5.0.2.2-13.14
  • libreoffice-l10n-fi >= 5.0.2.2-13.14
  • libreoffice-l10n-fr >= 5.0.2.2-13.14
  • libreoffice-l10n-gu >= 5.0.2.2-13.14
  • libreoffice-l10n-hi >= 5.0.2.2-13.14
  • libreoffice-l10n-hu >= 5.0.2.2-13.14
  • libreoffice-l10n-it >= 5.0.2.2-13.14
  • libreoffice-l10n-ja >= 5.0.2.2-13.14
  • libreoffice-l10n-ko >= 5.0.2.2-13.14
  • libreoffice-l10n-nb >= 5.0.2.2-13.14
  • libreoffice-l10n-nl >= 5.0.2.2-13.14
  • libreoffice-l10n-nn >= 5.0.2.2-13.14
  • libreoffice-l10n-pl >= 5.0.2.2-13.14
  • libreoffice-l10n-pt-BR >= 5.0.2.2-13.14
  • libreoffice-l10n-pt-PT >= 5.0.2.2-13.14
  • libreoffice-l10n-ru >= 5.0.2.2-13.14
  • libreoffice-l10n-sk >= 5.0.2.2-13.14
  • libreoffice-l10n-sv >= 5.0.2.2-13.14
  • libreoffice-l10n-xh >= 5.0.2.2-13.14
  • libreoffice-l10n-zh-Hans >= 5.0.2.2-13.14
  • libreoffice-l10n-zh-Hant >= 5.0.2.2-13.14
  • libreoffice-l10n-zu >= 5.0.2.2-13.14
  • libreoffice-mailmerge >= 5.0.2.2-13.14
  • libreoffice-math >= 5.0.2.2-13.14
  • libreoffice-officebean >= 5.0.2.2-13.14
  • libreoffice-pyuno >= 5.0.2.2-13.14
  • libreoffice-share-linker >= 1-2.1
  • libreoffice-voikko >= 4.1-6.3
  • libreoffice-writer >= 5.0.2.2-13.14
  • libreoffice-writer-extensions >= 5.0.2.2-13.14
  • librepository >= 1.1.3-4.3
  • librevenge >= 0.0.2-4.1
  • librevenge-0_0-0 >= 0.0.2-4.1
  • librevenge-stream-0_0-0 >= 0.0.2-4.1
  • libserializer >= 1.1.2-4.3
  • libvisio >= 0.1.3-4.3
  • libvisio-0_1-1 >= 0.1.3-4.3
  • libvoikko >= 3.7.1-3.1
  • libvoikko1 >= 3.7.1-3.1
  • libwps >= 0.4.1-3.1
  • libwps-0_4-4 >= 0.4.1-3.1
  • malaga-suomi >= 1.18-3.2
  • myspell-af_ZA >= 20150827-5.1
  • myspell-ar >= 20150827-5.1
  • myspell-be_BY >= 20150827-5.1
  • myspell-bg_BG >= 20150827-5.1
  • myspell-bn_BD >= 20150827-5.1
  • myspell-bs_BA >= 20150827-5.1
  • myspell-ca >= 20150827-5.1
  • myspell-cs_CZ >= 20150827-5.1
  • myspell-da_DK >= 20150827-5.1
  • myspell-de >= 20150827-5.1
  • myspell-dictionaries >= 20150827-5.1
  • myspell-el_GR >= 20150827-5.1
  • myspell-en >= 20150827-5.1
  • myspell-es >= 20150827-5.1
  • myspell-et_EE >= 20150827-5.1
  • myspell-fr_FR >= 20150827-5.1
  • myspell-gu_IN >= 20150827-5.1
  • myspell-he_IL >= 20150827-5.1
  • myspell-hi_IN >= 20150827-5.1
  • myspell-hr_HR >= 20150827-5.1
  • myspell-hu_HU >= 20150827-5.1
  • myspell-it_IT >= 20150827-5.1
  • myspell-lo_LA >= 20150827-5.1
  • myspell-lt_LT >= 20150827-5.1
  • myspell-lv_LV >= 20150827-5.1
  • myspell-nl_NL >= 20150827-5.1
  • myspell-no >= 20150827-5.1
  • myspell-pl_PL >= 20150827-5.1
  • myspell-pt_BR >= 20150827-5.1
  • myspell-pt_PT >= 20150827-5.1
  • myspell-ro >= 20150827-5.1
  • myspell-ru_RU >= 20150827-5.1
  • myspell-sk_SK >= 20150827-5.1
  • myspell-sl_SI >= 20150827-5.1
  • myspell-sr >= 20150827-5.1
  • myspell-sv_SE >= 20150827-5.1
  • myspell-te_IN >= 20150827-5.1
  • myspell-th_TH >= 20150827-5.1
  • myspell-vi >= 20150827-5.1
  • myspell-zu_ZA >= 20150827-5.1
  • pentaho-libxml >= 1.1.3-4.3
  • pentaho-reporting-flow-engine >= 0.9.4-4.5
  • sac >= 1.3-4.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-797
SUSE Linux Enterprise Server 12
  • apache-commons-logging >= 1.1.3-7.1
  • graphite2 >= 1.3.1-3.1
  • libgraphite2-3 >= 1.3.1-3.1
  • libgraphite2-3-32bit >= 1.3.1-3.1
Patchnames:
SUSE-SLE-SERVER-12-2015-797
SUSE Linux Enterprise Server for SAP Applications 12
  • apache-commons-logging >= 1.1.3-7.1
  • graphite2 >= 1.3.1-3.1
  • libgraphite2-3 >= 1.3.1-3.1
  • libgraphite2-3-32bit >= 1.3.1-3.1
Patchnames:
SUSE-SLE-SERVER-12-2015-797
SUSE Linux Enterprise Software Development Kit 12
  • cmis-client >= 0.5.0-5.1
  • graphite2 >= 1.3.1-3.1
  • graphite2-devel >= 1.3.1-3.1
  • hyphen >= 2.8.8-9.1
  • hyphen-devel >= 2.8.8-9.1
  • libabw >= 0.1.1-5.3
  • libabw-devel >= 0.1.1-5.3
  • libabw-devel-doc >= 0.1.1-5.3
  • libcdr >= 0.1.1-5.3
  • libcdr-devel >= 0.1.1-5.3
  • libcdr-devel-doc >= 0.1.1-5.3
  • libcmis-0_5-5 >= 0.5.0-5.1
  • libcmis-c-0_5-5 >= 0.5.0-5.1
  • libcmis-c-devel >= 0.5.0-5.1
  • libcmis-devel >= 0.5.0-5.1
  • libe-book >= 0.1.2-4.2
  • libe-book-devel >= 0.1.2-4.2
  • libe-book-devel-doc >= 0.1.2-4.2
  • libetonyek >= 0.1.3-3.5
  • libetonyek-devel >= 0.1.3-3.5
  • libetonyek-devel-doc >= 0.1.3-3.5
  • libfreehand >= 0.1.1-4.9
  • libfreehand-devel >= 0.1.1-4.9
  • libfreehand-devel-doc >= 0.1.1-4.9
  • libhyphen0 >= 2.8.8-9.1
  • libixion >= 0.9.1-3.1
  • libixion-0_10-0 >= 0.9.1-3.1
  • libixion-devel >= 0.9.1-3.1
  • liblangtag >= 0.5.7-3.1
  • liblangtag-devel >= 0.5.7-3.1
  • liblangtag1 >= 0.5.7-3.1
  • libmspub >= 0.1.2-5.1
  • libmspub-devel >= 0.1.2-5.1
  • libmspub-devel-doc >= 0.1.2-5.1
  • libmwaw >= 0.3.6-3.3
  • libmwaw-devel >= 0.3.6-3.3
  • libmwaw-devel-doc >= 0.3.6-3.3
  • libodfgen >= 0.1.4-3.9
  • libodfgen-devel >= 0.1.4-3.9
  • libodfgen-devel-doc >= 0.1.4-3.9
  • liborcus >= 0.7.1-3.1
  • liborcus-devel >= 0.7.1-3.1
  • librevenge >= 0.0.2-4.1
  • librevenge-0_0-0 >= 0.0.2-4.1
  • librevenge-devel >= 0.0.2-4.1
  • librevenge-generators-0_0-0 >= 0.0.2-4.1
  • librevenge-stream-0_0-0 >= 0.0.2-4.1
  • libvisio >= 0.1.3-4.3
  • libvisio-devel >= 0.1.3-4.3
  • libvisio-devel-doc >= 0.1.3-4.3
  • libvoikko >= 3.7.1-3.1
  • libvoikko-devel >= 3.7.1-3.1
  • libvoikko1 >= 3.7.1-3.1
  • libwps >= 0.4.1-3.1
  • libwps-devel >= 0.4.1-3.1
  • malaga-suomi >= 1.18-3.2
Patchnames:
SUSE-SLE-SDK-12-2015-797
SUSE Linux Enterprise Workstation Extension 12
  • apache-commons-logging >= 1.1.3-7.1
  • cmis-client >= 0.5.0-5.1
  • flute >= 1.3.0-4.2
  • hyphen >= 2.8.8-9.1
  • libabw >= 0.1.1-5.3
  • libabw-0_1-1 >= 0.1.1-5.3
  • libbase >= 1.1.3-4.3
  • libcdr >= 0.1.1-5.3
  • libcdr-0_1-1 >= 0.1.1-5.3
  • libcmis-0_5-5 >= 0.5.0-5.1
  • libe-book >= 0.1.2-4.2
  • libe-book-0_1-1 >= 0.1.2-4.2
  • libetonyek >= 0.1.3-3.5
  • libetonyek-0_1-1 >= 0.1.3-3.5
  • libfonts >= 1.1.3-4.9
  • libformula >= 1.1.3-4.3
  • libfreehand >= 0.1.1-4.9
  • libfreehand-0_1-1 >= 0.1.1-4.9
  • libgltf >= 0.0.1-2.1
  • libgltf-0_0-0 >= 0.0.1-2.1
  • libhyphen0 >= 2.8.8-9.1
  • libixion >= 0.9.1-3.1
  • libixion-0_10-0 >= 0.9.1-3.1
  • liblangtag >= 0.5.7-3.1
  • liblangtag1 >= 0.5.7-3.1
  • liblayout >= 0.2.10-4.8
  • libloader >= 1.1.3-3.2
  • libmspub >= 0.1.2-5.1
  • libmspub-0_1-1 >= 0.1.2-5.1
  • libmwaw >= 0.3.6-3.3
  • libmwaw-0_3-3 >= 0.3.6-3.3
  • libodfgen >= 0.1.4-3.9
  • libodfgen-0_1-1 >= 0.1.4-3.9
  • liborcus >= 0.7.1-3.1
  • liborcus-0_8-0 >= 0.7.1-3.1
  • libpagemaker >= 0.0.2-2.3
  • libpagemaker-0_0-0 >= 0.0.2-2.3
  • libreoffice >= 5.0.2.2-13.14
  • libreoffice-base >= 5.0.2.2-13.14
  • libreoffice-base-drivers-mysql >= 5.0.2.2-13.14
  • libreoffice-base-drivers-postgresql >= 5.0.2.2-13.14
  • libreoffice-calc >= 5.0.2.2-13.14
  • libreoffice-calc-extensions >= 5.0.2.2-13.14
  • libreoffice-draw >= 5.0.2.2-13.14
  • libreoffice-filters-optional >= 5.0.2.2-13.14
  • libreoffice-gnome >= 5.0.2.2-13.14
  • libreoffice-icon-theme-tango >= 5.0.2.2-13.14
  • libreoffice-impress >= 5.0.2.2-13.14
  • libreoffice-l10n-af >= 5.0.2.2-13.14
  • libreoffice-l10n-ar >= 5.0.2.2-13.14
  • libreoffice-l10n-ca >= 5.0.2.2-13.14
  • libreoffice-l10n-cs >= 5.0.2.2-13.14
  • libreoffice-l10n-da >= 5.0.2.2-13.14
  • libreoffice-l10n-de >= 5.0.2.2-13.14
  • libreoffice-l10n-en >= 5.0.2.2-13.14
  • libreoffice-l10n-es >= 5.0.2.2-13.14
  • libreoffice-l10n-fi >= 5.0.2.2-13.14
  • libreoffice-l10n-fr >= 5.0.2.2-13.14
  • libreoffice-l10n-gu >= 5.0.2.2-13.14
  • libreoffice-l10n-hi >= 5.0.2.2-13.14
  • libreoffice-l10n-hu >= 5.0.2.2-13.14
  • libreoffice-l10n-it >= 5.0.2.2-13.14
  • libreoffice-l10n-ja >= 5.0.2.2-13.14
  • libreoffice-l10n-ko >= 5.0.2.2-13.14
  • libreoffice-l10n-nb >= 5.0.2.2-13.14
  • libreoffice-l10n-nl >= 5.0.2.2-13.14
  • libreoffice-l10n-nn >= 5.0.2.2-13.14
  • libreoffice-l10n-pl >= 5.0.2.2-13.14
  • libreoffice-l10n-pt-BR >= 5.0.2.2-13.14
  • libreoffice-l10n-pt-PT >= 5.0.2.2-13.14
  • libreoffice-l10n-ru >= 5.0.2.2-13.14
  • libreoffice-l10n-sk >= 5.0.2.2-13.14
  • libreoffice-l10n-sv >= 5.0.2.2-13.14
  • libreoffice-l10n-xh >= 5.0.2.2-13.14
  • libreoffice-l10n-zh-Hans >= 5.0.2.2-13.14
  • libreoffice-l10n-zh-Hant >= 5.0.2.2-13.14
  • libreoffice-l10n-zu >= 5.0.2.2-13.14
  • libreoffice-mailmerge >= 5.0.2.2-13.14
  • libreoffice-math >= 5.0.2.2-13.14
  • libreoffice-officebean >= 5.0.2.2-13.14
  • libreoffice-pyuno >= 5.0.2.2-13.14
  • libreoffice-share-linker >= 1-2.1
  • libreoffice-voikko >= 4.1-6.3
  • libreoffice-writer >= 5.0.2.2-13.14
  • libreoffice-writer-extensions >= 5.0.2.2-13.14
  • librepository >= 1.1.3-4.3
  • librevenge >= 0.0.2-4.1
  • librevenge-0_0-0 >= 0.0.2-4.1
  • librevenge-stream-0_0-0 >= 0.0.2-4.1
  • libserializer >= 1.1.2-4.3
  • libvisio >= 0.1.3-4.3
  • libvisio-0_1-1 >= 0.1.3-4.3
  • libvoikko >= 3.7.1-3.1
  • libvoikko1 >= 3.7.1-3.1
  • libwps >= 0.4.1-3.1
  • libwps-0_4-4 >= 0.4.1-3.1
  • malaga-suomi >= 1.18-3.2
  • myspell-af_ZA >= 20150827-5.1
  • myspell-ar >= 20150827-5.1
  • myspell-be_BY >= 20150827-5.1
  • myspell-bg_BG >= 20150827-5.1
  • myspell-bn_BD >= 20150827-5.1
  • myspell-bs_BA >= 20150827-5.1
  • myspell-ca >= 20150827-5.1
  • myspell-cs_CZ >= 20150827-5.1
  • myspell-da_DK >= 20150827-5.1
  • myspell-de >= 20150827-5.1
  • myspell-dictionaries >= 20150827-5.1
  • myspell-el_GR >= 20150827-5.1
  • myspell-en >= 20150827-5.1
  • myspell-es >= 20150827-5.1
  • myspell-et_EE >= 20150827-5.1
  • myspell-fr_FR >= 20150827-5.1
  • myspell-gu_IN >= 20150827-5.1
  • myspell-he_IL >= 20150827-5.1
  • myspell-hi_IN >= 20150827-5.1
  • myspell-hr_HR >= 20150827-5.1
  • myspell-hu_HU >= 20150827-5.1
  • myspell-it_IT >= 20150827-5.1
  • myspell-lo_LA >= 20150827-5.1
  • myspell-lt_LT >= 20150827-5.1
  • myspell-lv_LV >= 20150827-5.1
  • myspell-nl_NL >= 20150827-5.1
  • myspell-no >= 20150827-5.1
  • myspell-pl_PL >= 20150827-5.1
  • myspell-pt_BR >= 20150827-5.1
  • myspell-pt_PT >= 20150827-5.1
  • myspell-ro >= 20150827-5.1
  • myspell-ru_RU >= 20150827-5.1
  • myspell-sk_SK >= 20150827-5.1
  • myspell-sl_SI >= 20150827-5.1
  • myspell-sr >= 20150827-5.1
  • myspell-sv_SE >= 20150827-5.1
  • myspell-te_IN >= 20150827-5.1
  • myspell-th_TH >= 20150827-5.1
  • myspell-vi >= 20150827-5.1
  • myspell-zu_ZA >= 20150827-5.1
  • pentaho-libxml >= 1.1.3-4.3
  • pentaho-reporting-flow-engine >= 0.9.4-4.5
  • sac >= 1.3-4.1
Patchnames:
SUSE-SLE-WE-12-2015-797


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 GA libreoffice Released
SUSE Linux Enterprise BSK 12 SP1 libreoffice Released
SUSE Linux Enterprise Desktop 11 SP3 libreoffice Ignore
SUSE Linux Enterprise Desktop 12 GA libreoffice Released
SUSE Linux Enterprise Desktop 12 SP1 libreoffice Released
SUSE Linux Enterprise SDK 11 SP3 libreoffice Ignore
SUSE Linux Enterprise Workstation Extension 12 GA libreoffice Released