Upstream information

CVE-2015-1572 at MITRE

Description

Heap-based buffer overflow in closefs.c in the libext2fs library in e2fsprogs before 1.42.12 allows local users to execute arbitrary code by causing a crafted block group descriptor to be marked as dirty. NOTE: this vulnerability exists because of an incomplete fix for CVE-2015-0247.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 915402 [RESOLVED], 918346 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libblkid1-32bit >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libcom_err2-32bit >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid-devel >= 2.19.1-6.62.7
  • libuuid1 >= 2.19.1-6.62.7
  • libuuid1-32bit >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Patchnames:
sledsp3-e2fsprogs
SUSE Linux Enterprise Desktop 12
  • e2fsprogs >= 1.42.11-7.1
  • libcom_err2 >= 1.42.11-7.1
  • libcom_err2-32bit >= 1.42.11-7.1
  • libext2fs2 >= 1.42.11-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-366
SUSE Linux Enterprise Desktop 12 SP1
  • e2fsprogs >= 1.42.11-7.1
  • libcom_err2 >= 1.42.11-7.1
  • libcom_err2-32bit >= 1.42.11-7.1
  • libext2fs2 >= 1.42.11-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA e2fsprogs
SUSE Linux Enterprise Desktop 12 SP2
  • e2fsprogs >= 1.42.11-7.1
  • libcom_err2 >= 1.42.11-7.1
  • libcom_err2-32bit >= 1.42.11-7.1
  • libext2fs2 >= 1.42.11-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA e2fsprogs
SUSE Linux Enterprise Desktop 12 SP3
  • e2fsprogs >= 1.42.11-15.1
  • libcom_err2 >= 1.42.11-15.1
  • libcom_err2-32bit >= 1.42.11-15.1
  • libext2fs2 >= 1.42.11-15.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA e2fsprogs
SUSE Linux Enterprise Module for Basesystem 15
  • e2fsprogs >= 1.43.8-4.3.1
  • e2fsprogs-devel >= 1.43.8-4.3.1
  • libcom_err-devel >= 1.43.8-4.3.1
  • libcom_err-devel-static >= 1.43.8-4.3.1
  • libcom_err2 >= 1.43.8-4.3.1
  • libcom_err2-32bit >= 1.43.8-4.3.1
  • libext2fs-devel >= 1.43.8-4.3.1
  • libext2fs-devel-static >= 1.43.8-4.3.1
  • libext2fs2 >= 1.43.8-4.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1353
SUSE Linux Enterprise Server 11 SP3
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libblkid1-32bit >= 2.19.1-6.62.7
  • libblkid1-x86 >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libcom_err2-32bit >= 1.41.9-2.10.11.1
  • libcom_err2-x86 >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid1 >= 2.19.1-6.62.7
  • libuuid1-32bit >= 2.19.1-6.62.7
  • libuuid1-x86 >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Patchnames:
slessp3-e2fsprogs
SUSE Linux Enterprise Server 11 SP4
  • e2fsprogs >= 1.41.9-2.14.3
  • libcom_err2 >= 1.41.9-2.14.3
  • libcom_err2-32bit >= 1.41.9-2.14.3
  • libcom_err2-x86 >= 1.41.9-2.14.3
  • libext2fs2 >= 1.41.9-2.14.3
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA e2fsprogs
SUSE Linux Enterprise Server 12
  • e2fsprogs >= 1.42.11-7.1
  • libcom_err2 >= 1.42.11-7.1
  • libcom_err2-32bit >= 1.42.11-7.1
  • libext2fs2 >= 1.42.11-7.1
Patchnames:
SUSE-SLE-SERVER-12-2015-366
SUSE Linux Enterprise Server 12 SP1
  • e2fsprogs >= 1.42.11-7.1
  • libcom_err2 >= 1.42.11-7.1
  • libcom_err2-32bit >= 1.42.11-7.1
  • libext2fs2 >= 1.42.11-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA e2fsprogs
SUSE Linux Enterprise Server 12 SP2
  • e2fsprogs >= 1.42.11-7.1
  • libcom_err2 >= 1.42.11-7.1
  • libcom_err2-32bit >= 1.42.11-7.1
  • libext2fs2 >= 1.42.11-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA e2fsprogs
SUSE Linux Enterprise Server 12 SP3
  • e2fsprogs >= 1.42.11-15.1
  • libcom_err2 >= 1.42.11-15.1
  • libcom_err2-32bit >= 1.42.11-15.1
  • libext2fs2 >= 1.42.11-15.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA e2fsprogs
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • e2fsprogs >= 1.42.11-7.1
  • libcom_err2 >= 1.42.11-7.1
  • libext2fs2 >= 1.42.11-7.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA e2fsprogs
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libblkid1-32bit >= 2.19.1-6.62.7
  • libblkid1-x86 >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libcom_err2-32bit >= 1.41.9-2.10.11.1
  • libcom_err2-x86 >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid1 >= 2.19.1-6.62.7
  • libuuid1-32bit >= 2.19.1-6.62.7
  • libuuid1-x86 >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Patchnames:
slessp3-e2fsprogs
SUSE Linux Enterprise Server for SAP Applications 12
  • e2fsprogs >= 1.42.11-7.1
  • libcom_err2 >= 1.42.11-7.1
  • libcom_err2-32bit >= 1.42.11-7.1
  • libext2fs2 >= 1.42.11-7.1
Patchnames:
SUSE-SLE-SERVER-12-2015-366
SUSE Linux Enterprise Server for VMWare 11 SP3
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libblkid1-32bit >= 2.19.1-6.62.7
  • libblkid1-x86 >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libcom_err2-32bit >= 1.41.9-2.10.11.1
  • libcom_err2-x86 >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid1 >= 2.19.1-6.62.7
  • libuuid1-32bit >= 2.19.1-6.62.7
  • libuuid1-x86 >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Patchnames:
slessp3-e2fsprogs
SUSE Linux Enterprise Software Development Kit 11 SP3
  • e2fsprogs-devel >= 1.41.9-2.10.11.1
  • libblkid-devel >= 2.19.1-6.62.7
  • libblkid-devel-32bit >= 2.19.1-6.62.7
  • libcom_err-devel >= 1.41.9-2.10.11.1
  • libcom_err-devel-32bit >= 1.41.9-2.10.11.1
  • libext2fs-devel >= 1.41.9-2.10.11.1
  • libext2fs-devel-32bit >= 1.41.9-2.10.11.1
  • libext2fs2-32bit >= 1.41.9-2.10.11.1
  • libext2fs2-x86 >= 1.41.9-2.10.11.1
  • libuuid-devel >= 2.19.1-6.62.7
  • libuuid-devel-32bit >= 2.19.1-6.62.7
Patchnames:
sdksp3-e2fsprogs
SUSE Linux Enterprise Software Development Kit 11 SP4
  • e2fsprogs-devel >= 1.41.9-2.14.3
  • libcom_err-devel >= 1.41.9-2.14.3
  • libcom_err-devel-32bit >= 1.41.9-2.14.3
  • libext2fs-devel >= 1.41.9-2.14.3
  • libext2fs-devel-32bit >= 1.41.9-2.14.3
  • libext2fs2-32bit >= 1.41.9-2.14.3
  • libext2fs2-x86 >= 1.41.9-2.14.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA e2fsprogs-devel
SUSE Linux Enterprise Software Development Kit 12
  • e2fsprogs >= 1.42.11-7.1
  • e2fsprogs-devel >= 1.42.11-7.1
  • libcom_err-devel >= 1.42.11-7.1
  • libext2fs-devel >= 1.42.11-7.1
Patchnames:
SUSE-SLE-SDK-12-2015-366
SUSE Linux Enterprise Software Development Kit 12 SP1
  • e2fsprogs-devel >= 1.42.11-7.1
  • libcom_err-devel >= 1.42.11-7.1
  • libext2fs-devel >= 1.42.11-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA e2fsprogs-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • e2fsprogs-devel >= 1.42.11-7.1
  • libcom_err-devel >= 1.42.11-7.1
  • libext2fs-devel >= 1.42.11-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA e2fsprogs-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • e2fsprogs-devel >= 1.42.11-15.1
  • libcom_err-devel >= 1.42.11-15.1
  • libext2fs-devel >= 1.42.11-15.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA e2fsprogs-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • e2fsprogs-devel >= 1.41.9-2.10.11.1
  • libblkid-devel >= 2.19.1-6.62.7
  • libcom_err-devel >= 1.41.9-2.10.11.1
  • libext2fs-devel >= 1.41.9-2.10.11.1
  • libuuid-devel >= 2.19.1-6.62.7
Builds
SAT Patch Nr: 10815
SUSE Linux Enterprise Software Development Kit 11 SP3
  • e2fsprogs-devel >= 1.41.9-2.10.11.1
  • libblkid-devel >= 2.19.1-6.62.7
  • libcom_err-devel >= 1.41.9-2.10.11.1
  • libext2fs-devel >= 1.41.9-2.10.11.1
  • libext2fs2-x86 >= 1.41.9-2.10.11.1
  • libuuid-devel >= 2.19.1-6.62.7
Builds
SAT Patch Nr: 10815
SUSE Linux Enterprise Software Development Kit 11 SP3
  • e2fsprogs-devel >= 1.41.9-2.10.11.1
  • libblkid-devel >= 2.19.1-6.62.7
  • libblkid-devel-32bit >= 2.19.1-6.62.7
  • libcom_err-devel >= 1.41.9-2.10.11.1
  • libcom_err-devel-32bit >= 1.41.9-2.10.11.1
  • libext2fs-devel >= 1.41.9-2.10.11.1
  • libext2fs-devel-32bit >= 1.41.9-2.10.11.1
  • libext2fs2-32bit >= 1.41.9-2.10.11.1
  • libuuid-devel >= 2.19.1-6.62.7
  • libuuid-devel-32bit >= 2.19.1-6.62.7
Builds
SAT Patch Nr: 10815
SUSE Linux Enterprise Desktop 11 SP3
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid-devel >= 2.19.1-6.62.7
  • libuuid1 >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Builds
SAT Patch Nr: 10815
SUSE Linux Enterprise Desktop 11 SP3
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libblkid1-32bit >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libcom_err2-32bit >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid-devel >= 2.19.1-6.62.7
  • libuuid1 >= 2.19.1-6.62.7
  • libuuid1-32bit >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Builds
SAT Patch Nr: 10815
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libblkid1-32bit >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libcom_err2-32bit >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid1 >= 2.19.1-6.62.7
  • libuuid1-32bit >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Builds
SAT Patch Nr: 10815
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid1 >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Builds
SAT Patch Nr: 10815
SUSE Linux Enterprise Server 11 SP3
  • e2fsprogs >= 1.41.9-2.10.11.1
  • libblkid1 >= 2.19.1-6.62.7
  • libblkid1-x86 >= 2.19.1-6.62.7
  • libcom_err2 >= 1.41.9-2.10.11.1
  • libcom_err2-x86 >= 1.41.9-2.10.11.1
  • libext2fs2 >= 1.41.9-2.10.11.1
  • libuuid1 >= 2.19.1-6.62.7
  • libuuid1-x86 >= 2.19.1-6.62.7
  • uuid-runtime >= 2.19.1-6.62.7
Builds
SAT Patch Nr: 10815
openSUSE 13.1
  • e2fsprogs >= 1.42.8-2.8.1
  • e2fsprogs-debuginfo >= 1.42.8-2.8.1
  • e2fsprogs-debuginfo-32bit >= 1.42.8-2.8.1
  • e2fsprogs-debugsource >= 1.42.8-2.8.1
  • e2fsprogs-devel >= 1.42.8-2.8.1
  • libcom_err-devel >= 1.42.8-2.8.1
  • libcom_err-devel-32bit >= 1.42.8-2.8.1
  • libcom_err2 >= 1.42.8-2.8.1
  • libcom_err2-32bit >= 1.42.8-2.8.1
  • libcom_err2-debuginfo >= 1.42.8-2.8.1
  • libcom_err2-debuginfo-32bit >= 1.42.8-2.8.1
  • libext2fs-devel >= 1.42.8-2.8.1
  • libext2fs-devel-32bit >= 1.42.8-2.8.1
  • libext2fs2 >= 1.42.8-2.8.1
  • libext2fs2-32bit >= 1.42.8-2.8.1
  • libext2fs2-debuginfo >= 1.42.8-2.8.1
  • libext2fs2-debuginfo-32bit >= 1.42.8-2.8.1
Patchnames:
openSUSE-2015-400
openSUSE Leap 15.0
  • e2fsprogs >= 1.43.8-lp150.3.3.1
  • e2fsprogs-32bit-debuginfo >= 1.43.8-lp150.3.3.1
  • e2fsprogs-debuginfo >= 1.43.8-lp150.3.3.1
  • e2fsprogs-debugsource >= 1.43.8-lp150.3.3.1
  • e2fsprogs-devel >= 1.43.8-lp150.3.3.1
  • libcom_err-devel >= 1.43.8-lp150.3.3.1
  • libcom_err-devel-32bit >= 1.43.8-lp150.3.3.1
  • libcom_err-devel-static >= 1.43.8-lp150.3.3.1
  • libcom_err2 >= 1.43.8-lp150.3.3.1
  • libcom_err2-32bit >= 1.43.8-lp150.3.3.1
  • libcom_err2-32bit-debuginfo >= 1.43.8-lp150.3.3.1
  • libcom_err2-debuginfo >= 1.43.8-lp150.3.3.1
  • libext2fs-devel >= 1.43.8-lp150.3.3.1
  • libext2fs-devel-32bit >= 1.43.8-lp150.3.3.1
  • libext2fs-devel-static >= 1.43.8-lp150.3.3.1
  • libext2fs2 >= 1.43.8-lp150.3.3.1
  • libext2fs2-32bit >= 1.43.8-lp150.3.3.1
  • libext2fs2-32bit-debuginfo >= 1.43.8-lp150.3.3.1
  • libext2fs2-debuginfo >= 1.43.8-lp150.3.3.1
Patchnames:
openSUSE-2018-771
openSUSE Leap 42.1
  • e2fsprogs >= 1.42.11-10.2
  • e2fsprogs-devel >= 1.42.11-10.2
  • libcom_err-devel >= 1.42.11-10.2
  • libcom_err2 >= 1.42.11-10.2
  • libcom_err2-32bit >= 1.42.11-10.2
  • libext2fs-devel >= 1.42.11-10.2
  • libext2fs2 >= 1.42.11-10.2
Patchnames:
openSUSE Leap 42.1 GA e2fsprogs
openSUSE Leap 42.2
  • e2fsprogs >= 1.42.11-11.4
  • e2fsprogs-devel >= 1.42.11-11.4
  • libcom_err-devel >= 1.42.11-11.4
  • libcom_err2 >= 1.42.11-11.4
  • libcom_err2-32bit >= 1.42.11-11.4
  • libext2fs-devel >= 1.42.11-11.4
  • libext2fs2 >= 1.42.11-11.4
Patchnames:
openSUSE Leap 42.2 GA e2fsprogs
openSUSE Leap 42.3
  • e2fsprogs >= 1.42.11-15.1
  • e2fsprogs-devel >= 1.42.11-15.1
  • libcom_err-devel >= 1.42.11-15.1
  • libcom_err2 >= 1.42.11-15.1
  • libcom_err2-32bit >= 1.42.11-15.1
  • libext2fs-devel >= 1.42.11-15.1
  • libext2fs2 >= 1.42.11-15.1
Patchnames:
openSUSE Leap 42.3 GA e2fsprogs


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 e2fsprogs Released
SUSE Linux Enterprise Desktop 11 SP1 e2fsprogs Released
SUSE Linux Enterprise Desktop 11 SP3 e2fsprogs Released
SUSE Linux Enterprise Desktop 11 SP4 e2fsprogs Released
SUSE Linux Enterprise Desktop 12 GA e2fsprogs Released
SUSE Linux Enterprise Desktop 12 SP1 e2fsprogs Released
SUSE Linux Enterprise Module for Basesystem 15 GA e2fsprogs Released
SUSE Linux Enterprise SDK 11 SP1 e2fsprogs Released
SUSE Linux Enterprise SDK 11 SP3 e2fsprogs Released
SUSE Linux Enterprise SDK 11 SP4 e2fsprogs Released
SUSE Linux Enterprise SDK 12 GA e2fsprogs Released
SUSE Linux Enterprise Server 10 SP3 e2fsprogs Released
SUSE Linux Enterprise Server 11 SP1 e2fsprogs Released
SUSE Linux Enterprise Server 11 SP1 LTSS e2fsprogs Released
SUSE Linux Enterprise Server 11 SP3 e2fsprogs Released
SUSE Linux Enterprise Server 11 SP4 e2fsprogs Released
SUSE Linux Enterprise Server 12 GA e2fsprogs Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 e2fsprogs Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 e2fsprogs Released
SUSE Linux Enterprise Server for VMWare 11 SP3 e2fsprogs Released
SUSE Studio Onsite 1.3 e2fsprogs Released