Upstream information

CVE-2015-1473 at MITRE

Description

The ADDW macro in stdio-common/vfscanf.c in the GNU C Library (aka glibc or libc6) before 2.21 does not properly consider data-type size during a risk-management decision for use of the alloca function, which might allow context-dependent attackers to cause a denial of service (segmentation violation) or overwrite memory locations beyond the stack boundary via a long line containing wide characters that are improperly handled in a wscanf call.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.4
Vector AV:N/AC:L/Au:N/C:N/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact Partial

Note from the SUSE Security Team

This issue only affected the glibc 2.19 in SUSE Linux Enterprise 12 GA, and was fixed together with the update for CVE-2015-1472. SUSE Linux Enterprise 11 and older products did not contain the erronoeous size calculation and were not affected by this problem.

SUSE Bugzilla entries: 916222 [RESOLVED], 920341 [RESOLVED], 922243 [RESOLVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • glibc >= 2.22-49.16
  • glibc-32bit >= 2.22-49.16
  • glibc-devel >= 2.22-49.16
  • glibc-devel-32bit >= 2.22-49.16
  • glibc-i18ndata >= 2.22-49.16
  • glibc-locale >= 2.22-49.16
  • glibc-locale-32bit >= 2.22-49.16
  • nscd >= 2.22-49.16
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA glibc
SUSE Linux Enterprise Desktop 12 SP3
  • glibc >= 2.22-61.3
  • glibc-32bit >= 2.22-61.3
  • glibc-devel >= 2.22-61.3
  • glibc-devel-32bit >= 2.22-61.3
  • glibc-i18ndata >= 2.22-61.3
  • glibc-locale >= 2.22-61.3
  • glibc-locale-32bit >= 2.22-61.3
  • nscd >= 2.22-61.3
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA glibc
SUSE Linux Enterprise Module for Basesystem 15
  • glibc >= 2.26-11.8
  • glibc-32bit >= 2.26-11.8
  • glibc-devel >= 2.26-11.8
  • glibc-extra >= 2.26-11.8
  • glibc-i18ndata >= 2.26-11.8
  • glibc-info >= 2.26-11.8
  • glibc-locale >= 2.26-11.8
  • glibc-locale-32bit >= 2.26-11.8
  • glibc-profile >= 2.26-11.8
  • nscd >= 2.26-11.8
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA glibc
SUSE Linux Enterprise Module for Development Tools 15
  • glibc-devel-32bit >= 2.26-11.8
  • glibc-devel-static >= 2.26-11.8
  • glibc-utils >= 2.26-11.8
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA glibc-devel-32bit
SUSE Linux Enterprise Server 12 SP2
  • glibc >= 2.22-49.16
  • glibc-32bit >= 2.22-49.16
  • glibc-devel >= 2.22-49.16
  • glibc-devel-32bit >= 2.22-49.16
  • glibc-html >= 2.22-49.16
  • glibc-i18ndata >= 2.22-49.16
  • glibc-info >= 2.22-49.16
  • glibc-locale >= 2.22-49.16
  • glibc-locale-32bit >= 2.22-49.16
  • glibc-profile >= 2.22-49.16
  • glibc-profile-32bit >= 2.22-49.16
  • nscd >= 2.22-49.16
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA glibc
SUSE Linux Enterprise Server 12 SP3
  • glibc >= 2.22-61.3
  • glibc-32bit >= 2.22-61.3
  • glibc-devel >= 2.22-61.3
  • glibc-devel-32bit >= 2.22-61.3
  • glibc-html >= 2.22-61.3
  • glibc-i18ndata >= 2.22-61.3
  • glibc-info >= 2.22-61.3
  • glibc-locale >= 2.22-61.3
  • glibc-locale-32bit >= 2.22-61.3
  • glibc-profile >= 2.22-61.3
  • glibc-profile-32bit >= 2.22-61.3
  • nscd >= 2.22-61.3
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA glibc
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • glibc >= 2.22-49.16
  • glibc-devel >= 2.22-49.16
  • glibc-html >= 2.22-49.16
  • glibc-i18ndata >= 2.22-49.16
  • glibc-info >= 2.22-49.16
  • glibc-locale >= 2.22-49.16
  • glibc-profile >= 2.22-49.16
  • nscd >= 2.22-49.16
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA glibc
SUSE Linux Enterprise Software Development Kit 12 SP2
  • glibc-devel-static >= 2.22-49.16
  • glibc-info >= 2.22-49.16
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA glibc-devel-static
SUSE Linux Enterprise Software Development Kit 12 SP3
  • glibc-devel-static >= 2.22-61.3
  • glibc-info >= 2.22-61.3
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA glibc-devel-static
openSUSE Leap 15.0
  • glibc >= 2.26-lp150.10.13
  • glibc-32bit >= 2.26-lp150.10.13
  • glibc-extra >= 2.26-lp150.10.13
  • glibc-locale >= 2.26-lp150.10.13
  • glibc-locale-32bit >= 2.26-lp150.10.13
  • nscd >= 2.26-lp150.10.13
Patchnames:
openSUSE Leap 15.0 GA glibc
openSUSE Leap 42.2
  • glibc >= 2.22-3.7
  • glibc-32bit >= 2.22-3.7
  • glibc-devel >= 2.22-3.7
  • glibc-extra >= 2.22-3.7
  • glibc-info >= 2.22-3.7
  • glibc-locale >= 2.22-3.7
  • glibc-locale-32bit >= 2.22-3.7
  • nscd >= 2.22-3.7
Patchnames:
openSUSE Leap 42.2 GA glibc
openSUSE Leap 42.3
  • glibc >= 2.22-8.4
  • glibc-32bit >= 2.22-8.4
  • glibc-devel >= 2.22-8.4
  • glibc-extra >= 2.22-8.4
  • glibc-info >= 2.22-8.4
  • glibc-locale >= 2.22-8.4
  • glibc-locale-32bit >= 2.22-8.4
  • nscd >= 2.22-8.4
Patchnames:
openSUSE Leap 42.3 GA glibc
openSUSE Tumbleweed
  • glibc >= 2.24-2.3
  • glibc-32bit >= 2.24-2.3
  • glibc-devel >= 2.24-2.3
  • glibc-devel-32bit >= 2.24-2.3
  • glibc-devel-static >= 2.24-2.3
  • glibc-devel-static-32bit >= 2.24-2.3
  • glibc-extra >= 2.24-2.3
  • glibc-html >= 2.24-2.3
  • glibc-i18ndata >= 2.24-2.3
  • glibc-info >= 2.24-2.3
  • glibc-locale >= 2.24-2.3
  • glibc-locale-32bit >= 2.24-2.3
  • glibc-obsolete >= 2.24-2.3
  • glibc-profile >= 2.24-2.3
  • glibc-profile-32bit >= 2.24-2.3
  • glibc-utils >= 2.24-2.3
  • glibc-utils-32bit >= 2.24-2.3
  • nscd >= 2.24-2.3
Patchnames:
openSUSE Tumbleweed GA glibc


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 glibc Released
SUSE Linux Enterprise Desktop 10 SP4 glibc Released
SUSE Linux Enterprise Desktop 11 SP1 glibc Released
SUSE Linux Enterprise Desktop 11 SP2 glibc Released
SUSE Linux Enterprise Desktop 11 SP3 glibc Released
SUSE Linux Enterprise Desktop 11 SP4 glibc Released
SUSE Linux Enterprise Desktop 12 GA glibc Released
SUSE Linux Enterprise SDK 11 SP1 glibc Released
SUSE Linux Enterprise SDK 11 SP2 glibc Released
SUSE Linux Enterprise SDK 11 SP3 glibc Released
SUSE Linux Enterprise SDK 11 SP4 glibc Released
SUSE Linux Enterprise SDK 12 GA glibc Released
SUSE Linux Enterprise Server 10 SP3 glibc Released
SUSE Linux Enterprise Server 10 SP4 glibc Released
SUSE Linux Enterprise Server 10 SP4 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP1 glibc Released
SUSE Linux Enterprise Server 11 SP1 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP2 glibc Released
SUSE Linux Enterprise Server 11 SP2 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP3 glibc Released
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Released
SUSE Linux Enterprise Server 11 SP4 glibc Released
SUSE Linux Enterprise Server 12 GA glibc Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 glibc Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 glibc Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 glibc Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 glibc Released
SUSE Linux Enterprise Server for VMWare 11 SP2 glibc Released
SUSE Linux Enterprise Server for VMWare 11 SP3 glibc Released