Upstream information

CVE-2015-1465 at MITRE

Description

The IPv4 implementation in the Linux kernel before 3.18.8 does not properly consider the length of the Read-Copy Update (RCU) grace period for redirecting lookups in the absence of caching, which allows remote attackers to cause a denial of service (memory consumption or system crash) via a flood of packets.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete

Note from the SUSE Security Team

This issue only affects Linux Kernels down to 3.7, so SUSE Linux Enterprise Server 11 and older products are not affected. The Linux kernel 3.12.38 received this fix, so SUSE Linux Enterprise 12 is fixed with current updates.

SUSE Bugzilla entry: 916225 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12
  • kernel-zfcpdump >= 3.12.43-52.6.1
Patchnames:
SUSE-SLE-BSK-12-2015-269
SUSE Linux Enterprise Desktop 12
  • kernel-default >= 3.12.43-52.6.1
  • kernel-default-devel >= 3.12.43-52.6.1
  • kernel-default-extra >= 3.12.43-52.6.1
  • kernel-devel >= 3.12.43-52.6.1
  • kernel-macros >= 3.12.43-52.6.1
  • kernel-source >= 3.12.43-52.6.1
  • kernel-syms >= 3.12.43-52.6.1
  • kernel-xen >= 3.12.43-52.6.1
  • kernel-xen-devel >= 3.12.43-52.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-269
SUSE Linux Enterprise Desktop 12 SP1
  • kernel-default >= 3.12.49-11.1
  • kernel-default-devel >= 3.12.49-11.1
  • kernel-default-extra >= 3.12.49-11.1
  • kernel-devel >= 3.12.49-11.1
  • kernel-macros >= 3.12.49-11.1
  • kernel-source >= 3.12.49-11.1
  • kernel-syms >= 3.12.49-11.1
  • kernel-xen >= 3.12.49-11.1
  • kernel-xen-devel >= 3.12.49-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA kernel-default
SUSE Linux Enterprise Live Patching 12
  • kgraft-patch-3_12_32-33-default >= 3-2.1
  • kgraft-patch-3_12_32-33-xen >= 3-2.1
  • kgraft-patch-3_12_36-38-default >= 3-2.1
  • kgraft-patch-3_12_36-38-xen >= 3-2.1
  • kgraft-patch-3_12_43-52_6-default >= 1-2.3
  • kgraft-patch-3_12_43-52_6-xen >= 1-2.3
  • kgraft-patch-SLE12_Update_1 >= 3-2.1
  • kgraft-patch-SLE12_Update_2 >= 3-2.1
  • kgraft-patch-SLE12_Update_5 >= 1-2.3
Patchnames:
SUSE-SLE-Live-Patching-12-2015-269
SUSE-SLE-Live-Patching-12-2015-484
SUSE-SLE-Live-Patching-12-2015-485
SUSE Linux Enterprise Module for Public Cloud 12
  • kernel-ec2 >= 3.12.43-52.6.1
  • kernel-ec2-devel >= 3.12.43-52.6.1
  • kernel-ec2-extra >= 3.12.43-52.6.1
Patchnames:
SUSE-SLE-Module-Public-Cloud-12-2015-269
SUSE Linux Enterprise Server 12
  • kernel-default >= 3.12.43-52.6.1
  • kernel-default-base >= 3.12.43-52.6.1
  • kernel-default-devel >= 3.12.43-52.6.1
  • kernel-default-man >= 3.12.43-52.6.1
  • kernel-devel >= 3.12.43-52.6.1
  • kernel-macros >= 3.12.43-52.6.1
  • kernel-source >= 3.12.43-52.6.1
  • kernel-syms >= 3.12.43-52.6.1
  • kernel-xen >= 3.12.43-52.6.1
  • kernel-xen-base >= 3.12.43-52.6.1
  • kernel-xen-devel >= 3.12.43-52.6.1
Patchnames:
SUSE-SLE-SERVER-12-2015-269
SUSE Linux Enterprise Server 12 SP1
  • kernel-default >= 3.12.49-11.1
  • kernel-default-base >= 3.12.49-11.1
  • kernel-default-devel >= 3.12.49-11.1
  • kernel-default-man >= 3.12.49-11.1
  • kernel-devel >= 3.12.49-11.1
  • kernel-macros >= 3.12.49-11.1
  • kernel-source >= 3.12.49-11.1
  • kernel-syms >= 3.12.49-11.1
  • kernel-xen >= 3.12.49-11.1
  • kernel-xen-base >= 3.12.49-11.1
  • kernel-xen-devel >= 3.12.49-11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA kernel-default
SUSE Linux Enterprise Server for SAP Applications 12
  • kernel-default >= 3.12.43-52.6.1
  • kernel-default-base >= 3.12.43-52.6.1
  • kernel-default-devel >= 3.12.43-52.6.1
  • kernel-default-man >= 3.12.43-52.6.1
  • kernel-devel >= 3.12.43-52.6.1
  • kernel-macros >= 3.12.43-52.6.1
  • kernel-source >= 3.12.43-52.6.1
  • kernel-syms >= 3.12.43-52.6.1
  • kernel-xen >= 3.12.43-52.6.1
  • kernel-xen-base >= 3.12.43-52.6.1
  • kernel-xen-devel >= 3.12.43-52.6.1
Patchnames:
SUSE-SLE-SERVER-12-2015-269
SUSE Linux Enterprise Software Development Kit 12
  • kernel-docs >= 3.12.43-52.6.2
  • kernel-obs-build >= 3.12.43-52.6.2
Patchnames:
SUSE-SLE-SDK-12-2015-269
SUSE Linux Enterprise Software Development Kit 12 SP1
  • kernel-docs >= 3.12.49-11.1
  • kernel-obs-build >= 3.12.49-11.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA kernel-docs
SUSE Linux Enterprise Workstation Extension 12
  • kernel-default >= 3.12.43-52.6.1
  • kernel-default-extra >= 3.12.43-52.6.1
Patchnames:
SUSE-SLE-WE-12-2015-269
SUSE Linux Enterprise Workstation Extension 12 SP1
  • kernel-default-extra >= 3.12.49-11.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA kernel-default-extra


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP2 php53 Released
SUSE Linux Enterprise SDK 11 SP3 php53 Affected
SUSE Linux Enterprise SDK 11 SP4 php53 Affected
SUSE Linux Enterprise Server 11 SP2 php53 Released
SUSE Linux Enterprise Server 11 SP2 LTSS php53 Released
SUSE Linux Enterprise Server 11 SP3 php53 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS php53 Affected
SUSE Linux Enterprise Server 11 SP4 php53 Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 php53 Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 php53 Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 php53 Released
SUSE Linux Enterprise Server for VMWare 11 SP3 php53 Affected