Upstream information

CVE-2015-1031 at MITRE

Description

Multiple use-after-free vulnerabilities in Privoxy before 3.0.22 allow remote attackers to have unspecified impact via vectors related to (1) the unmap function in list.c or (2) "two additional unconfirmed use-after-free complaints made by Coverity scan." NOTE: some of these details are obtained from third party information.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 907675, 913094 [RESOLVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • privoxy >= 3.0.23-4.2
Patchnames:
openSUSE Leap 42.1 GA privoxy
openSUSE Leap 42.2
  • privoxy >= 3.0.24-7.1
Patchnames:
openSUSE Leap 42.2 GA privoxy
openSUSE Leap 42.3
  • privoxy >= 3.0.24-9.1
Patchnames:
openSUSE Leap 42.3 GA privoxy
openSUSE Tumbleweed
  • privoxy >= 3.0.26-1.1
  • privoxy-doc >= 3.0.26-1.1
Patchnames:
openSUSE Tumbleweed GA privoxy