Upstream information

CVE-2015-0856 at MITRE

Description

daemon/Greeter.cpp in sddm before 0.13.0 does not properly disable the KDE crash handler, which allows local users to gain privileges by crashing a greeter when using certain themes, as demonstrated by the plasma-workspace breeze theme.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 950491

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • sddm >= 0.17.0-lp150.8.1
  • sddm-branding-openSUSE >= 0.17.0-lp150.8.1
Patchnames:
openSUSE Leap 15.0 GA sddm
openSUSE Leap 42.1
  • sddm >= 0.12.0-5.1
  • sddm-branding-openSUSE >= 0.12.0-5.1
Patchnames:
openSUSE Leap 42.1 GA sddm
openSUSE Leap 42.2
  • sddm >= 0.13.0-8.1
  • sddm-branding-openSUSE >= 0.13.0-8.1
Patchnames:
openSUSE Leap 42.2 GA sddm
openSUSE Leap 42.3
  • sddm >= 0.14.0-5.1
  • sddm-branding-openSUSE >= 0.14.0-5.1
Patchnames:
openSUSE Leap 42.3 GA sddm
openSUSE Tumbleweed
  • sddm >= 0.14.0-2.1
  • sddm-branding-openSUSE >= 0.14.0-2.1
  • sddm-branding-upstream >= 0.14.0-2.1
Patchnames:
openSUSE Tumbleweed GA sddm