Upstream information

CVE-2015-0254 at MITRE

Description

Apache Standard Taglibs before 1.2.3 allows remote attackers to execute arbitrary code or conduct external XML entity (XXE) attacks via a crafted XSLT extension in a (1) or (2) JSTL XML tag.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.8
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
SUSE Bugzilla entry: 920813 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • jakarta-taglibs-standard >= 1.1.1-255.2
  • jakarta-taglibs-standard-javadoc >= 1.1.1-255.2
SUSE Linux Enterprise Module for Web Scripting 15
SUSE Linux Enterprise Module for Web Scripting 15 SP1
SUSE Linux Enterprise Module for Web Scripting 15 SP2
  • jakarta-taglibs-standard >= 1.1.1-2.42
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • jakarta-taglibs-standard >= 1.1.1-234.31.1
  • jakarta-taglibs-standard-javadoc >= 1.1.1-234.31.1
Patchnames:
slessp4-jakarta-taglibs-standard-13173
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • jakarta-taglibs-standard >= 1.1.1-255.2
  • jakarta-taglibs-standard-javadoc >= 1.1.1-255.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-963
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • jakarta-taglibs-standard >= 1.1.1-255.2
  • jakarta-taglibs-standard-javadoc >= 1.1.1-255.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-963
openSUSE 13.1
  • jakarta-taglibs-standard >= 1.1.1-252.3.1
  • jakarta-taglibs-standard-javadoc >= 1.1.1-252.3.1
  • xalan-j2 >= 2.7.2-262.7.1
  • xalan-j2-demo >= 2.7.2-262.7.1
  • xalan-j2-manual >= 2.7.2-262.7.1
  • xalan-j2-xsltc >= 2.7.2-262.7.1
Patchnames:
openSUSE-2015-658
openSUSE Tumbleweed
  • jakarta-taglibs-standard >= 1.1.1-257.4
  • jakarta-taglibs-standard-javadoc >= 1.1.1-257.4
Patchnames:
openSUSE Tumbleweed GA jakarta-taglibs-standard


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Point of Service 11 SP3 jakarta-taglibs-standard Released
SUSE Linux Enterprise Server 11 SP3 jakarta-taglibs-standard Affected
SUSE Linux Enterprise Server 11 SP3 for VMware jakarta-taglibs-standard Affected
SUSE Linux Enterprise Server 11 SP4 jakarta-taglibs-standard Released
SUSE Linux Enterprise Server 11 SP4 LTSS jakarta-taglibs-standard Released
SUSE Linux Enterprise Server 12 jakarta-taglibs-standard Affected
SUSE Linux Enterprise Server 12 SP1 jakarta-taglibs-standard Unsupported
SUSE Linux Enterprise Server 12 SP2 jakarta-taglibs-standard Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 jakarta-taglibs-standard Released
SUSE Linux Enterprise Server for the Raspberry Pi jakarta-taglibs-standard Released