Upstream information

CVE-2014-9654 at MITRE

Description

The Regular Expressions package in International Components for Unicode (ICU) for C/C++ before 2014-12-03, as used in Google Chrome before 40.0.2214.91, calculates certain values without ensuring that they can be represented in a 24-bit field, which allows remote attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact via a crafted string, a related issue to CVE-2014-7923.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 917129 [RESOLVED / FIXED], 929629 [RESOLVED], 952260 [RESOLVED / FIXED], 969781 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • icu >= 4.0-7.28.1
  • libicu >= 4.0-7.28.1
Patchnames:
sledsp3-icu
SUSE Linux Enterprise Desktop 11 SP4
  • icu >= 4.0-7.30.2
  • libicu >= 4.0-7.30.2
Patchnames:
sledsp4-icu-12151
SUSE Linux Enterprise Desktop 12
  • icu >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-110
SUSE Linux Enterprise Desktop 12 SP1
  • icu >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA icu
SUSE Linux Enterprise Desktop 12 SP2
  • icu >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA icu
SUSE Linux Enterprise Desktop 12 SP3
  • icu >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA icu
SUSE Linux Enterprise Server 11 SP3
  • libicu >= 4.0-7.28.1
  • libicu-32bit >= 4.0-7.28.1
  • libicu-doc >= 4.0-7.28.1
  • libicu-x86 >= 4.0-7.28.1
Patchnames:
slessp3-icu
SUSE Linux Enterprise Server 11 SP4
  • icu >= 4.0-38.1
  • libicu >= 4.0-38.1
  • libicu-32bit >= 4.0-38.1
  • libicu-doc >= 4.0-38.1
  • libicu-x86 >= 4.0-38.1
Patchnames:
slessp4-icu-12151
slessp4-icu-12513
SUSE Linux Enterprise Server 12
  • icu >= 52.1-7.1
  • libicu-doc >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE-SLE-SERVER-12-2015-110
SUSE Linux Enterprise Server 12 SP1
  • libicu-doc >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libicu-doc
SUSE Linux Enterprise Server 12 SP2
  • libicu-doc >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libicu-doc
SUSE Linux Enterprise Server 12 SP3
  • libicu-doc >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libicu-doc
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libicu-doc >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libicu-doc
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • libicu >= 4.0-7.28.1
  • libicu-32bit >= 4.0-7.28.1
  • libicu-doc >= 4.0-7.28.1
  • libicu-x86 >= 4.0-7.28.1
Patchnames:
slessp3-icu
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • icu >= 4.0-38.1
  • libicu >= 4.0-38.1
  • libicu-32bit >= 4.0-38.1
  • libicu-doc >= 4.0-38.1
  • libicu-x86 >= 4.0-38.1
Patchnames:
slessp4-icu-12151
slessp4-icu-12513
SUSE Linux Enterprise Server for SAP Applications 12
  • icu >= 52.1-7.1
  • libicu-doc >= 52.1-7.1
  • libicu52_1 >= 52.1-7.1
  • libicu52_1-32bit >= 52.1-7.1
  • libicu52_1-data >= 52.1-7.1
Patchnames:
SUSE-SLE-SERVER-12-2015-110
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libicu >= 4.0-7.28.1
  • libicu-32bit >= 4.0-7.28.1
  • libicu-doc >= 4.0-7.28.1
  • libicu-x86 >= 4.0-7.28.1
Patchnames:
slessp3-icu
SUSE Linux Enterprise Software Development Kit 11 SP3
  • icu >= 4.0-7.28.1
  • libicu-32bit >= 4.0-7.28.1
  • libicu-devel >= 4.0-7.28.1
  • libicu-devel-32bit >= 4.0-7.28.1
Patchnames:
sdksp3-icu
SUSE Linux Enterprise Software Development Kit 11 SP4
  • icu >= 4.0-38.1
  • libicu-32bit >= 4.0-38.1
  • libicu-devel >= 4.0-38.1
  • libicu-devel-32bit >= 4.0-38.1
Patchnames:
sdksp4-icu-12151
sdksp4-icu-12513
SUSE Linux Enterprise Software Development Kit 12
  • icu >= 52.1-7.1
  • libicu-devel >= 52.1-7.1
Patchnames:
SUSE-SLE-SDK-12-2015-110
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libicu-devel >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libicu-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libicu-devel >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libicu-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libicu-devel >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libicu-devel
SUSE Linux Enterprise Workstation Extension 12
  • icu >= 52.1-7.1
Patchnames:
SUSE-SLE-WE-12-2015-110
SUSE Linux Enterprise Workstation Extension 12 SP1
  • icu >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA icu
SUSE Linux Enterprise Workstation Extension 12 SP2
  • icu >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA icu
SUSE Linux Enterprise Workstation Extension 12 SP3
  • icu >= 52.1-7.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA icu
SUSE Linux Enterprise Software Development Kit 11 SP3
  • icu >= 4.0-7.28.1
  • libicu-devel >= 4.0-7.28.1
Builds
SAT Patch Nr: 10783
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libicu-devel >= 4.0-7.28.1
Builds
SAT Patch Nr: 10783
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libicu-devel >= 4.0-7.28.1
  • libicu-devel-32bit >= 4.0-7.28.1
Builds
SAT Patch Nr: 10783
SUSE Linux Enterprise Software Development Kit 11 SP3
  • icu >= 4.0-7.28.1
  • libicu-32bit >= 4.0-7.28.1
  • libicu-devel >= 4.0-7.28.1
  • libicu-devel-32bit >= 4.0-7.28.1
Builds
SAT Patch Nr: 10783
SUSE Linux Enterprise Desktop 11 SP3
  • icu >= 4.0-7.28.1
  • libicu >= 4.0-7.28.1
Builds
SAT Patch Nr: 10783
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libicu >= 4.0-7.28.1
  • libicu-32bit >= 4.0-7.28.1
  • libicu-doc >= 4.0-7.28.1
Builds
SAT Patch Nr: 10783
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libicu >= 4.0-7.28.1
  • libicu-doc >= 4.0-7.28.1
Builds
SAT Patch Nr: 10783
SUSE Linux Enterprise Server 11 SP3
  • libicu >= 4.0-7.28.1
  • libicu-doc >= 4.0-7.28.1
  • libicu-x86 >= 4.0-7.28.1
Builds
SAT Patch Nr: 10783
openSUSE Leap 42.1
  • libicu-devel >= 52.1-10.3
  • libicu52_1 >= 52.1-10.3
  • libicu52_1-data >= 52.1-10.3
Patchnames:
openSUSE Leap 42.1 GA libicu-devel
openSUSE Leap 42.2
  • libicu-devel >= 52.1-11.5
  • libicu52_1 >= 52.1-11.5
  • libicu52_1-data >= 52.1-11.5
Patchnames:
openSUSE Leap 42.2 GA libicu-devel
openSUSE Leap 42.3
  • libicu-devel >= 52.1-13.3
  • libicu52_1 >= 52.1-13.3
  • libicu52_1-data >= 52.1-13.3
Patchnames:
openSUSE Leap 42.3 GA libicu-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 icu Released
SUSE Linux Enterprise Desktop 10 SP4 icu Released
SUSE Linux Enterprise Desktop 11 SP1 icu Released
SUSE Linux Enterprise Desktop 11 SP2 icu Released
SUSE Linux Enterprise Desktop 11 SP3 icu Released
SUSE Linux Enterprise Desktop 11 SP4 icu Released
SUSE Linux Enterprise Desktop 12 GA icu Released
SUSE Linux Enterprise Desktop 12 SP1 icu Released
SUSE Linux Enterprise SDK 11 SP1 icu Released
SUSE Linux Enterprise SDK 11 SP2 icu Released
SUSE Linux Enterprise SDK 11 SP3 icu Released
SUSE Linux Enterprise SDK 11 SP4 icu Released
SUSE Linux Enterprise SDK 12 GA icu Released
SUSE Linux Enterprise Server 10 SP3 icu Released
SUSE Linux Enterprise Server 10 SP4 icu Released
SUSE Linux Enterprise Server 10 SP4 LTSS icu Released
SUSE Linux Enterprise Server 11 SP1 icu Released
SUSE Linux Enterprise Server 11 SP1 LTSS icu Released
SUSE Linux Enterprise Server 11 SP2 icu Released
SUSE Linux Enterprise Server 11 SP2 LTSS icu Released
SUSE Linux Enterprise Server 11 SP3 icu Released
SUSE Linux Enterprise Server 11 SP3 LTSS icu Released
SUSE Linux Enterprise Server 11 SP4 icu Released
SUSE Linux Enterprise Server 12 GA icu Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 icu Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 icu Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 icu Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 icu Released
SUSE Linux Enterprise Server for VMWare 11 SP2 icu Released
SUSE Linux Enterprise Server for VMWare 11 SP3 icu Released
SUSE Linux Enterprise Workstation Extension 12 GA icu Released