Upstream information

CVE-2014-9653 at MITRE

Description

readelf.c in file before 5.22, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not consider that pread calls sometimes read only a subset of the available data, which allows remote attackers to cause a denial of service (uninitialized memory access) or possibly have unspecified other impact via a crafted ELF file.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 917152 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1881
SUSE CaaS Platform ALL
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
  • sles12-caasp-dex-image >= 2.0.0-3.3.11
  • sles12-dnsmasq-nanny-image >= 2.0.1-2.3.15
  • sles12-haproxy-image >= 2.0.1-2.3.16
  • sles12-kubedns-image >= 2.0.1-2.3.11
  • sles12-mariadb-image >= 2.0.1-2.3.15
  • sles12-openldap-image >= 2.0.0-2.3.11
  • sles12-pause-image >= 2.0.1-2.3.9
  • sles12-pv-recycler-node-image >= 2.0.1-2.3.10
  • sles12-salt-api-image >= 2.0.1-2.3.10
  • sles12-salt-master-image >= 2.0.1-2.3.10
  • sles12-salt-minion-image >= 2.0.1-2.3.14
  • sles12-sidecar-image >= 2.0.1-2.3.11
  • sles12-tiller-image >= 2.0.0-2.3.11
  • sles12-velum-image >= 2.0.1-2.3.13
Patchnames:
SUSE-CAASP-ALL-2017-1881
SUSE-CAASP-ALL-2018-40
SUSE Linux Enterprise Desktop 12 SP2
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
  • libmagic1-32bit >= 5.22-10.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1881
SUSE Linux Enterprise Desktop 12 SP3
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
  • libmagic1-32bit >= 5.22-10.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1881
SUSE Linux Enterprise Server 12 SP2
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
  • libmagic1-32bit >= 5.22-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1881
SUSE Linux Enterprise Server 12 SP3
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
  • libmagic1-32bit >= 5.22-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1881
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1881
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
  • libmagic1-32bit >= 5.22-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1881
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • file >= 5.22-10.3.1
  • file-magic >= 5.22-10.3.1
  • libmagic1 >= 5.22-10.3.1
  • libmagic1-32bit >= 5.22-10.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1881
SUSE Linux Enterprise Software Development Kit 12 SP2
  • file >= 5.22-10.3.1
  • file-devel >= 5.22-10.3.1
  • python-magic >= 5.22-10.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1881
SUSE Linux Enterprise Software Development Kit 12 SP3
  • file >= 5.22-10.3.1
  • file-devel >= 5.22-10.3.1
  • python-magic >= 5.22-10.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1881
openSUSE Leap 42.2
  • file >= 5.22-7.3.1
  • file-debuginfo >= 5.22-7.3.1
  • file-debugsource >= 5.22-7.3.1
  • file-devel >= 5.22-7.3.1
  • file-magic >= 5.22-7.3.1
  • libmagic1 >= 5.22-7.3.1
  • libmagic1-32bit >= 5.22-7.3.1
  • libmagic1-debuginfo >= 5.22-7.3.1
  • libmagic1-debuginfo-32bit >= 5.22-7.3.1
  • python-magic >= 5.22-7.3.1
Patchnames:
openSUSE-2017-1298
openSUSE Leap 42.3
  • file >= 5.22-10.1
  • file-debuginfo >= 5.22-10.1
  • file-debugsource >= 5.22-10.1
  • file-devel >= 5.22-10.1
  • file-magic >= 5.22-10.1
  • libmagic1 >= 5.22-10.1
  • libmagic1-32bit >= 5.22-10.1
  • libmagic1-debuginfo >= 5.22-10.1
  • libmagic1-debuginfo-32bit >= 5.22-10.1
  • python-magic >= 5.22-10.1
Patchnames:
openSUSE-2017-1298


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 file In progress
CaaS Platform 2.0 file Released
OpenStack Cloud Magnum Orchestration 7.0 file Released
SUSE Linux Enterprise Desktop 11 SP3 file Affected
SUSE Linux Enterprise Desktop 12 GA file Affected
SUSE Linux Enterprise Desktop 12 SP2 file Released
SUSE Linux Enterprise Desktop 12 SP3 file Released
SUSE Linux Enterprise SDK 11 SP3 file Affected
SUSE Linux Enterprise SDK 12 GA file Affected
SUSE Linux Enterprise SDK 12 SP2 file Released
SUSE Linux Enterprise SDK 12 SP3 file Released
SUSE Linux Enterprise Server 11 SP3 file Affected
SUSE Linux Enterprise Server 12 GA file Affected
SUSE Linux Enterprise Server 12 SP2 file Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI file Released
SUSE Linux Enterprise Server 12 SP3 file Released
SUSE Linux Enterprise Server for VMWare 11 SP3 file Affected