Upstream information

CVE-2014-9495 at MITRE

Description

Heap-based buffer overflow in the png_combine_row function in libpng before 1.5.21 and 1.6.x before 1.6.16, when running on 64-bit systems, might allow context-dependent attackers to execute arbitrary code via a "very wide interlaced" PNG image.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 912076 [RESOLVED], 912929 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libpng16 >= 1.6.8-5.1
  • libpng16-16 >= 1.6.8-5.1
  • libpng16-16-32bit >= 1.6.8-5.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-33
SUSE Linux Enterprise Desktop 12 SP1
  • libpng16-16 >= 1.6.8-5.1
  • libpng16-16-32bit >= 1.6.8-5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libpng16-16
SUSE Linux Enterprise Desktop 12 SP2
  • libpng16-16 >= 1.6.8-11.1
  • libpng16-16-32bit >= 1.6.8-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libpng16-16
SUSE Linux Enterprise Desktop 12 SP3
  • libpng16-16 >= 1.6.8-14.1
  • libpng16-16-32bit >= 1.6.8-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libpng16-16
SUSE Linux Enterprise Module for Basesystem 15
  • libpng12-0 >= 1.2.57-2.18
  • libpng12-devel >= 1.2.57-2.18
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpng12-0
SUSE Linux Enterprise Server 12
  • libpng16 >= 1.6.8-5.1
  • libpng16-16 >= 1.6.8-5.1
  • libpng16-16-32bit >= 1.6.8-5.1
Patchnames:
SUSE-SLE-SERVER-12-2015-33
SUSE Linux Enterprise Server 12 SP1
  • libpng16-16 >= 1.6.8-5.1
  • libpng16-16-32bit >= 1.6.8-5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libpng16-16
SUSE Linux Enterprise Server 12 SP2
  • libpng16-16 >= 1.6.8-11.1
  • libpng16-16-32bit >= 1.6.8-11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libpng16-16
SUSE Linux Enterprise Server 12 SP3
  • libpng16-16 >= 1.6.8-14.1
  • libpng16-16-32bit >= 1.6.8-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libpng16-16
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libpng16-16 >= 1.6.8-11.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libpng16-16
SUSE Linux Enterprise Server for SAP Applications 12
  • libpng16 >= 1.6.8-5.1
  • libpng16-16 >= 1.6.8-5.1
  • libpng16-16-32bit >= 1.6.8-5.1
Patchnames:
SUSE-SLE-SERVER-12-2015-33
SUSE Linux Enterprise Software Development Kit 12
  • libpng16 >= 1.6.8-5.1
  • libpng16-compat-devel >= 1.6.8-5.1
  • libpng16-devel >= 1.6.8-5.1
Patchnames:
SUSE-SLE-SDK-12-2015-33
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libpng16-compat-devel >= 1.6.8-5.1
  • libpng16-devel >= 1.6.8-5.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libpng16-compat-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libpng16-compat-devel >= 1.6.8-11.1
  • libpng16-devel >= 1.6.8-11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libpng16-compat-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpng16-compat-devel >= 1.6.8-14.1
  • libpng16-devel >= 1.6.8-14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libpng16-compat-devel
openSUSE 13.1
  • libpng16 >= 1.6.6-16.1
  • libpng16-16 >= 1.6.6-16.1
  • libpng16-16-32bit >= 1.6.6-16.1
  • libpng16-16-debuginfo >= 1.6.6-16.1
  • libpng16-16-debuginfo-32bit >= 1.6.6-16.1
  • libpng16-compat-devel >= 1.6.6-16.1
  • libpng16-compat-devel-32bit >= 1.6.6-16.1
  • libpng16-debugsource >= 1.6.6-16.1
  • libpng16-devel >= 1.6.6-16.1
  • libpng16-devel-32bit >= 1.6.6-16.1
  • libpng16-tools >= 1.6.6-16.1
  • libpng16-tools-debuginfo >= 1.6.6-16.1
Patchnames:
openSUSE-2015-79
openSUSE Leap 42.1
  • libpng16-16 >= 1.6.8-2.2
  • libpng16-16-32bit >= 1.6.8-2.2
  • libpng16-compat-devel >= 1.6.8-2.2
  • libpng16-devel >= 1.6.8-2.2
Patchnames:
openSUSE Leap 42.1 GA libpng16-16
openSUSE Leap 42.2
  • libpng16-16 >= 1.6.8-8.1
  • libpng16-16-32bit >= 1.6.8-8.1
  • libpng16-compat-devel >= 1.6.8-8.1
  • libpng16-devel >= 1.6.8-8.1
Patchnames:
openSUSE Leap 42.2 GA libpng16-16
openSUSE Leap 42.3
  • libpng16-16 >= 1.6.8-11.3
  • libpng16-16-32bit >= 1.6.8-11.3
  • libpng16-compat-devel >= 1.6.8-11.3
  • libpng16-devel >= 1.6.8-11.3
Patchnames:
openSUSE Leap 42.3 GA libpng16-16
openSUSE Tumbleweed
  • libpng12-0 >= 1.2.56-1.5
  • libpng12-0-32bit >= 1.2.56-1.5
  • libpng12-compat-devel >= 1.2.56-1.5
  • libpng12-compat-devel-32bit >= 1.2.56-1.5
  • libpng12-devel >= 1.2.56-1.5
  • libpng12-devel-32bit >= 1.2.56-1.5
Patchnames:
openSUSE Tumbleweed GA libpng12-0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA libpng12 Not affected
SUSE Linux Enterprise Desktop 12 GA libpng16 Released
SUSE Linux Enterprise Desktop 12 SP1 libpng16 Released
SUSE Linux Enterprise SDK 12 GA libpng12 Not affected
SUSE Linux Enterprise SDK 12 GA libpng16 Released
SUSE Linux Enterprise Server 12 GA libpng12 Not affected
SUSE Linux Enterprise Server 12 GA libpng16 Released