Upstream information

CVE-2014-9494 at MITRE


RabbitMQ before 3.4.0 allows remote attackers to bypass the loopback_users restriction via a crafted X-Forwareded-For header.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 911857 [RESOLVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15 SP2
  • erlang-rabbitmq-client >= 3.8.3-1.27
  • rabbitmq-server >= 3.8.3-1.27
  • rabbitmq-server-plugins >= 3.8.3-1.27
SUSE OpenStack Cloud 6
  • rabbitmq-server >= 3.4.4-2.20
  • rabbitmq-server-plugins >= 3.4.4-2.20
openSUSE Tumbleweed
  • erlang-rabbitmq-client >= 3.5.4-1.4
  • rabbitmq-server >= 3.5.4-1.4
  • rabbitmq-server-plugins >= 3.5.4-1.4
openSUSE Tumbleweed GA erlang-rabbitmq-client

Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 2.0 rabbitmq-server Not affected
SUSE Cloud 3 rabbitmq-server Ignore
SUSE Cloud 4 rabbitmq-server Not affected
SUSE Cloud 4 Dependencies rabbitmq-server Not affected
SUSE Cloud 5 rabbitmq-server Already fixed