Upstream information

CVE-2014-9474 at MITRE

Description

Buffer overflow in the mpfr_strtofr function in GNU MPFR before 3.1.2-p11 allows context-dependent attackers to have unspecified impact via vectors related to incorrect documentation for mpn_set_str.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 911812 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libmpfr1 >= 2.3.2-3.118.1
Patchnames:
sledsp3-libmpfr1
SUSE Linux Enterprise Desktop 12
  • libmpfr4 >= 3.1.2-7.1
  • mpfr >= 3.1.2-7.1
Patchnames:
SUSE-SLE-DESKTOP-12-2015-53
SUSE Linux Enterprise Desktop 12 SP1
  • libmpfr4 >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libmpfr4
SUSE Linux Enterprise Desktop 12 SP2
  • libmpfr4 >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libmpfr4
SUSE Linux Enterprise Desktop 12 SP3
  • libmpfr4 >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libmpfr4
SUSE Linux Enterprise Module for Basesystem 15
  • libmpfr6 >= 4.0.1-1.46
  • mpfr-devel >= 4.0.1-1.46
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libmpfr6
SUSE Linux Enterprise Server 11 SP3
  • libmpfr1 >= 2.3.2-3.118.1
  • libmpfr1-32bit >= 2.3.2-3.118.1
  • libmpfr1-x86 >= 2.3.2-3.118.1
Patchnames:
slessp3-libmpfr1
SUSE Linux Enterprise Server 11 SP4
  • libmpfr1 >= 2.3.2-3.118.2
  • libmpfr1-32bit >= 2.3.2-3.118.2
  • libmpfr1-x86 >= 2.3.2-3.118.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libmpfr1
SUSE Linux Enterprise Server 12
  • libmpfr4 >= 3.1.2-7.1
  • libmpfr4-32bit >= 3.1.2-7.1
  • mpfr >= 3.1.2-7.1
Patchnames:
SUSE-SLE-SERVER-12-2015-53
SUSE Linux Enterprise Server 12 SP1
  • libmpfr4 >= 3.1.2-7.1
  • libmpfr4-32bit >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libmpfr4
SUSE Linux Enterprise Server 12 SP2
  • libmpfr4 >= 3.1.2-7.1
  • libmpfr4-32bit >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libmpfr4
SUSE Linux Enterprise Server 12 SP3
  • libmpfr4 >= 3.1.2-7.1
  • libmpfr4-32bit >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libmpfr4
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libmpfr4 >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libmpfr4
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • libmpfr1 >= 2.3.2-3.118.1
  • libmpfr1-32bit >= 2.3.2-3.118.1
  • libmpfr1-x86 >= 2.3.2-3.118.1
Patchnames:
slessp3-libmpfr1
SUSE Linux Enterprise Server for SAP Applications 12
  • libmpfr4 >= 3.1.2-7.1
  • libmpfr4-32bit >= 3.1.2-7.1
  • mpfr >= 3.1.2-7.1
Patchnames:
SUSE-SLE-SERVER-12-2015-53
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libmpfr1 >= 2.3.2-3.118.1
  • libmpfr1-32bit >= 2.3.2-3.118.1
  • libmpfr1-x86 >= 2.3.2-3.118.1
Patchnames:
slessp3-libmpfr1
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libmpfr1-32bit >= 2.3.2-3.118.1
  • mpfr-devel >= 2.3.2-3.118.1
  • mpfr-devel-32bit >= 2.3.2-3.118.1
Patchnames:
sdksp3-libmpfr1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmpfr1-32bit >= 2.3.2-3.118.2
  • mpfr-devel >= 2.3.2-3.118.1
  • mpfr-devel-32bit >= 2.3.2-3.118.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmpfr1-32bit
SUSE Linux Enterprise Software Development Kit 12
  • mpfr >= 3.1.2-7.1
  • mpfr-devel >= 3.1.2-7.1
Patchnames:
SUSE-SLE-SDK-12-2015-53
SUSE Linux Enterprise Software Development Kit 12 SP1
  • mpfr-devel >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA mpfr-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • mpfr-devel >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA mpfr-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • mpfr-devel >= 3.1.2-7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA mpfr-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • mpfr-devel >= 2.3.2-3.3.2
Builds
SAT Patch Nr: 10212
SUSE Linux Enterprise Software Development Kit 11 SP3
  • mpfr-devel >= 2.3.2-3.3.2
  • mpfr-devel-32bit >= 2.3.2-3.3.2
Builds
SAT Patch Nr: 10212
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libmpfr1-32bit >= 2.3.2-3.3.2
  • mpfr-devel >= 2.3.2-3.3.2
  • mpfr-devel-32bit >= 2.3.2-3.3.2
Builds
SAT Patch Nr: 10212
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libmpfr1 >= 2.3.2-3.3.2
Builds
SAT Patch Nr: 10212
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libmpfr1 >= 2.3.2-3.3.2
  • libmpfr1-32bit >= 2.3.2-3.3.2
Builds
SAT Patch Nr: 10212
SUSE Linux Enterprise Server 11 SP3
  • libmpfr1 >= 2.3.2-3.3.2
  • libmpfr1-x86 >= 2.3.2-3.3.2
Builds
SAT Patch Nr: 10212
openSUSE Leap 15.0
  • libmpfr6 >= 4.0.1-lp150.1.21
Patchnames:
openSUSE Leap 15.0 GA libmpfr6
openSUSE Leap 42.1
  • libmpfr4 >= 3.1.2-10.5
  • mpfr-devel >= 3.1.2-10.5
Patchnames:
openSUSE Leap 42.1 GA libmpfr4
openSUSE Leap 42.2
  • libmpfr4 >= 3.1.2-11.53
  • mpfr-devel >= 3.1.2-11.53
Patchnames:
openSUSE Leap 42.2 GA libmpfr4
openSUSE Leap 42.3
  • libmpfr4 >= 3.1.2-13.15
  • mpfr-devel >= 3.1.2-13.15
Patchnames:
openSUSE Leap 42.3 GA libmpfr4
openSUSE Tumbleweed
  • libmpfr4 >= 3.1.5-2.1
  • libmpfr4-32bit >= 3.1.5-2.1
  • mpfr-devel >= 3.1.5-2.1
  • mpfr-devel-32bit >= 3.1.5-2.1
Patchnames:
openSUSE Tumbleweed GA libmpfr4


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 mpfr Released
SUSE Linux Enterprise Desktop 11 SP2 mpfr Ignore
SUSE Linux Enterprise Desktop 11 SP3 mpfr Released
SUSE Linux Enterprise Desktop 12 GA mpfr Released
SUSE Linux Enterprise SDK 11 SP1 mpfr Released
SUSE Linux Enterprise SDK 11 SP2 mpfr Ignore
SUSE Linux Enterprise SDK 11 SP3 mpfr Released
SUSE Linux Enterprise SDK 12 GA mpfr Released
SUSE Linux Enterprise Server 10 SP3 mpfr Released
SUSE Linux Enterprise Server 10 SP4 mpfr Released
SUSE Linux Enterprise Server 10 SP4 LTSS mpfr Released
SUSE Linux Enterprise Server 11 SP1 mpfr Released
SUSE Linux Enterprise Server 11 SP1 LTSS mpfr Released
SUSE Linux Enterprise Server 11 SP2 mpfr Ignore
SUSE Linux Enterprise Server 11 SP2 LTSS mpfr Ignore
SUSE Linux Enterprise Server 11 SP3 mpfr Released
SUSE Linux Enterprise Server 12 GA mpfr Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 mpfr Released
SUSE Linux Enterprise Server for VMWare 11 SP2 mpfr Ignore
SUSE Linux Enterprise Server for VMWare 11 SP3 mpfr Released