Upstream information

CVE-2014-9163 at MITRE

Description

Stack-based buffer overflow in Adobe Flash Player before 13.0.0.259 and 14.x and 15.x before 15.0.0.246 on Windows and OS X and before 11.2.202.425 on Linux allows attackers to execute arbitrary code via unspecified vectors, as exploited in the wild in December 2014.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 909219

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • flash-player >= 11.2.202.425-0.3.1
  • flash-player-gnome >= 11.2.202.425-0.3.1
  • flash-player-kde4 >= 11.2.202.425-0.3.1
Patchnames:
sledsp3-flash-player
SUSE Linux Enterprise Desktop 12
  • flash-player >= 11.2.202.425-19.1
  • flash-player-gnome >= 11.2.202.425-19.1
Patchnames:
SUSE-SLE-DESKTOP-12-2014-110
SUSE Linux Enterprise Desktop 12 SP1
  • flash-player >= 11.2.202.548-111.1
  • flash-player-gnome >= 11.2.202.548-111.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA flash-player
SUSE Linux Enterprise Workstation Extension 12
  • flash-player >= 11.2.202.425-19.1
  • flash-player-gnome >= 11.2.202.425-19.1
Patchnames:
SUSE-SLE-WE-12-2014-110
SUSE Linux Enterprise Workstation Extension 12 SP1
  • flash-player >= 11.2.202.548-111.1
  • flash-player-gnome >= 11.2.202.548-111.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA flash-player
SUSE Linux Enterprise Desktop 11 SP3
  • flash-player >= 11.2.202.425-0.3.1
  • flash-player-gnome >= 11.2.202.425-0.3.1
  • flash-player-kde4 >= 11.2.202.425-0.3.1
Builds
SAT Patch Nr: 10090


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA flash-player Released
SUSE Linux Enterprise Workstation Extension 12 GA flash-player Released