Upstream information

CVE-2014-9112 at MITRE

Description

Heap-based buffer overflow in the process_copy_in function in GNU Cpio 2.11 allows remote attackers to cause a denial of service via a large block value in a cpio archive.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 907456 [RESOLVED], 913479 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • cpio >= 2.9-75.78.1
  • cpio-lang >= 2.9-75.78.1
Patchnames:
sledsp3-cpio
SUSE Linux Enterprise Desktop 12
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
Patchnames:
SUSE-SLE-DESKTOP-12-2014-113
SUSE Linux Enterprise Desktop 12 SP1
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA cpio
SUSE Linux Enterprise Desktop 12 SP2
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA cpio
SUSE Linux Enterprise Desktop 12 SP3
  • cpio >= 2.11-35.1
  • cpio-lang >= 2.11-35.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA cpio
SUSE Linux Enterprise Module for Basesystem 15
  • cpio >= 2.12-1.439
  • cpio-lang >= 2.12-1.439
  • cpio-mt >= 2.12-1.439
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA cpio
SUSE Linux Enterprise Server 11 SP3
  • cpio >= 2.9-75.78.1
  • cpio-lang >= 2.9-75.78.1
Patchnames:
slessp3-cpio
SUSE Linux Enterprise Server 11 SP4
  • cpio >= 2.9-75.78.1
  • cpio-lang >= 2.9-75.78.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA cpio
SUSE Linux Enterprise Server 12
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
Patchnames:
SUSE-SLE-SERVER-12-2014-113
SUSE Linux Enterprise Server 12 SP1
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA cpio
SUSE Linux Enterprise Server 12 SP2
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA cpio
SUSE Linux Enterprise Server 12 SP3
  • cpio >= 2.11-35.1
  • cpio-lang >= 2.11-35.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA cpio
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA cpio
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • cpio >= 2.9-75.78.1
  • cpio-lang >= 2.9-75.78.1
Patchnames:
slessp3-cpio
SUSE Linux Enterprise Server for SAP Applications 12
  • cpio >= 2.11-29.1
  • cpio-lang >= 2.11-29.1
Patchnames:
SUSE-SLE-SERVER-12-2014-113
SUSE Linux Enterprise Server for VMWare 11 SP3
  • cpio >= 2.9-75.78.1
  • cpio-lang >= 2.9-75.78.1
Patchnames:
slessp3-cpio
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • cpio >= 2.9-75.78.1
  • cpio-lang >= 2.9-75.78.1
Builds
SAT Patch Nr: 10070
openSUSE 13.1
  • cpio >= 2.11-25.4.1
  • cpio-debuginfo >= 2.11-25.4.1
  • cpio-debugsource >= 2.11-25.4.1
  • cpio-lang >= 2.11-25.4.1
Patchnames:
openSUSE-2014-771
openSUSE Leap 15.0
  • cpio >= 2.12-lp150.1.48
  • cpio-lang >= 2.12-lp150.1.48
  • cpio-mt >= 2.12-lp150.1.48
Patchnames:
openSUSE Leap 15.0 GA cpio
openSUSE Leap 42.1
  • cpio >= 2.11-30.4
  • cpio-lang >= 2.11-30.4
Patchnames:
openSUSE Leap 42.1 GA cpio
openSUSE Leap 42.2
  • cpio >= 2.11-31.51
  • cpio-lang >= 2.11-31.51
Patchnames:
openSUSE Leap 42.2 GA cpio
openSUSE Leap 42.3
  • cpio >= 2.11-37.12
  • cpio-lang >= 2.11-37.12
Patchnames:
openSUSE Leap 42.3 GA cpio
openSUSE Tumbleweed
  • cpio >= 2.12-3.90
  • cpio-lang >= 2.12-3.90
Patchnames:
openSUSE Tumbleweed GA cpio


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 cpio Released
SUSE Linux Enterprise Desktop 11 SP1 cpio Released
SUSE Linux Enterprise Desktop 11 SP2 cpio Released
SUSE Linux Enterprise Desktop 11 SP3 cpio Released
SUSE Linux Enterprise Desktop 11 SP4 cpio Released
SUSE Linux Enterprise Desktop 12 GA cpio Released
SUSE Linux Enterprise Desktop 12 SP1 cpio Released
SUSE Linux Enterprise Server 10 SP3 cpio Released
SUSE Linux Enterprise Server 11 SP1 cpio Released
SUSE Linux Enterprise Server 11 SP1 LTSS cpio Released
SUSE Linux Enterprise Server 11 SP2 cpio Released
SUSE Linux Enterprise Server 11 SP2 LTSS cpio Released
SUSE Linux Enterprise Server 11 SP3 cpio Released
SUSE Linux Enterprise Server 11 SP3 LTSS cpio Released
SUSE Linux Enterprise Server 11 SP4 cpio Released
SUSE Linux Enterprise Server 12 GA cpio Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 cpio Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 cpio Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 cpio Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 cpio Released
SUSE Linux Enterprise Server for VMWare 11 SP2 cpio Released
SUSE Linux Enterprise Server for VMWare 11 SP3 cpio Released