Upstream information

CVE-2014-8564 at MITRE

Description

The _gnutls_ecc_ansi_x963_export function in gnutls_ecc.c in GnuTLS 3.x before 3.1.28, 3.2.x before 3.2.20, and 3.3.x before 3.3.10 allows remote attackers to cause a denial of service (out-of-bounds write) via a crafted (1) Elliptic Curve Cryptography (ECC) certificate or (2) certificate signing requests (CSR), related to generating key IDs.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 904603

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • gnutls >= 3.2.15-4.1
  • libgnutls28 >= 3.2.15-4.1
  • libgnutls28-32bit >= 3.2.15-4.1
Patchnames:
SUSE-SLE-DESKTOP-12-2014-109
SUSE Linux Enterprise Desktop 12 SP1
  • gnutls >= 3.2.15-11.1
  • libgnutls28 >= 3.2.15-11.1
  • libgnutls28-32bit >= 3.2.15-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA gnutls
SUSE Linux Enterprise Desktop 12 SP2
  • gnutls >= 3.2.15-11.1
  • libgnutls28 >= 3.2.15-11.1
  • libgnutls28-32bit >= 3.2.15-11.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA gnutls
SUSE Linux Enterprise Desktop 12 SP3
  • gnutls >= 3.3.27-1.10
  • libgnutls28 >= 3.3.27-1.10
  • libgnutls28-32bit >= 3.3.27-1.10
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gnutls
SUSE Linux Enterprise Module for Basesystem 15
  • gnutls >= 3.6.2-4.15
  • libgnutls-devel >= 3.6.2-4.15
  • libgnutls30 >= 3.6.2-4.15
  • libgnutlsxx-devel >= 3.6.2-4.15
  • libgnutlsxx28 >= 3.6.2-4.15
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA gnutls
SUSE Linux Enterprise Module for Desktop Applications 15
  • libgnutls30-32bit >= 3.6.2-4.15
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libgnutls30-32bit
SUSE Linux Enterprise Server 12
  • gnutls >= 3.2.15-4.1
  • libgnutls-openssl27 >= 3.2.15-4.1
  • libgnutls28 >= 3.2.15-4.1
  • libgnutls28-32bit >= 3.2.15-4.1
Patchnames:
SUSE-SLE-SERVER-12-2014-109
SUSE Linux Enterprise Server 12 SP1
  • gnutls >= 3.2.15-11.1
  • libgnutls-openssl27 >= 3.2.15-11.1
  • libgnutls28 >= 3.2.15-11.1
  • libgnutls28-32bit >= 3.2.15-11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA gnutls
SUSE Linux Enterprise Server 12 SP2
  • gnutls >= 3.2.15-11.1
  • libgnutls-openssl27 >= 3.2.15-11.1
  • libgnutls28 >= 3.2.15-11.1
  • libgnutls28-32bit >= 3.2.15-11.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA gnutls
SUSE Linux Enterprise Server 12 SP3
  • gnutls >= 3.3.27-1.10
  • libgnutls-openssl27 >= 3.3.27-1.10
  • libgnutls28 >= 3.3.27-1.10
  • libgnutls28-32bit >= 3.3.27-1.10
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gnutls
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gnutls >= 3.2.15-11.1
  • libgnutls-openssl27 >= 3.2.15-11.1
  • libgnutls28 >= 3.2.15-11.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA gnutls
SUSE Linux Enterprise Server for SAP Applications 12
  • gnutls >= 3.2.15-4.1
  • libgnutls-openssl27 >= 3.2.15-4.1
  • libgnutls28 >= 3.2.15-4.1
  • libgnutls28-32bit >= 3.2.15-4.1
Patchnames:
SUSE-SLE-SERVER-12-2014-109
SUSE Linux Enterprise Software Development Kit 12
  • gnutls >= 3.2.15-4.1
  • libgnutls-devel >= 3.2.15-4.1
  • libgnutls-openssl-devel >= 3.2.15-4.1
  • libgnutlsxx-devel >= 3.2.15-4.1
  • libgnutlsxx28 >= 3.2.15-4.1
Patchnames:
SUSE-SLE-SDK-12-2014-109
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libgnutls-devel >= 3.2.15-11.1
  • libgnutls-openssl-devel >= 3.2.15-11.1
  • libgnutlsxx-devel >= 3.2.15-11.1
  • libgnutlsxx28 >= 3.2.15-11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libgnutls-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libgnutls-devel >= 3.2.15-11.1
  • libgnutls-openssl-devel >= 3.2.15-11.1
  • libgnutlsxx-devel >= 3.2.15-11.1
  • libgnutlsxx28 >= 3.2.15-11.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libgnutls-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgnutls-devel >= 3.3.27-1.10
  • libgnutls-openssl-devel >= 3.3.27-1.10
  • libgnutlsxx-devel >= 3.3.27-1.10
  • libgnutlsxx28 >= 3.3.27-1.10
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libgnutls-devel
openSUSE 13.1
  • gnutls >= 3.2.4-2.28.1
  • gnutls-debuginfo >= 3.2.4-2.28.1
  • gnutls-debugsource >= 3.2.4-2.28.1
  • libgnutls-devel >= 3.2.4-2.28.1
  • libgnutls-devel-32bit >= 3.2.4-2.28.1
  • libgnutls-openssl-devel >= 3.2.4-2.28.1
  • libgnutls-openssl27 >= 3.2.4-2.28.1
  • libgnutls-openssl27-debuginfo >= 3.2.4-2.28.1
  • libgnutls28 >= 3.2.4-2.28.1
  • libgnutls28-32bit >= 3.2.4-2.28.1
  • libgnutls28-debuginfo >= 3.2.4-2.28.1
  • libgnutls28-debuginfo-32bit >= 3.2.4-2.28.1
  • libgnutlsxx-devel >= 3.2.4-2.28.1
  • libgnutlsxx28 >= 3.2.4-2.28.1
  • libgnutlsxx28-debuginfo >= 3.2.4-2.28.1
Patchnames:
openSUSE-2014-696
openSUSE Leap 15.0
  • gnutls >= 3.6.2-lp150.3.2
  • libgnutls-dane0 >= 3.6.2-lp150.3.2
  • libgnutls30 >= 3.6.2-lp150.3.2
Patchnames:
openSUSE Leap 15.0 GA gnutls
openSUSE Leap 42.1
  • gnutls >= 3.2.15-6.2
  • libgnutls-devel >= 3.2.15-6.2
  • libgnutls-openssl27 >= 3.2.15-6.2
  • libgnutls28 >= 3.2.15-6.2
  • libgnutls28-32bit >= 3.2.15-6.2
Patchnames:
openSUSE Leap 42.1 GA gnutls
openSUSE Leap 42.2
  • gnutls >= 3.2.15-7.5
  • libgnutls-devel >= 3.2.15-7.5
  • libgnutls-openssl27 >= 3.2.15-7.5
  • libgnutls28 >= 3.2.15-7.5
  • libgnutls28-32bit >= 3.2.15-7.5
Patchnames:
openSUSE Leap 42.2 GA gnutls
openSUSE Leap 42.3
  • gnutls >= 3.3.27-1.5
  • libgnutls-devel >= 3.3.27-1.5
  • libgnutls-openssl27 >= 3.3.27-1.5
  • libgnutls28 >= 3.3.27-1.5
  • libgnutls28-32bit >= 3.3.27-1.5
Patchnames:
openSUSE Leap 42.3 GA gnutls
openSUSE Tumbleweed
  • gnutls >= 3.4.15-1.1
  • gnutls-guile >= 3.4.15-1.1
  • libgnutls-dane-devel >= 3.4.15-1.1
  • libgnutls-dane0 >= 3.4.15-1.1
  • libgnutls-devel >= 3.4.15-1.1
  • libgnutls-devel-32bit >= 3.4.15-1.1
  • libgnutls-openssl-devel >= 3.4.15-1.1
  • libgnutls-openssl27 >= 3.4.15-1.1
  • libgnutls30 >= 3.4.15-1.1
  • libgnutls30-32bit >= 3.4.15-1.1
  • libgnutlsxx-devel >= 3.4.15-1.1
  • libgnutlsxx28 >= 3.4.15-1.1
Patchnames:
openSUSE Tumbleweed GA gnutls


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA gnutls Released
SUSE Linux Enterprise Desktop 12 SP1 gnutls Released
SUSE Linux Enterprise SDK 12 GA gnutls Released
SUSE Linux Enterprise Server 12 GA gnutls Released