Upstream information

CVE-2014-7273 at MITRE

Description

The IMAP-over-SSL implementation in getmail 4.0.0 through 4.43.0 does not verify X.509 certificates from SSL servers, which allows man-in-the-middle attackers to spoof IMAP servers and obtain sensitive information via a crafted certificate.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 900217

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.1
  • getmail >= 4.46.0-2.4.1
  • getmail-doc >= 4.46.0-2.4.1
Patchnames:
openSUSE-2014-598
openSUSE Tumbleweed
  • getmail >= 4.46.0-1.2
  • getmail-doc >= 4.46.0-1.2
Patchnames:
openSUSE Tumbleweed GA getmail