Upstream information

CVE-2014-7230 at MITRE

Description

The processutils.execute function in OpenStack oslo-incubator, Cinder, Nova, and Trove before 2013.2.4 and 2014.1 before 2014.1.3 allows local users to obtain passwords from commands that cause a ProcessExecutionError by reading the log.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 899190 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 4
  • openstack-cinder >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-api >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-backup >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-doc >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-scheduler >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-volume >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-nova >= 2014.1.4.dev49-0.7.1
  • openstack-nova-api >= 2014.1.4.dev49-0.7.1
  • openstack-nova-cells >= 2014.1.4.dev49-0.7.1
  • openstack-nova-cert >= 2014.1.4.dev49-0.7.1
  • openstack-nova-compute >= 2014.1.4.dev49-0.7.1
  • openstack-nova-conductor >= 2014.1.4.dev49-0.7.1
  • openstack-nova-console >= 2014.1.4.dev49-0.7.1
  • openstack-nova-consoleauth >= 2014.1.4.dev49-0.7.1
  • openstack-nova-doc >= 2014.1.4.dev49-0.7.1
  • openstack-nova-novncproxy >= 2014.1.4.dev49-0.7.1
  • openstack-nova-objectstore >= 2014.1.4.dev49-0.7.1
  • openstack-nova-scheduler >= 2014.1.4.dev49-0.7.1
  • openstack-nova-vncproxy >= 2014.1.4.dev49-0.7.1
  • python-cinder >= 2014.1.4.dev19.g80c0054-0.7.1
  • python-nova >= 2014.1.4.dev49-0.7.1
Patchnames:
sleclo40sp3-cinder-1114
sleclo40sp3-openstack-nova-0115
SUSE OpenStack Cloud 6
  • openstack-cinder >= 7.0.2~a0~dev1-1.2
  • openstack-cinder-api >= 7.0.2~a0~dev1-1.2
  • openstack-cinder-backup >= 7.0.2~a0~dev1-1.2
  • openstack-cinder-scheduler >= 7.0.2~a0~dev1-1.2
  • openstack-cinder-volume >= 7.0.2~a0~dev1-1.2
  • openstack-nova >= 12.0.2~a0~dev18-1.3
  • openstack-nova-api >= 12.0.2~a0~dev18-1.3
  • openstack-nova-cells >= 12.0.2~a0~dev18-1.3
  • openstack-nova-cert >= 12.0.2~a0~dev18-1.3
  • openstack-nova-compute >= 12.0.2~a0~dev18-1.3
  • openstack-nova-conductor >= 12.0.2~a0~dev18-1.3
  • openstack-nova-console >= 12.0.2~a0~dev18-1.3
  • openstack-nova-consoleauth >= 12.0.2~a0~dev18-1.3
  • openstack-nova-novncproxy >= 12.0.2~a0~dev18-1.3
  • openstack-nova-objectstore >= 12.0.2~a0~dev18-1.3
  • openstack-nova-scheduler >= 12.0.2~a0~dev18-1.3
  • openstack-nova-serialproxy >= 12.0.2~a0~dev18-1.3
  • openstack-nova-vncproxy >= 12.0.2~a0~dev18-1.3
  • openstack-trove >= 4.0.1~a0~dev2-2.1
  • openstack-trove-api >= 4.0.1~a0~dev2-2.1
  • openstack-trove-conductor >= 4.0.1~a0~dev2-2.1
  • openstack-trove-guestagent >= 4.0.1~a0~dev2-2.1
  • openstack-trove-taskmanager >= 4.0.1~a0~dev2-2.1
  • python-cinder >= 7.0.2~a0~dev1-1.2
  • python-nova >= 12.0.2~a0~dev18-1.3
  • python-trove >= 4.0.1~a0~dev2-2.1
Patchnames:
SUSE OpenStack Cloud 6 GA openstack-cinder
SUSE OpenStack Cloud 6 GA openstack-nova
SUSE OpenStack Cloud 6 GA openstack-trove
SUSE Cloud 4
  • openstack-cinder >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-api >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-backup >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-doc >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-scheduler >= 2014.1.4.dev19.g80c0054-0.7.1
  • openstack-cinder-volume >= 2014.1.4.dev19.g80c0054-0.7.1
  • python-cinder >= 2014.1.4.dev19.g80c0054-0.7.1
Builds
SAT Patch Nr: 9960
SUSE Cloud 4
  • openstack-nova >= 2014.1.4.dev49-0.7.1
  • openstack-nova-api >= 2014.1.4.dev49-0.7.1
  • openstack-nova-cells >= 2014.1.4.dev49-0.7.1
  • openstack-nova-cert >= 2014.1.4.dev49-0.7.1
  • openstack-nova-compute >= 2014.1.4.dev49-0.7.1
  • openstack-nova-conductor >= 2014.1.4.dev49-0.7.1
  • openstack-nova-console >= 2014.1.4.dev49-0.7.1
  • openstack-nova-consoleauth >= 2014.1.4.dev49-0.7.1
  • openstack-nova-doc >= 2014.1.4.dev49-0.7.1
  • openstack-nova-novncproxy >= 2014.1.4.dev49-0.7.1
  • openstack-nova-objectstore >= 2014.1.4.dev49-0.7.1
  • openstack-nova-scheduler >= 2014.1.4.dev49-0.7.1
  • openstack-nova-vncproxy >= 2014.1.4.dev49-0.7.1
  • python-nova >= 2014.1.4.dev49-0.7.1
Builds
SAT Patch Nr: 10199


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 11.3 ceph Released
SUSE Cloud 2.0 ceph Released
SUSE Cloud 4 ceph Released
SUSE Linux Enterprise Desktop 11 SP3 ceph Released
SUSE Linux Enterprise SDK 11 SP3 ceph Released
SUSE Linux Enterprise Server 11 SP3 ceph Released