Upstream information

CVE-2014-5388 at MITRE

Description

Off-by-one error in the pci_read function in the ACPI PCI hotplug interface (hw/acpi/pcihp.c) in QEMU allows local guest users to obtain sensitive information and have other unspecified impact related to a crafted PCI device that triggers memory corruption.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 893323 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12-LTSS
  • qemu >= 2.0.2-48.22.1
  • qemu-block-curl >= 2.0.2-48.22.1
  • qemu-block-rbd >= 2.0.2-48.22.1
  • qemu-guest-agent >= 2.0.2-48.22.1
  • qemu-ipxe >= 1.0.0-48.22.1
  • qemu-kvm >= 2.0.2-48.22.1
  • qemu-lang >= 2.0.2-48.22.1
  • qemu-ppc >= 2.0.2-48.22.1
  • qemu-s390 >= 2.0.2-48.22.1
  • qemu-seabios >= 1.7.4-48.22.1
  • qemu-sgabios >= 8-48.22.1
  • qemu-tools >= 2.0.2-48.22.1
  • qemu-vgabios >= 1.7.4-48.22.1
  • qemu-x86 >= 2.0.2-48.22.1
Patchnames:
SUSE-SLE-SERVER-12-2016-1646
SUSE Linux Enterprise Server for SAP Applications 12
  • qemu >= 2.0.2-48.22.1
  • qemu-block-curl >= 2.0.2-48.22.1
  • qemu-block-rbd >= 2.0.2-48.22.1
  • qemu-guest-agent >= 2.0.2-48.22.1
  • qemu-ipxe >= 1.0.0-48.22.1
  • qemu-kvm >= 2.0.2-48.22.1
  • qemu-lang >= 2.0.2-48.22.1
  • qemu-seabios >= 1.7.4-48.22.1
  • qemu-sgabios >= 8-48.22.1
  • qemu-tools >= 2.0.2-48.22.1
  • qemu-vgabios >= 1.7.4-48.22.1
  • qemu-x86 >= 2.0.2-48.22.1
Patchnames:
SUSE-SLE-SAP-12-2016-1646
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • qemu >= 2.0.2-48.22.1
  • qemu-block-curl >= 2.0.2-48.22.1
  • qemu-block-rbd >= 2.0.2-48.22.1
  • qemu-guest-agent >= 2.0.2-48.22.1
  • qemu-ipxe >= 1.0.0-48.22.1
  • qemu-kvm >= 2.0.2-48.22.1
  • qemu-lang >= 2.0.2-48.22.1
  • qemu-ppc >= 2.0.2-48.22.1
  • qemu-s390 >= 2.0.2-48.22.1
  • qemu-seabios >= 1.7.4-48.22.1
  • qemu-sgabios >= 8-48.22.1
  • qemu-tools >= 2.0.2-48.22.1
  • qemu-vgabios >= 1.7.4-48.22.1
  • qemu-x86 >= 2.0.2-48.22.1
Patchnames:
SUSE-SLE-SERVER-12-2016-1646


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 GA qemu Released
SUSE Linux Enterprise Desktop 12 SP1 qemu Unsupported
SUSE Linux Enterprise SDK 11 SP2 qemu Not affected
SUSE Linux Enterprise SDK 11 SP3 qemu Not affected
SUSE Linux Enterprise Server 12 GA qemu Released
SUSE Linux Enterprise Server 12 GA LTSS qemu Released
SUSE Linux Enterprise Server 12 SP1 qemu Unsupported