Upstream information

CVE-2014-4975 at MITRE

Description

Off-by-one error in the encodes function in pack.c in Ruby 1.9.3 and earlier, and 2.x through 2.1.2, when using certain format string specifiers, allows context-dependent attackers to cause a denial of service (segmentation fault) via vectors that trigger a stack-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 887877 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libruby2_1-2_1 >= 2.1.9-15.1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-stdlib >= 2.1.9-15.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-624
SUSE Linux Enterprise Desktop 12 SP1
  • libruby2_1-2_1 >= 2.1.9-15.1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-stdlib >= 2.1.9-15.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-624
SUSE Linux Enterprise Desktop 12 SP2
  • libruby2_1-2_1 >= 2.1.9-15.1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-stdlib >= 2.1.9-15.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-624
SUSE Linux Enterprise Desktop 12 SP3
  • libruby2_1-2_1 >= 2.1.9-18.1
  • ruby2.1 >= 2.1.9-18.1
  • ruby2.1-stdlib >= 2.1.9-18.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libruby2_1-2_1
SUSE Linux Enterprise Server 12 SP1
  • libruby2_1-2_1 >= 2.1.9-15.1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-stdlib >= 2.1.9-15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-624
SUSE Linux Enterprise Server 12 SP2
  • libruby2_1-2_1 >= 2.1.9-15.1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-stdlib >= 2.1.9-15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-624
SUSE Linux Enterprise Server 12 SP3
  • libruby2_1-2_1 >= 2.1.9-18.1
  • ruby2.1 >= 2.1.9-18.1
  • ruby2.1-stdlib >= 2.1.9-18.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libruby2_1-2_1
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libruby2_1-2_1 >= 2.1.9-15.1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-stdlib >= 2.1.9-15.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-624
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libruby2_1-2_1 >= 2.1.9-15.1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-stdlib >= 2.1.9-15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-624
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libruby2_1-2_1 >= 2.1.9-15.1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-stdlib >= 2.1.9-15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-624
SUSE Linux Enterprise Software Development Kit 12 SP1
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-devel >= 2.1.9-15.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-624
SUSE Linux Enterprise Software Development Kit 12 SP2
  • ruby2.1 >= 2.1.9-15.1
  • ruby2.1-devel >= 2.1.9-15.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-624
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ruby2.1-devel >= 2.1.9-18.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA ruby2.1-devel
openSUSE Leap 42.1
  • libruby2_1-2_1 >= 2.1.9-10.2
  • libruby2_1-2_1-debuginfo >= 2.1.9-10.2
  • ruby2.1 >= 2.1.9-10.2
  • ruby2.1-debuginfo >= 2.1.9-10.2
  • ruby2.1-debugsource >= 2.1.9-10.2
  • ruby2.1-devel >= 2.1.9-10.2
  • ruby2.1-devel-extra >= 2.1.9-10.2
  • ruby2.1-doc >= 2.1.9-10.2
  • ruby2.1-doc-ri >= 2.1.9-10.2
  • ruby2.1-stdlib >= 2.1.9-10.2
  • ruby2.1-stdlib-debuginfo >= 2.1.9-10.2
Patchnames:
openSUSE-2017-527
openSUSE Leap 42.2
  • libruby2_1-2_1 >= 2.1.9-8.3.2
  • libruby2_1-2_1-debuginfo >= 2.1.9-8.3.2
  • ruby2.1 >= 2.1.9-8.3.2
  • ruby2.1-debuginfo >= 2.1.9-8.3.2
  • ruby2.1-debugsource >= 2.1.9-8.3.2
  • ruby2.1-devel >= 2.1.9-8.3.2
  • ruby2.1-devel-extra >= 2.1.9-8.3.2
  • ruby2.1-doc >= 2.1.9-8.3.2
  • ruby2.1-doc-ri >= 2.1.9-8.3.2
  • ruby2.1-stdlib >= 2.1.9-8.3.2
  • ruby2.1-stdlib-debuginfo >= 2.1.9-8.3.2
Patchnames:
openSUSE-2017-527
openSUSE Leap 42.3
  • libruby2_1-2_1 >= 2.1.9-9.1
  • ruby2.1 >= 2.1.9-9.1
  • ruby2.1-devel >= 2.1.9-9.1
  • ruby2.1-stdlib >= 2.1.9-9.1
Patchnames:
openSUSE Leap 42.3 GA libruby2_1-2_1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
OpenStack Cloud Magnum Orchestration 7.0 ruby2.1 Released
SUSE Linux Enterprise Desktop 12 SP1 ruby2.1 Released
SUSE Linux Enterprise Desktop 12 SP2 ruby2.1 Released
SUSE Linux Enterprise SDK 12 SP1 ruby2.1 Released
SUSE Linux Enterprise SDK 12 SP2 ruby2.1 Released
SUSE Linux Enterprise Server 12 SP1 ruby2.1 Released
SUSE Linux Enterprise Server 12 SP2 ruby2.1 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI ruby2.1 Released