Upstream information

CVE-2014-4338 at MITRE

Description

cups-browsed in cups-filters before 1.0.53 allows remote attackers to bypass intended access restrictions in opportunistic circumstances by leveraging a malformed cups-browsed.conf BrowseAllow directive that is interpreted as granting browse access to all IP addresses.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:H/Au:N/C:P/I:P/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 871327 [RESOLVED / FIXED], 883536 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • cups-filters >= 1.0.58-2.6
  • cups-filters-cups-browsed >= 1.0.58-2.6
  • cups-filters-foomatic-rip >= 1.0.58-2.6
  • cups-filters-ghostscript >= 1.0.58-2.6
Patchnames:
SUSE Linux Enterprise Desktop 12 GA cups-filters
SUSE Linux Enterprise Desktop 12 SP1
  • cups-filters >= 1.0.58-8.1
  • cups-filters-cups-browsed >= 1.0.58-8.1
  • cups-filters-foomatic-rip >= 1.0.58-8.1
  • cups-filters-ghostscript >= 1.0.58-8.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA cups-filters
SUSE Linux Enterprise Desktop 12 SP2
  • cups-filters >= 1.0.58-13.1
  • cups-filters-cups-browsed >= 1.0.58-13.1
  • cups-filters-foomatic-rip >= 1.0.58-13.1
  • cups-filters-ghostscript >= 1.0.58-13.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA cups-filters
SUSE Linux Enterprise Desktop 12 SP3
  • cups-filters >= 1.0.58-17.11
  • cups-filters-cups-browsed >= 1.0.58-17.11
  • cups-filters-foomatic-rip >= 1.0.58-17.11
  • cups-filters-ghostscript >= 1.0.58-17.11
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA cups-filters
SUSE Linux Enterprise Module for Basesystem 15
  • cups-filters >= 1.20.3-1.12
  • cups-filters-devel >= 1.20.3-1.12
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA cups-filters
SUSE Linux Enterprise Server 12
  • cups-filters >= 1.0.58-2.6
  • cups-filters-cups-browsed >= 1.0.58-2.6
  • cups-filters-foomatic-rip >= 1.0.58-2.6
  • cups-filters-ghostscript >= 1.0.58-2.6
Patchnames:
SUSE Linux Enterprise Server 12 GA cups-filters
SUSE Linux Enterprise Server 12 SP1
  • cups-filters >= 1.0.58-8.1
  • cups-filters-cups-browsed >= 1.0.58-8.1
  • cups-filters-foomatic-rip >= 1.0.58-8.1
  • cups-filters-ghostscript >= 1.0.58-8.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA cups-filters
SUSE Linux Enterprise Server 12 SP2
  • cups-filters >= 1.0.58-13.1
  • cups-filters-cups-browsed >= 1.0.58-13.1
  • cups-filters-foomatic-rip >= 1.0.58-13.1
  • cups-filters-ghostscript >= 1.0.58-13.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA cups-filters
SUSE Linux Enterprise Server 12 SP3
  • cups-filters >= 1.0.58-17.11
  • cups-filters-cups-browsed >= 1.0.58-17.11
  • cups-filters-foomatic-rip >= 1.0.58-17.11
  • cups-filters-ghostscript >= 1.0.58-17.11
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA cups-filters
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • cups-filters >= 1.0.58-13.1
  • cups-filters-cups-browsed >= 1.0.58-13.1
  • cups-filters-foomatic-rip >= 1.0.58-13.1
  • cups-filters-ghostscript >= 1.0.58-13.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA cups-filters
openSUSE Leap 15.0
  • cups-filters >= 1.20.3-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA cups-filters
openSUSE Leap 42.1
  • cups-filters >= 1.0.58-10.3
  • cups-filters-cups-browsed >= 1.0.58-10.3
  • cups-filters-foomatic-rip >= 1.0.58-10.3
  • cups-filters-ghostscript >= 1.0.58-10.3
Patchnames:
openSUSE Leap 42.1 GA cups-filters
openSUSE Leap 42.2
  • cups-filters >= 1.8.2-1.5
  • cups-filters-cups-browsed >= 1.8.2-1.5
  • cups-filters-foomatic-rip >= 1.8.2-1.5
  • cups-filters-ghostscript >= 1.8.2-1.5
Patchnames:
openSUSE Leap 42.2 GA cups-filters
openSUSE Leap 42.3
  • cups-filters >= 1.8.2-3.1
  • cups-filters-cups-browsed >= 1.8.2-3.1
  • cups-filters-foomatic-rip >= 1.8.2-3.1
  • cups-filters-ghostscript >= 1.8.2-3.1
Patchnames:
openSUSE Leap 42.3 GA cups-filters
openSUSE Tumbleweed
  • cups-filters >= 1.8.2-1.11
  • cups-filters-cups-browsed >= 1.8.2-1.11
  • cups-filters-devel >= 1.8.2-1.11
  • cups-filters-foomatic-rip >= 1.8.2-1.11
  • cups-filters-ghostscript >= 1.8.2-1.11
Patchnames:
openSUSE Tumbleweed GA cups-filters