Upstream information

CVE-2014-4240 at MITRE

Description

Unspecified vulnerability in the MySQL Server component in Oracle MySQL 5.6.17 and earlier allows local users to affect confidentiality and integrity via vectors related to SRREP.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 3.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 887580 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libmysql55client18 >= 5.5.39-0.7.1
  • libmysql55client18-32bit >= 5.5.39-0.7.1
  • libmysql55client_r18 >= 5.5.39-0.7.1
  • libmysql55client_r18-32bit >= 5.5.39-0.7.1
  • libmysqlclient15 >= 5.0.96-0.6.13
  • libmysqlclient15-32bit >= 5.0.96-0.6.13
  • libmysqlclient_r15 >= 5.0.96-0.6.13
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.13
  • mysql >= 5.5.39-0.7.1
  • mysql-client >= 5.5.39-0.7.1
Patchnames:
sledsp3-libmysql55client18
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server for SAP Applications 11 SP3
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libmysql55client18 >= 5.5.39-0.7.1
  • libmysql55client18-32bit >= 5.5.39-0.7.1
  • libmysql55client18-x86 >= 5.5.39-0.7.1
  • libmysql55client_r18 >= 5.5.39-0.7.1
  • libmysqlclient15 >= 5.0.96-0.6.13
  • libmysqlclient15-32bit >= 5.0.96-0.6.13
  • libmysqlclient15-x86 >= 5.0.96-0.6.13
  • libmysqlclient_r15 >= 5.0.96-0.6.13
  • mysql >= 5.5.39-0.7.1
  • mysql-client >= 5.5.39-0.7.1
  • mysql-tools >= 5.5.39-0.7.1
Patchnames:
slessp3-libmysql55client18
SUSE Linux Enterprise Server 11 SP4
  • libmysql55client18 >= 5.5.43-0.7.3
  • libmysql55client18-32bit >= 5.5.43-0.7.3
  • libmysql55client18-x86 >= 5.5.43-0.7.3
  • libmysql55client_r18 >= 5.5.43-0.7.3
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
  • mysql >= 5.5.43-0.7.3
  • mysql-client >= 5.5.43-0.7.3
  • mysql-tools >= 5.5.43-0.7.3
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libmysql55client_r18-32bit >= 5.5.39-0.7.1
  • libmysql55client_r18-x86 >= 5.5.39-0.7.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.13
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.13
Patchnames:
sdksp3-libmysql55client18
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmysql55client_r18-32bit >= 5.5.43-0.7.3
  • libmysql55client_r18-x86 >= 5.5.43-0.7.3
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libmysql55client_r18-x86 >= 5.5.39-0.7.1
  • libmysqlclient_r15-x86 >= 5.0.96-0.6.13
Builds
SAT Patch Nr: 9624
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libmysql55client_r18-32bit >= 5.5.39-0.7.1
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.13
Builds
SAT Patch Nr: 9624
SUSE Linux Enterprise Desktop 11 SP3
  • libmysql55client18 >= 5.5.39-0.7.1
  • libmysql55client_r18 >= 5.5.39-0.7.1
  • libmysqlclient15 >= 5.0.96-0.6.13
  • libmysqlclient_r15 >= 5.0.96-0.6.13
  • mysql >= 5.5.39-0.7.1
  • mysql-client >= 5.5.39-0.7.1
Builds
SAT Patch Nr: 9624
SUSE Linux Enterprise Desktop 11 SP3
  • libmysql55client18 >= 5.5.39-0.7.1
  • libmysql55client18-32bit >= 5.5.39-0.7.1
  • libmysql55client_r18 >= 5.5.39-0.7.1
  • libmysql55client_r18-32bit >= 5.5.39-0.7.1
  • libmysqlclient15 >= 5.0.96-0.6.13
  • libmysqlclient15-32bit >= 5.0.96-0.6.13
  • libmysqlclient_r15 >= 5.0.96-0.6.13
  • libmysqlclient_r15-32bit >= 5.0.96-0.6.13
  • mysql >= 5.5.39-0.7.1
  • mysql-client >= 5.5.39-0.7.1
Builds
SAT Patch Nr: 9624
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libmysql55client18 >= 5.5.39-0.7.1
  • libmysql55client_r18 >= 5.5.39-0.7.1
  • libmysqlclient15 >= 5.0.96-0.6.13
  • libmysqlclient_r15 >= 5.0.96-0.6.13
  • mysql >= 5.5.39-0.7.1
  • mysql-client >= 5.5.39-0.7.1
  • mysql-tools >= 5.5.39-0.7.1
Builds
SAT Patch Nr: 9624
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libmysql55client18 >= 5.5.39-0.7.1
  • libmysql55client18-32bit >= 5.5.39-0.7.1
  • libmysql55client_r18 >= 5.5.39-0.7.1
  • libmysqlclient15 >= 5.0.96-0.6.13
  • libmysqlclient15-32bit >= 5.0.96-0.6.13
  • libmysqlclient_r15 >= 5.0.96-0.6.13
  • mysql >= 5.5.39-0.7.1
  • mysql-client >= 5.5.39-0.7.1
  • mysql-tools >= 5.5.39-0.7.1
Builds
SAT Patch Nr: 9624
SUSE Linux Enterprise Server 11 SP3
  • libmysql55client18 >= 5.5.39-0.7.1
  • libmysql55client18-x86 >= 5.5.39-0.7.1
  • libmysql55client_r18 >= 5.5.39-0.7.1
  • libmysqlclient15 >= 5.0.96-0.6.13
  • libmysqlclient15-x86 >= 5.0.96-0.6.13
  • libmysqlclient_r15 >= 5.0.96-0.6.13
  • mysql >= 5.5.39-0.7.1
  • mysql-client >= 5.5.39-0.7.1
  • mysql-tools >= 5.5.39-0.7.1
Builds
SAT Patch Nr: 9624


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 mysql Affected
SLED-10-SP4 mysql Affected
SLES-10-SP3 mysql Affected
SLES-10-SP4 mysql Affected
SLES_LTSS-10-SP4 mysql Affected
SUSE Linux Enterprise Desktop 11 SP1 mysql Affected
SUSE Linux Enterprise Desktop 11 SP3 mysql Released
SUSE Linux Enterprise Desktop 11 SP4 mysql Released
SUSE Linux Enterprise Server 11 SP1 mysql Affected
SUSE Linux Enterprise Server 11 SP1 LTSS mysql Affected
SUSE Linux Enterprise Server 11 SP3 mysql Released
SUSE Linux Enterprise Server 11 SP3 for VMware mysql Released
SUSE Linux Enterprise Server 11 SP4 mysql Released
SUSE Linux Enterprise Server 11 SP4 LTSS mysql Released
SUSE Linux Enterprise Server for SAP Business All-in-One mysql Affected
SUSE Linux Enterprise Software Development Kit 11 SP1 mysql Affected
SUSE Linux Enterprise Software Development Kit 11 SP3 mysql Released