Upstream information

CVE-2014-3708 at MITRE

Description

OpenStack Compute (Nova) before 2014.1.4 and 2014.2.x before 2014.2.1 allows remote authenticated users to cause a denial of service (CPU consumption) via an IP filter in a list active servers API request.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication Single Single
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
SUSE Bugzilla entry: 903013 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 4
  • openstack-nova >= 2014.1.4.dev49-0.7.1
  • openstack-nova-api >= 2014.1.4.dev49-0.7.1
  • openstack-nova-cells >= 2014.1.4.dev49-0.7.1
  • openstack-nova-cert >= 2014.1.4.dev49-0.7.1
  • openstack-nova-compute >= 2014.1.4.dev49-0.7.1
  • openstack-nova-conductor >= 2014.1.4.dev49-0.7.1
  • openstack-nova-console >= 2014.1.4.dev49-0.7.1
  • openstack-nova-consoleauth >= 2014.1.4.dev49-0.7.1
  • openstack-nova-doc >= 2014.1.4.dev49-0.7.1
  • openstack-nova-novncproxy >= 2014.1.4.dev49-0.7.1
  • openstack-nova-objectstore >= 2014.1.4.dev49-0.7.1
  • openstack-nova-scheduler >= 2014.1.4.dev49-0.7.1
  • openstack-nova-vncproxy >= 2014.1.4.dev49-0.7.1
  • python-nova >= 2014.1.4.dev49-0.7.1
Patchnames:
sleclo40sp3-openstack-nova-0115
SUSE OpenStack Cloud 6
  • openstack-nova >= 12.0.2~a0~dev18-1.3
  • openstack-nova-api >= 12.0.2~a0~dev18-1.3
  • openstack-nova-cells >= 12.0.2~a0~dev18-1.3
  • openstack-nova-cert >= 12.0.2~a0~dev18-1.3
  • openstack-nova-compute >= 12.0.2~a0~dev18-1.3
  • openstack-nova-conductor >= 12.0.2~a0~dev18-1.3
  • openstack-nova-console >= 12.0.2~a0~dev18-1.3
  • openstack-nova-consoleauth >= 12.0.2~a0~dev18-1.3
  • openstack-nova-novncproxy >= 12.0.2~a0~dev18-1.3
  • openstack-nova-objectstore >= 12.0.2~a0~dev18-1.3
  • openstack-nova-scheduler >= 12.0.2~a0~dev18-1.3
  • openstack-nova-serialproxy >= 12.0.2~a0~dev18-1.3
  • openstack-nova-vncproxy >= 12.0.2~a0~dev18-1.3
  • python-nova >= 12.0.2~a0~dev18-1.3
Patchnames:
SUSE OpenStack Cloud 6 GA openstack-nova
SUSE Cloud 4
  • openstack-nova >= 2014.1.4.dev49-0.7.1
  • openstack-nova-api >= 2014.1.4.dev49-0.7.1
  • openstack-nova-cells >= 2014.1.4.dev49-0.7.1
  • openstack-nova-cert >= 2014.1.4.dev49-0.7.1
  • openstack-nova-compute >= 2014.1.4.dev49-0.7.1
  • openstack-nova-conductor >= 2014.1.4.dev49-0.7.1
  • openstack-nova-console >= 2014.1.4.dev49-0.7.1
  • openstack-nova-consoleauth >= 2014.1.4.dev49-0.7.1
  • openstack-nova-doc >= 2014.1.4.dev49-0.7.1
  • openstack-nova-novncproxy >= 2014.1.4.dev49-0.7.1
  • openstack-nova-objectstore >= 2014.1.4.dev49-0.7.1
  • openstack-nova-scheduler >= 2014.1.4.dev49-0.7.1
  • openstack-nova-vncproxy >= 2014.1.4.dev49-0.7.1
  • python-nova >= 2014.1.4.dev49-0.7.1
Builds
SAT Patch Nr: 10199


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Cloud 11.3 openstack-nova Released
SUSE Cloud 2.0 openstack-nova Released
SUSE Cloud 4 openstack-nova Released