Upstream information

CVE-2014-3583 at MITRE

Description

The handle_headers function in mod_proxy_fcgi.c in the mod_proxy_fcgi module in the Apache HTTP Server 2.4.10 allows remote FastCGI servers to cause a denial of service (buffer over-read and daemon crash) via long response headers.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
No SUSE Bugzilla entries cross referenced.

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Server Applications 15
  • apache2 >= 2.4.33-1.28
  • apache2-devel >= 2.4.33-1.28
  • apache2-doc >= 2.4.33-1.28
  • apache2-prefork >= 2.4.33-1.28
  • apache2-utils >= 2.4.33-1.28
  • apache2-worker >= 2.4.33-1.28
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA apache2
SUSE Linux Enterprise Server 12 SP1
  • apache2 >= 2.4.16-5.1
  • apache2-doc >= 2.4.16-5.1
  • apache2-example-pages >= 2.4.16-5.1
  • apache2-prefork >= 2.4.16-5.1
  • apache2-utils >= 2.4.16-5.1
  • apache2-worker >= 2.4.16-5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA apache2
SUSE Linux Enterprise Server 12 SP2
  • apache2 >= 2.4.23-14.7
  • apache2-doc >= 2.4.23-14.7
  • apache2-example-pages >= 2.4.23-14.7
  • apache2-prefork >= 2.4.23-14.7
  • apache2-utils >= 2.4.23-14.7
  • apache2-worker >= 2.4.23-14.7
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA apache2
SUSE Linux Enterprise Server 12 SP3
  • apache2 >= 2.4.23-28.1
  • apache2-doc >= 2.4.23-28.1
  • apache2-example-pages >= 2.4.23-28.1
  • apache2-prefork >= 2.4.23-28.1
  • apache2-utils >= 2.4.23-28.1
  • apache2-worker >= 2.4.23-28.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA apache2
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • apache2 >= 2.4.23-14.7
  • apache2-doc >= 2.4.23-14.7
  • apache2-example-pages >= 2.4.23-14.7
  • apache2-prefork >= 2.4.23-14.7
  • apache2-utils >= 2.4.23-14.7
  • apache2-worker >= 2.4.23-14.7
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA apache2
SUSE Linux Enterprise Software Development Kit 12 SP1
  • apache2-devel >= 2.4.16-5.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA apache2-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • apache2-devel >= 2.4.23-14.7
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA apache2-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • apache2-devel >= 2.4.23-28.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA apache2-devel
openSUSE Leap 15.0
  • apache2 >= 2.4.33-lp150.1.2
  • apache2-doc >= 2.4.33-lp150.1.2
  • apache2-example-pages >= 2.4.33-lp150.1.2
  • apache2-prefork >= 2.4.33-lp150.1.2
  • apache2-utils >= 2.4.33-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA apache2
openSUSE Leap 42.1
  • apache2 >= 2.4.16-7.1
  • apache2-devel >= 2.4.16-7.1
  • apache2-doc >= 2.4.16-7.1
  • apache2-example-pages >= 2.4.16-7.1
  • apache2-prefork >= 2.4.16-7.1
  • apache2-utils >= 2.4.16-7.1
Patchnames:
openSUSE Leap 42.1 GA apache2
openSUSE Leap 42.2
  • apache2 >= 2.4.23-4.3
  • apache2-devel >= 2.4.23-4.3
  • apache2-doc >= 2.4.23-4.3
  • apache2-example-pages >= 2.4.23-4.3
  • apache2-prefork >= 2.4.23-4.3
  • apache2-utils >= 2.4.23-4.3
Patchnames:
openSUSE Leap 42.2 GA apache2
openSUSE Leap 42.3
  • apache2 >= 2.4.23-11.2
  • apache2-devel >= 2.4.23-11.2
  • apache2-doc >= 2.4.23-11.2
  • apache2-example-pages >= 2.4.23-11.2
  • apache2-prefork >= 2.4.23-11.2
  • apache2-utils >= 2.4.23-11.2
Patchnames:
openSUSE Leap 42.3 GA apache2
openSUSE Tumbleweed
  • apache2 >= 2.4.23-4.1
  • apache2-devel >= 2.4.23-4.1
  • apache2-doc >= 2.4.23-4.1
  • apache2-event >= 2.4.23-4.1
  • apache2-example-pages >= 2.4.23-4.1
  • apache2-prefork >= 2.4.23-4.1
  • apache2-utils >= 2.4.23-4.1
  • apache2-worker >= 2.4.23-4.1
Patchnames:
openSUSE Tumbleweed GA apache2