Upstream information

CVE-2014-3564 at MITRE

Description

Multiple heap-based buffer overflows in the status_handler function in (1) engine-gpgsm.c and (2) engine-uiserver.c in GPGME before 1.5.1 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to "different line lengths in a specific order."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 890123 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • gpgme >= 1.1.6-25.32.1
  • libgpgme11 >= 1.1.6-25.32.1
Patchnames:
sledsp3-gpgme
SUSE Linux Enterprise Desktop 12
  • gpgme >= 1.5.1-1.12
  • libgpgme11 >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Desktop 12 GA gpgme
SUSE Linux Enterprise Desktop 12 SP1
  • gpgme >= 1.5.1-1.12
  • libgpgme11 >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA gpgme
SUSE Linux Enterprise Desktop 12 SP2
  • gpgme >= 1.5.1-1.12
  • libgpgme11 >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA gpgme
SUSE Linux Enterprise Desktop 12 SP3
  • gpgme >= 1.5.1-1.12
  • libgpgme11 >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gpgme
SUSE Linux Enterprise Module for Basesystem 15
  • gpgme >= 1.10.0-2.43
  • libgpgme-devel >= 1.10.0-2.43
  • libgpgme11 >= 1.10.0-2.43
  • libgpgmepp-devel >= 1.10.0-2.43
  • libgpgmepp6 >= 1.10.0-2.43
  • libqgpgme-devel >= 1.10.0-2.43
  • libqgpgme7 >= 1.10.0-2.43
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA gpgme
SUSE Linux Enterprise Server 11 SP3
  • gpgme >= 1.1.6-25.32.1
  • libgpgme11 >= 1.1.6-25.32.1
Patchnames:
slessp3-gpgme
SUSE Linux Enterprise Server 11 SP4
  • gpgme >= 1.1.6-25.32.1
  • libgpgme11 >= 1.1.6-25.32.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA gpgme
SUSE Linux Enterprise Server 12
  • gpgme >= 1.5.1-1.12
  • libgpgme11 >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Server 12 GA gpgme
SUSE Linux Enterprise Server 12 SP1
  • gpgme >= 1.5.1-1.12
  • libgpgme11 >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA gpgme
SUSE Linux Enterprise Server 12 SP2
  • gpgme >= 1.5.1-1.12
  • libgpgme11 >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA gpgme
SUSE Linux Enterprise Server 12 SP3
  • gpgme >= 1.5.1-1.12
  • libgpgme11 >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gpgme
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gpgme >= 1.5.1-1.11
  • libgpgme11 >= 1.5.1-1.11
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA gpgme
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • gpgme >= 1.1.6-25.32.1
  • libgpgme11 >= 1.1.6-25.32.1
Patchnames:
slessp3-gpgme
SUSE Linux Enterprise Server for VMWare 11 SP3
  • gpgme >= 1.1.6-25.32.1
  • libgpgme11 >= 1.1.6-25.32.1
Patchnames:
slessp3-gpgme
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libgpgme-devel >= 1.1.6-25.32.1
  • libgpgme11-32bit >= 1.1.6-25.32.1
  • libgpgme11-x86 >= 1.1.6-25.32.1
Patchnames:
sdksp3-gpgme
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libgpgme-devel >= 1.1.6-25.32.1
  • libgpgme11-32bit >= 1.1.6-25.32.1
  • libgpgme11-x86 >= 1.1.6-25.32.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libgpgme-devel
SUSE Linux Enterprise Software Development Kit 12
  • libgpgme-devel >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libgpgme-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libgpgme-devel >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libgpgme-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libgpgme-devel >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libgpgme-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libgpgme-devel >= 1.5.1-1.12
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libgpgme-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libgpgme-devel >= 1.1.6-25.32.1
Builds
SAT Patch Nr: 9644
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libgpgme-devel >= 1.1.6-25.32.1
  • libgpgme11-x86 >= 1.1.6-25.32.1
Builds
SAT Patch Nr: 9644
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libgpgme-devel >= 1.1.6-25.32.1
  • libgpgme11-32bit >= 1.1.6-25.32.1
Builds
SAT Patch Nr: 9644
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • gpgme >= 1.1.6-25.32.1
  • libgpgme11 >= 1.1.6-25.32.1
Builds
SAT Patch Nr: 9644
openSUSE 13.1
  • gpgme >= 1.4.4-2.4.1
  • gpgme-debugsource >= 1.4.4-2.4.1
  • libgpgme-devel >= 1.4.4-2.4.1
  • libgpgme11 >= 1.4.4-2.4.1
  • libgpgme11-32bit >= 1.4.4-2.4.1
  • libgpgme11-debuginfo >= 1.4.4-2.4.1
  • libgpgme11-debuginfo-32bit >= 1.4.4-2.4.1
Patchnames:
openSUSE-2014-500
openSUSE Leap 15.0
  • gpgme >= 1.10.0-lp150.2.6
  • libgpgme11 >= 1.10.0-lp150.2.6
  • libgpgmepp6 >= 1.10.0-lp150.2.6
  • libqgpgme7 >= 1.10.0-lp150.2.6
Patchnames:
openSUSE Leap 15.0 GA gpgme
openSUSE Leap 42.1
  • gpgme >= 1.6.0-9.1
  • libgpgme-devel >= 1.6.0-9.1
  • libgpgme11 >= 1.6.0-9.1
Patchnames:
openSUSE Leap 42.1 GA gpgme
openSUSE Leap 42.2
  • gpgme >= 1.6.0-10.5
  • libgpgme-devel >= 1.6.0-10.5
  • libgpgme11 >= 1.6.0-10.5
Patchnames:
openSUSE Leap 42.2 GA gpgme
openSUSE Leap 42.3
  • gpgme >= 1.9.0-1.3
  • libgpgme-devel >= 1.9.0-1.3
  • libgpgme11 >= 1.9.0-1.3
  • libgpgmepp6 >= 1.9.0-1.3
  • libqgpgme7 >= 1.9.0-1.3
Patchnames:
openSUSE Leap 42.3 GA gpgme
openSUSE Tumbleweed
  • gpgme >= 1.8.0-2.1
  • libgpgme-devel >= 1.8.0-2.1
  • libgpgme11 >= 1.8.0-2.1
  • libgpgme11-32bit >= 1.8.0-2.1
  • libgpgmepp-devel >= 1.8.0-2.1
  • libgpgmepp6 >= 1.8.0-2.1
  • libgpgmepp6-32bit >= 1.8.0-2.1
  • libqgpgme-devel >= 1.8.0-2.1
  • libqgpgme7 >= 1.8.0-2.1
  • libqgpgme7-32bit >= 1.8.0-2.1
  • python-gpg >= 1.8.0-2.1
Patchnames:
openSUSE Tumbleweed GA gpgme


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 gpgme Released
SUSE Linux Enterprise Desktop 10 SP4 gpgme Released
SUSE Linux Enterprise Desktop 11 SP1 gpgme Released
SUSE Linux Enterprise Desktop 11 SP3 gpgme Released
SUSE Linux Enterprise SDK 11 SP1 gpgme Released
SUSE Linux Enterprise SDK 11 SP3 gpgme Released
SUSE Linux Enterprise Server 10 SP3 gpgme Released
SUSE Linux Enterprise Server 10 SP4 gpgme Released
SUSE Linux Enterprise Server 10 SP4 LTSS gpgme Released
SUSE Linux Enterprise Server 11 SP1 gpgme Released
SUSE Linux Enterprise Server 11 SP1 LTSS gpgme Released
SUSE Linux Enterprise Server 11 SP3 gpgme Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 gpgme Released
SUSE Linux Enterprise Server for VMWare 11 SP3 gpgme Released