Upstream information

CVE-2014-3248 at MITRE

Description

Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.2 6.6
Vector AV:L/AC:H/Au:N/C:C/I:C/A:C AV:L/AC:M/Au:S/C:C/I:C/A:C
Access Vector Local Local
Access Complexity High Medium
Authentication None Single
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
SUSE Bugzilla entry: 879913 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • puppet >= 2.6.18-0.16.1
Patchnames:
sledsp3-puppet
SUSE Linux Enterprise Desktop 12
  • facter >= 2.0.2-1.6
  • puppet >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Desktop 12 GA facter
SUSE Linux Enterprise Desktop 12 GA puppet
SUSE Linux Enterprise Desktop 12 SP1
  • facter >= 2.0.2-6.1
  • puppet >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA facter
SUSE Linux Enterprise Desktop 12 SP1 GA puppet
SUSE Linux Enterprise Desktop 12 SP2
  • facter >= 2.0.2-6.1
  • puppet >= 3.8.5-5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA facter
SUSE Linux Enterprise Desktop 12 SP2 GA puppet
SUSE Linux Enterprise Desktop 12 SP3
  • facter >= 2.4.6-11.3
  • puppet >= 3.8.5-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA facter
SUSE Linux Enterprise Desktop 12 SP3 GA puppet
SUSE Linux Enterprise Module for Advanced Systems Management 12
  • facter >= 2.0.2-1.6
  • puppet >= 3.6.2-3.62
  • puppet-server >= 3.6.2-3.62
Patchnames:
SUSE Linux Enterprise Module for Advanced Systems Management 12 GA facter
SUSE Linux Enterprise Module for Advanced Systems Management 12 GA puppet
SUSE Linux Enterprise Server 11 SP3
  • puppet >= 2.6.18-0.16.1
  • puppet-server >= 2.6.18-0.16.1
Patchnames:
slessp3-puppet
SUSE Linux Enterprise Server 11 SP4
  • puppet >= 2.7.26-0.5.1
  • puppet-server >= 2.7.26-0.5.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA puppet
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • puppet >= 2.6.18-0.16.1
  • puppet-server >= 2.6.18-0.16.1
Patchnames:
slessp3-puppet
SUSE Linux Enterprise Server for VMWare 11 SP3
  • puppet >= 2.6.18-0.16.1
  • puppet-server >= 2.6.18-0.16.1
Patchnames:
slessp3-puppet
SUSE Linux Enterprise Desktop 11 SP3
  • puppet >= 2.6.18-0.16.1
Builds
SAT Patch Nr: 9472
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • puppet >= 2.6.18-0.16.1
  • puppet-server >= 2.6.18-0.16.1
Builds
SAT Patch Nr: 9472
openSUSE Tumbleweed
  • ruby2.2-rubygem-facter >= 2.4.6-2.1
  • ruby2.2-rubygem-facter-doc >= 2.4.6-2.1
  • ruby2.2-rubygem-facter-testsuite >= 2.4.6-2.1
  • ruby2.2-rubygem-hiera >= 1.3.4-3.5
  • ruby2.2-rubygem-hiera-doc >= 1.3.4-3.5
  • ruby2.2-rubygem-hiera-testsuite >= 1.3.4-3.5
  • ruby2.2-rubygem-puppet >= 3.8.7-2.2
  • ruby2.2-rubygem-puppet-doc >= 3.8.7-2.2
  • ruby2.2-rubygem-puppet-testsuite >= 3.8.7-2.2
  • ruby2.3-rubygem-facter >= 2.4.6-2.1
  • ruby2.3-rubygem-facter-doc >= 2.4.6-2.1
  • ruby2.3-rubygem-facter-testsuite >= 2.4.6-2.1
  • ruby2.3-rubygem-hiera >= 1.3.4-3.5
  • ruby2.3-rubygem-hiera-doc >= 1.3.4-3.5
  • ruby2.3-rubygem-hiera-testsuite >= 1.3.4-3.5
  • ruby2.3-rubygem-puppet >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet-doc >= 3.8.7-2.2
  • ruby2.3-rubygem-puppet-testsuite >= 3.8.7-2.2
  • rubygem-facter >= 2.4.6-2.1
  • rubygem-hiera >= 1.3.4-3.5
  • rubygem-puppet >= 3.8.7-2.2
  • rubygem-puppet-emacs >= 3.8.7-2.2
  • rubygem-puppet-master >= 3.8.7-2.2
  • rubygem-puppet-master-unicorn >= 3.8.7-2.2
  • rubygem-puppet-vim >= 3.8.7-2.2
Patchnames:
openSUSE Tumbleweed GA ruby2.2-rubygem-facter
openSUSE Tumbleweed GA ruby2.2-rubygem-puppet


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 puppet Released
SUSE Linux Enterprise Desktop 11 SP2 puppet Released
SUSE Linux Enterprise Desktop 11 SP3 puppet Released
SUSE Linux Enterprise Desktop 11 SP4 puppet Released
SUSE Linux Enterprise Server 11 SP1 puppet Released
SUSE Linux Enterprise Server 11 SP1 LTSS puppet Released
SUSE Linux Enterprise Server 11 SP2 puppet Released
SUSE Linux Enterprise Server 11 SP2 LTSS puppet Released
SUSE Linux Enterprise Server 11 SP3 puppet Released
SUSE Linux Enterprise Server 11 SP3 LTSS puppet Released
SUSE Linux Enterprise Server 11 SP4 puppet Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 puppet Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 puppet Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 puppet Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 puppet Released
SUSE Linux Enterprise Server for VMWare 11 SP2 puppet Released
SUSE Linux Enterprise Server for VMWare 11 SP3 puppet Released