Upstream information

CVE-2014-3158 at MITRE

Description

Integer overflow in the getword function in options.c in pppd in Paul's PPP Package (ppp) before 2.4.7 allows attackers to "access privileged options" via a long word in an options file, which triggers a heap-based buffer overflow that "[corrupts] security-relevant variables."

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 891489 [RESOLVED / FIXED], 969773 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • ppp >= 2.4.5.git-2.29.1
Patchnames:
sledsp3-ppp
SUSE Linux Enterprise Desktop 12
  • ppp >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Desktop 12 GA ppp
SUSE Linux Enterprise Desktop 12 SP1
  • ppp >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA ppp
SUSE Linux Enterprise Desktop 12 SP2
  • ppp >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA ppp
SUSE Linux Enterprise Desktop 12 SP3
  • ppp >= 2.4.7-3.4
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA ppp
SUSE Linux Enterprise Module for Desktop Applications 15
  • ppp >= 2.4.7-3.28
  • ppp-devel >= 2.4.7-3.28
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA ppp
SUSE Linux Enterprise Server 11 SP3
  • ppp >= 2.4.5.git-2.29.1
Patchnames:
slessp3-ppp
SUSE Linux Enterprise Server 11 SP4
  • ppp >= 2.4.5.git-2.29.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ppp
SUSE Linux Enterprise Server 12
  • ppp >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Server 12 GA ppp
SUSE Linux Enterprise Server 12 SP1
  • ppp >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA ppp
SUSE Linux Enterprise Server 12 SP2
  • ppp >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA ppp
SUSE Linux Enterprise Server 12 SP3
  • ppp >= 2.4.7-3.4
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA ppp
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ppp >= 2.4.7-1.4
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA ppp
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • ppp >= 2.4.5.git-2.29.1
Patchnames:
slessp3-ppp
SUSE Linux Enterprise Server for VMWare 11 SP3
  • ppp >= 2.4.5.git-2.29.1
Patchnames:
slessp3-ppp
SUSE Linux Enterprise Software Development Kit 11 SP3
  • ppp-devel >= 2.4.5.git-2.29.1
Patchnames:
sdksp3-ppp
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ppp-devel >= 2.4.5.git-2.29.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ppp-devel
SUSE Linux Enterprise Software Development Kit 12
  • ppp-devel >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA ppp-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • ppp-devel >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA ppp-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • ppp-devel >= 2.4.7-1.7
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA ppp-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ppp-devel >= 2.4.7-3.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA ppp-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • ppp-devel >= 2.4.5.git-2.29.1
Builds
SAT Patch Nr: 9648
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • ppp >= 2.4.5.git-2.29.1
Builds
SAT Patch Nr: 9648
openSUSE 13.1
  • ppp >= 2.4.5-20.4.1
  • ppp-debuginfo >= 2.4.5-20.4.1
  • ppp-debugsource >= 2.4.5-20.4.1
  • ppp-devel >= 2.4.5-20.4.1
Patchnames:
openSUSE-2014-545
openSUSE Leap 15.0
  • ppp >= 2.4.7-lp150.3.3
Patchnames:
openSUSE Leap 15.0 GA ppp
openSUSE Leap 42.1
  • ppp >= 2.4.7-3.2
Patchnames:
openSUSE Leap 42.1 GA ppp
openSUSE Leap 42.2
  • ppp >= 2.4.7-5.5
Patchnames:
openSUSE Leap 42.2 GA ppp
openSUSE Leap 42.3
  • ppp >= 2.4.7-7.6
Patchnames:
openSUSE Leap 42.3 GA ppp
openSUSE Tumbleweed
  • ppp >= 2.4.7-7.1
  • ppp-devel >= 2.4.7-7.1
Patchnames:
openSUSE Tumbleweed GA ppp


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 ppp Released
SUSE Linux Enterprise Desktop 10 SP4 ppp Released
SUSE Linux Enterprise Desktop 11 SP1 ppp Released
SUSE Linux Enterprise Desktop 11 SP2 ppp Released
SUSE Linux Enterprise Desktop 11 SP3 ppp Released
SUSE Linux Enterprise Desktop 11 SP4 ppp Released
SUSE Linux Enterprise SDK 11 SP1 ppp Released
SUSE Linux Enterprise SDK 11 SP2 ppp Released
SUSE Linux Enterprise SDK 11 SP3 ppp Released
SUSE Linux Enterprise SDK 11 SP4 ppp Released
SUSE Linux Enterprise Server 10 SP3 ppp Released
SUSE Linux Enterprise Server 10 SP4 ppp Released
SUSE Linux Enterprise Server 10 SP4 LTSS ppp Released
SUSE Linux Enterprise Server 11 SP1 ppp Released
SUSE Linux Enterprise Server 11 SP1 LTSS ppp Released
SUSE Linux Enterprise Server 11 SP2 ppp Released
SUSE Linux Enterprise Server 11 SP2 LTSS ppp Released
SUSE Linux Enterprise Server 11 SP3 ppp Released
SUSE Linux Enterprise Server 11 SP3 LTSS ppp Released
SUSE Linux Enterprise Server 11 SP4 ppp Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 ppp Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ppp Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ppp Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 ppp Released
SUSE Linux Enterprise Server for VMWare 11 SP2 ppp Released
SUSE Linux Enterprise Server for VMWare 11 SP3 ppp Released